[package] update alsa-lib to 1.0.20 (#5365)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16509 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f9ba66bd07
commit
9de0b325f2
@ -8,14 +8,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=alsa-lib
|
PKG_NAME:=alsa-lib
|
||||||
PKG_VERSION:=1.0.19
|
PKG_VERSION:=1.0.20
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
|
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
|
||||||
http://alsa.cybermirror.org/lib/
|
http://alsa.cybermirror.org/lib/
|
||||||
|
|
||||||
PKG_MD5SUM:=73db3666c211e5fb023bb77450cf430d
|
PKG_MD5SUM:=6e9080ba1faa5d3739d14dd76c62d8dc
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
@ -1,7 +1,6 @@
|
|||||||
diff -ur alsa.old/src/Makefile.in alsa.dev/src/Makefile.in
|
--- a/src/Makefile.in
|
||||||
--- alsa.old/src/Makefile.in 2006-04-19 09:50:27.000000000 +0200
|
+++ b/src/Makefile.in
|
||||||
+++ alsa.dev/src/Makefile.in 2006-10-14 17:16:10.000000000 +0200
|
@@ -387,7 +387,7 @@ clean-libLTLIBRARIES:
|
||||||
@@ -360,7 +360,7 @@
|
|
||||||
rm -f "$${dir}/so_locations"; \
|
rm -f "$${dir}/so_locations"; \
|
||||||
done
|
done
|
||||||
libasound.la: $(libasound_la_OBJECTS) $(libasound_la_DEPENDENCIES)
|
libasound.la: $(libasound_la_OBJECTS) $(libasound_la_DEPENDENCIES)
|
||||||
@ -10,10 +9,9 @@ diff -ur alsa.old/src/Makefile.in alsa.dev/src/Makefile.in
|
|||||||
|
|
||||||
mostlyclean-compile:
|
mostlyclean-compile:
|
||||||
-rm -f *.$(OBJEXT)
|
-rm -f *.$(OBJEXT)
|
||||||
diff -ur alsa.old/src/pcm/scopes/Makefile.in alsa.dev/src/pcm/scopes/Makefile.in
|
--- a/src/pcm/scopes/Makefile.in
|
||||||
--- alsa.old/src/pcm/scopes/Makefile.in 2006-04-19 09:50:38.000000000 +0200
|
+++ b/src/pcm/scopes/Makefile.in
|
||||||
+++ alsa.dev/src/pcm/scopes/Makefile.in 2006-10-14 17:16:38.000000000 +0200
|
@@ -341,7 +341,7 @@ clean-pkglibLTLIBRARIES:
|
||||||
@@ -317,7 +317,7 @@
|
|
||||||
rm -f "$${dir}/so_locations"; \
|
rm -f "$${dir}/so_locations"; \
|
||||||
done
|
done
|
||||||
scope-level.la: $(scope_level_la_OBJECTS) $(scope_level_la_DEPENDENCIES)
|
scope-level.la: $(scope_level_la_OBJECTS) $(scope_level_la_DEPENDENCIES)
|
||||||
|
@ -1,53 +0,0 @@
|
|||||||
From: Takashi Iwai <tiwai@suse.de>
|
|
||||||
Date: Wed, 21 Jan 2009 08:25:48 +0000 (+0100)
|
|
||||||
Subject: Fix build with softfloat option
|
|
||||||
X-Git-Url: http://git.alsa-project.org/?p=alsa-lib.git;a=commitdiff_plain;h=a789b66d00644eeeb72fd424d686c7fe8faa5daa
|
|
||||||
|
|
||||||
Fix build with softfloat option
|
|
||||||
|
|
||||||
Fix build of alsa-lib when --with-softfloat is used:
|
|
||||||
- disable ladspa plugin
|
|
||||||
- don't use sqrt() function
|
|
||||||
|
|
||||||
Signed-off-by: Takashi Iwai <tiwai@suse.de>
|
|
||||||
---
|
|
||||||
|
|
||||||
diff --git a/configure.in b/configure.in
|
|
||||||
index 9a71d95..ea6a8a0 100644
|
|
||||||
--- a/configure.in
|
|
||||||
+++ b/configure.in
|
|
||||||
@@ -367,6 +367,7 @@ AC_ARG_ENABLE(seq,
|
|
||||||
AC_ARG_ENABLE(alisp,
|
|
||||||
AS_HELP_STRING([--disable-alisp], [disable the alisp component]),
|
|
||||||
[build_alisp="$enableval"], [build_alisp="yes"])
|
|
||||||
+test "$softfloat" = "yes" && build_alisp="no"
|
|
||||||
AC_ARG_ENABLE(old-symbols,
|
|
||||||
AS_HELP_STRING([--disable-old-symbols], [disable old obsoleted symbols]),
|
|
||||||
[keep_old_symbols="$enableval"], [keep_old_symbols="yes"])
|
|
||||||
@@ -474,6 +475,7 @@ fi
|
|
||||||
|
|
||||||
if test "$softfloat" = "yes"; then
|
|
||||||
build_pcm_lfloat="no"
|
|
||||||
+ build_pcm_ladspa="no"
|
|
||||||
fi
|
|
||||||
|
|
||||||
AM_CONDITIONAL(BUILD_PCM_PLUGIN, test x$build_pcm_plugin = xyes)
|
|
||||||
diff --git a/src/mixer/simple_none.c b/src/mixer/simple_none.c
|
|
||||||
index 0f4dd3a..4802200 100644
|
|
||||||
--- a/src/mixer/simple_none.c
|
|
||||||
+++ b/src/mixer/simple_none.c
|
|
||||||
@@ -1450,7 +1450,14 @@ static int simple_add1(snd_mixer_class_t *class, const char *name,
|
|
||||||
}
|
|
||||||
if (ctype != SND_CTL_ELEM_TYPE_BOOLEAN)
|
|
||||||
return 0;
|
|
||||||
+#ifdef HAVE_SOFT_FLOAT
|
|
||||||
+ /* up to 256 channels */
|
|
||||||
+ for (n = 1; n < 256; n++)
|
|
||||||
+ if (n * n == values)
|
|
||||||
+ break;
|
|
||||||
+#else
|
|
||||||
n = sqrt((double)values);
|
|
||||||
+#endif
|
|
||||||
if (n * n != values)
|
|
||||||
return 0;
|
|
||||||
values = n;
|
|
@ -1,28 +0,0 @@
|
|||||||
From: Takashi Iwai <tiwai@suse.de>
|
|
||||||
Date: Wed, 21 Jan 2009 08:29:35 +0000 (+0100)
|
|
||||||
Subject: Add missing -ldl to modules/mixer/simple/*
|
|
||||||
X-Git-Url: http://git.alsa-project.org/?p=alsa-lib.git;a=commitdiff_plain;h=3b728db20d1729f1270731006f44c20ab910bee0
|
|
||||||
|
|
||||||
Add missing -ldl to modules/mixer/simple/*
|
|
||||||
|
|
||||||
Signed-off-by: Takashi Iwai <tiwai@suse.de>
|
|
||||||
---
|
|
||||||
|
|
||||||
diff --git a/modules/mixer/simple/Makefile.am b/modules/mixer/simple/Makefile.am
|
|
||||||
index f73871f..bad0944 100644
|
|
||||||
--- a/modules/mixer/simple/Makefile.am
|
|
||||||
+++ b/modules/mixer/simple/Makefile.am
|
|
||||||
@@ -21,11 +21,11 @@ smixer_sbase_la_LIBADD = ../../../src/libasound.la
|
|
||||||
|
|
||||||
smixer_ac97_la_SOURCES = ac97.c sbasedl.c
|
|
||||||
smixer_ac97_la_LDFLAGS = -module -avoid-version $(LDFLAGS_NOUNDEFINED)
|
|
||||||
-smixer_ac97_la_LIBADD = ../../../src/libasound.la
|
|
||||||
+smixer_ac97_la_LIBADD = ../../../src/libasound.la -ldl
|
|
||||||
|
|
||||||
smixer_hda_la_SOURCES = hda.c sbasedl.c
|
|
||||||
smixer_hda_la_LDFLAGS = -module -avoid-version $(LDFLAGS_NOUNDEFINED)
|
|
||||||
-smixer_hda_la_LIBADD = ../../../src/libasound.la
|
|
||||||
+smixer_hda_la_LIBADD = ../../../src/libasound.la -ldl
|
|
||||||
|
|
||||||
if BUILD_PYTHON
|
|
||||||
smixer_python_la_SOURCES = python.c
|
|
Loading…
x
Reference in New Issue
Block a user