lame: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41904 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c451f59dfc
commit
9e8bb769ff
@ -1,82 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2007-2008 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
# blogic@openwrt.org
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=lame
|
|
||||||
PKG_VERSION:=398-2
|
|
||||||
PKG_RELEASE:=3
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=@SF/lame
|
|
||||||
PKG_MD5SUM:=719dae0ee675d0c16e0e89952930ed35
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
|
|
||||||
PKG_LICENSE:=LGPLv2
|
|
||||||
PKG_LICENSE_FILES:=COPYING LICENSE
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
PKG_INSTALL=1
|
|
||||||
|
|
||||||
define Package/lame/Default
|
|
||||||
SECTION:=sound
|
|
||||||
CATEGORY:=Sound
|
|
||||||
URL:=http://sourceforge.net/projects/lame
|
|
||||||
DEPENDS:=@BUILD_PATENTED
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/lame
|
|
||||||
$(call Package/lame/Default)
|
|
||||||
TITLE:=lame
|
|
||||||
MENU:=1
|
|
||||||
DEPENDS += +libncurses
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/lame/description
|
|
||||||
lame mp3 encoder
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/lame-lib
|
|
||||||
$(call Package/lame/Default)
|
|
||||||
TITLE:=lame-lib
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/lame-lib/description
|
|
||||||
lame mp3 encoder libs
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
$(call Build/Configure/Default, \
|
|
||||||
--disable-nasm \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
|
|
||||||
define Package/lame/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lame $(1)/usr/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/lame-lib/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include/lame
|
|
||||||
$(INSTALL_DATA) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/include/lame/*.h \
|
|
||||||
$(1)/usr/include/lame/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/*.{la,so*} \
|
|
||||||
$(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,lame-lib))
|
|
||||||
$(eval $(call BuildPackage,lame))
|
|
@ -1,33 +0,0 @@
|
|||||||
--- a/configure.in
|
|
||||||
+++ b/configure.in
|
|
||||||
@@ -385,7 +385,7 @@ CONFIG_MATH_LIB="${USE_LIBM}"
|
|
||||||
|
|
||||||
dnl configure use of features
|
|
||||||
|
|
||||||
-AM_PATH_GTK(1.2.0, HAVE_GTK="yes", HAVE_GTK="no")
|
|
||||||
+HAVE_GTK="no"
|
|
||||||
|
|
||||||
dnl ElectricFence malloc debugging
|
|
||||||
AC_MSG_CHECKING(use of ElectricFence malloc debugging)
|
|
||||||
--- a/frontend/Makefile.am
|
|
||||||
+++ b/frontend/Makefile.am
|
|
||||||
@@ -51,7 +51,7 @@ mp3rtp_SOURCES = mp3rtp.c rtp.c rtp.h $(
|
|
||||||
mp3x_SOURCES = mp3x.c gtkanal.c gpkplotting.c $(common_sources)
|
|
||||||
endif
|
|
||||||
|
|
||||||
-CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
|
|
||||||
+CFLAGS = @CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
|
|
||||||
LDFLAGS = @LDFLAGS@ @FRONTEND_LDFLAGS@ @SNDFILE_LIBS@ -static
|
|
||||||
|
|
||||||
INCLUDES = -I$(top_srcdir)/libmp3lame -I$(top_srcdir)/include -I$(top_builddir)
|
|
||||||
--- a/frontend/Makefile.in
|
|
||||||
+++ b/frontend/Makefile.in
|
|
||||||
@@ -113,7 +113,7 @@ AUTOMAKE = @AUTOMAKE@
|
|
||||||
AWK = @AWK@
|
|
||||||
CC = @CC@
|
|
||||||
CCDEPMODE = @CCDEPMODE@
|
|
||||||
-CFLAGS = @CFLAGS@ @GTK_CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
|
|
||||||
+CFLAGS = @CFLAGS@ @FRONTEND_CFLAGS@ @SNDFILE_CFLAGS@
|
|
||||||
CONFIG_DEFS = @CONFIG_DEFS@
|
|
||||||
CONFIG_MATH_LIB = @CONFIG_MATH_LIB@
|
|
||||||
CPP = @CPP@
|
|
Loading…
x
Reference in New Issue
Block a user