Upgrade jamvm to 1.4.4 (#1030)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@5743 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-12-09 20:29:01 +00:00
parent c326b97dfc
commit 9f5e93c52d
3 changed files with 119 additions and 94 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=jamvm PKG_NAME:=jamvm
PKG_VERSION:=1.4.1 PKG_VERSION:=1.4.4
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/jamvm PKG_SOURCE_URL:=@SF/jamvm
PKG_MD5SUM:=ed79d6b60e50b007614831f8c28321ac PKG_MD5SUM:=1b7bc9928c534412e062685a4191651d
PKG_CAT:=zcat PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@ -40,6 +40,7 @@ endef
define Build/Configure define Build/Configure
$(call Build/Configure/Default, \ $(call Build/Configure/Default, \
--enable-ffi \ --enable-ffi \
--disable-int-threading \
) )
endef endef

View File

@ -1,73 +1,73 @@
diff -urN jamvm-1.4.0-orig/configure jamvm-1.4.0/configure diff -urN jamvm-1.4.4/configure jamvm-1.4.4.new/configure
--- jamvm-1.4.0-orig/configure 2005-11-20 08:18:52.000000000 +0100 --- jamvm-1.4.4/configure 2006-11-01 00:07:51.000000000 +0100
+++ jamvm-1.4.0/configure 2005-11-27 17:02:15.000000000 +0100 +++ jamvm-1.4.4.new/configure 2006-12-09 21:02:52.000000000 +0100
@@ -1934,6 +1934,7 @@ @@ -2035,6 +2035,7 @@
i[456]86-*-openbsd*) host_cpu=i386 host_os=linux libdl_needed=no ;;
x86_64-*-linux*) host_os=linux ;;
arm*-*-linux*) host_cpu=arm host_os=linux ;; arm*-*-linux*) host_cpu=arm host_os=linux ;;
arm*-*-openbsd*) host_cpu=arm host_os=bsd libdl_needed=no ;;
arm*-*-freebsd*) host_cpu=arm host_os=bsd libdl_needed=no ;;
+mips*-linux*) host_cpu=mips host_os=linux ;; +mips*-linux*) host_cpu=mips host_os=linux ;;
powerpc*-*-linux*) host_cpu=powerpc host_os=linux ;; powerpc*-*-linux*) host_cpu=powerpc host_os=linux ;;
powerpc-*-darwin*) host_os=darwin ;; powerpc*-*-openbsd*) host_cpu=powerpc host_os=bsd libdl_needed=no ;;
*) { { echo "$as_me:$LINENO: error: $host not supported" >&5 powerpc*-*-freebsd*) host_cpu=powerpc host_os=bsd libdl_needed=no ;;
@@ -5742,7 +5743,7 @@ @@ -22949,7 +22950,7 @@
ac_config_links="$ac_config_links src/arch.h:src/arch/$arch.h" ac_config_links="$ac_config_links src/arch.h:src/arch/$arch.h"
- ac_config_files="$ac_config_files Makefile src/Makefile src/arch/Makefile src/os/Makefile src/os/linux/Makefile src/os/darwin/Makefile src/os/linux/powerpc/Makefile src/os/linux/arm/Makefile src/os/linux/i386/Makefile src/os/linux/x86_64/Makefile src/os/darwin/powerpc/Makefile lib/Makefile lib/java/Makefile lib/java/lang/Makefile lib/jamvm/Makefile lib/jamvm/java/Makefile lib/jamvm/java/lang/Makefile lib/java/lang/reflect/Makefile lib/java/security/Makefile lib/gnu/Makefile lib/gnu/classpath/Makefile" - ac_config_files="$ac_config_files Makefile src/Makefile src/arch/Makefile src/os/Makefile src/os/linux/Makefile src/os/darwin/Makefile src/os/bsd/Makefile src/os/linux/powerpc/Makefile src/os/linux/arm/Makefile src/os/linux/i386/Makefile src/os/linux/x86_64/Makefile src/os/linux/parisc/Makefile src/os/darwin/i386/Makefile src/os/darwin/powerpc/Makefile src/os/bsd/powerpc/Makefile src/os/bsd/arm/Makefile src/os/bsd/i386/Makefile src/os/bsd/x86_64/Makefile lib/Makefile lib/java/Makefile lib/java/lang/Makefile lib/jamvm/Makefile lib/jamvm/java/Makefile lib/jamvm/java/lang/Makefile lib/java/lang/reflect/Makefile lib/java/security/Makefile lib/gnu/Makefile lib/gnu/classpath/Makefile"
+ ac_config_files="$ac_config_files Makefile src/Makefile src/arch/Makefile src/os/Makefile src/os/linux/Makefile src/os/darwin/Makefile src/os/linux/powerpc/Makefile src/os/linux/arm/Makefile src/os/linux/i386/Makefile src/os/linux/x86_64/Makefile src/os/linux/mips/Makefile src/os/darwin/powerpc/Makefile lib/Makefile lib/java/Makefile lib/java/lang/Makefile lib/jamvm/Makefile lib/jamvm/java/Makefile lib/jamvm/java/lang/Makefile lib/java/lang/reflect/Makefile lib/java/security/Makefile lib/gnu/Makefile lib/gnu/classpath/Makefile" + ac_config_files="$ac_config_files Makefile src/Makefile src/arch/Makefile src/os/Makefile src/os/linux/Makefile src/os/darwin/Makefile src/os/bsd/Makefile src/os/linux/powerpc/Makefile src/os/linux/arm/Makefile src/os/linux/i386/Makefile src/os/linux/x86_64/Makefile src/os/linux/mips/Makefile src/os/linux/parisc/Makefile src/os/darwin/i386/Makefile src/os/darwin/powerpc/Makefile src/os/bsd/powerpc/Makefile src/os/bsd/arm/Makefile src/os/bsd/i386/Makefile src/os/bsd/x86_64/Makefile lib/Makefile lib/java/Makefile lib/java/lang/Makefile lib/jamvm/Makefile lib/jamvm/java/Makefile lib/jamvm/java/lang/Makefile lib/java/lang/reflect/Makefile lib/java/security/Makefile lib/gnu/Makefile lib/gnu/classpath/Makefile"
cat >confcache <<\_ACEOF cat >confcache <<\_ACEOF
@@ -6340,6 +6341,7 @@ @@ -23537,6 +23538,7 @@
"src/os/linux/arm/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/arm/Makefile" ;;
"src/os/linux/i386/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/i386/Makefile" ;; "src/os/linux/i386/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/i386/Makefile" ;;
"src/os/linux/x86_64/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/x86_64/Makefile" ;; "src/os/linux/x86_64/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/x86_64/Makefile" ;;
"src/os/linux/parisc/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/parisc/Makefile" ;;
+ "src/os/linux/mips/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/mips/Makefile" ;; + "src/os/linux/mips/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/linux/mips/Makefile" ;;
"src/os/darwin/i386/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/darwin/i386/Makefile" ;;
"src/os/darwin/powerpc/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/darwin/powerpc/Makefile" ;; "src/os/darwin/powerpc/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/darwin/powerpc/Makefile" ;;
"lib/Makefile" ) CONFIG_FILES="$CONFIG_FILES lib/Makefile" ;; "src/os/bsd/powerpc/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/os/bsd/powerpc/Makefile" ;;
"lib/java/Makefile" ) CONFIG_FILES="$CONFIG_FILES lib/java/Makefile" ;; diff -urN jamvm-1.4.4/configure.ac jamvm-1.4.4.new/configure.ac
diff -urN jamvm-1.4.0-orig/configure.ac jamvm-1.4.0/configure.ac --- jamvm-1.4.4/configure.ac 2006-11-01 00:06:11.000000000 +0100
--- jamvm-1.4.0-orig/configure.ac 2005-11-20 08:18:33.000000000 +0100 +++ jamvm-1.4.4.new/configure.ac 2006-12-09 21:03:31.000000000 +0100
+++ jamvm-1.4.0/configure.ac 2005-11-27 16:29:53.000000000 +0100 @@ -15,6 +15,7 @@
@@ -60,6 +60,7 @@ hppa*-*-linux*) host_cpu=parisc host_os=linux ;;
i[[456]]86-*-openbsd*) host_cpu=i386 host_os=linux libdl_needed=no ;; amd64-*-openbsd*) host_os=bsd libdl_needed=no ;;
x86_64-*-linux*) host_os=linux ;; amd64-*-freebsd*) host_os=bsd libdl_needed=no ;;
arm*-*-linux*) host_cpu=arm host_os=linux ;;
+mips*-linux*) host_cpu=mips host_os=linux ;; +mips*-linux*) host_cpu=mips host_os=linux ;;
powerpc*-*-linux*) host_cpu=powerpc host_os=linux ;; arm*-*-linux*) host_cpu=arm host_os=linux ;;
powerpc-*-darwin*) host_os=darwin ;; arm*-*-openbsd*) host_cpu=arm host_os=bsd libdl_needed=no ;;
*) AC_MSG_ERROR($host not supported) ;; arm*-*-freebsd*) host_cpu=arm host_os=bsd libdl_needed=no ;;
@@ -202,6 +203,7 @@ @@ -229,6 +230,7 @@
src/os/linux/arm/Makefile \
src/os/linux/i386/Makefile \ src/os/linux/i386/Makefile \
src/os/linux/x86_64/Makefile \ src/os/linux/x86_64/Makefile \
src/os/linux/parisc/Makefile \
+ src/os/linux/mips/Makefile \ + src/os/linux/mips/Makefile \
src/os/darwin/i386/Makefile \
src/os/darwin/powerpc/Makefile \ src/os/darwin/powerpc/Makefile \
lib/Makefile \ src/os/bsd/powerpc/Makefile \
lib/java/Makefile \ diff -urN jamvm-1.4.4/src/arch/Makefile.am jamvm-1.4.4.new/src/arch/Makefile.am
diff -urN jamvm-1.4.0-orig/src/arch/Makefile.am jamvm-1.4.0/src/arch/Makefile.am --- jamvm-1.4.4/src/arch/Makefile.am 2006-10-23 02:35:11.000000000 +0200
--- jamvm-1.4.0-orig/src/arch/Makefile.am 2005-09-05 02:02:58.000000000 +0200 +++ jamvm-1.4.4.new/src/arch/Makefile.am 2006-12-09 21:03:51.000000000 +0100
+++ jamvm-1.4.0/src/arch/Makefile.am 2005-11-24 23:09:02.000000000 +0100
@@ -1,3 +1,3 @@ @@ -1,3 +1,3 @@
# used by automake to generate Makefile.in # used by automake to generate Makefile.in
-EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h -EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h parisc.h
+EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h mips.h +EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h parisc.h mips.h
diff -urN jamvm-1.4.0-orig/src/arch/Makefile.in jamvm-1.4.0/src/arch/Makefile.in diff -urN jamvm-1.4.4/src/arch/Makefile.in jamvm-1.4.4.new/src/arch/Makefile.in
--- jamvm-1.4.0-orig/src/arch/Makefile.in 2005-11-20 08:18:49.000000000 +0100 --- jamvm-1.4.4/src/arch/Makefile.in 2006-11-03 02:47:53.000000000 +0100
+++ jamvm-1.4.0/src/arch/Makefile.in 2005-11-27 17:04:08.000000000 +0100 +++ jamvm-1.4.4.new/src/arch/Makefile.in 2006-12-09 21:04:54.000000000 +0100
@@ -141,7 +141,7 @@ @@ -158,7 +158,7 @@
use_zip_no = @use_zip_no@ use_zip_no = @use_zip_no@
use_zip_yes = @use_zip_yes@ use_zip_yes = @use_zip_yes@
with_classpath_install_dir = @with_classpath_install_dir@ with_classpath_install_dir = @with_classpath_install_dir@
-EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h -EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h parisc.h
+EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h mips.h +EXTRA_DIST = powerpc.h arm.h i386.h x86_64.h parisc.h mips.h
all: all-am all: all-am
.SUFFIXES: .SUFFIXES:
diff -urN jamvm-1.4.0-orig/src/arch/mips.h jamvm-1.4.0/src/arch/mips.h diff -urN jamvm-1.4.4/src/arch/mips.h jamvm-1.4.4.new/src/arch/mips.h
--- jamvm-1.4.0-orig/src/arch/mips.h 1970-01-01 01:00:00.000000000 +0100 --- jamvm-1.4.4/src/arch/mips.h 1970-01-01 01:00:00.000000000 +0100
+++ jamvm-1.4.0/src/arch/mips.h 2005-11-29 22:31:08.000000000 +0100 +++ jamvm-1.4.4.new/src/arch/mips.h 2006-12-09 21:05:27.000000000 +0100
@@ -0,0 +1,69 @@ @@ -0,0 +1,69 @@
+/* +/*
+ * Copyright (C) 2003, 2004, 2005 Robert Lougher <rob@lougher.demon.co.uk>. + * Copyright (C) 2003, 2004, 2005 Robert Lougher <rob@lougher.demon.co.uk>.
@ -138,66 +138,39 @@ diff -urN jamvm-1.4.0-orig/src/arch/mips.h jamvm-1.4.0/src/arch/mips.h
+#define JMM_LOCK_MBARRIER() __asm__ __volatile__ ("" ::: "memory") +#define JMM_LOCK_MBARRIER() __asm__ __volatile__ ("" ::: "memory")
+#define JMM_UNLOCK_MBARRIER() __asm__ __volatile__ ("" ::: "memory") +#define JMM_UNLOCK_MBARRIER() __asm__ __volatile__ ("" ::: "memory")
+ +
diff -urN jamvm-1.4.0-orig/src/os/linux/Makefile.am jamvm-1.4.0/src/os/linux/Makefile.am diff -urN jamvm-1.4.4/src/os/linux/Makefile.am jamvm-1.4.4.new/src/os/linux/Makefile.am
--- jamvm-1.4.0-orig/src/os/linux/Makefile.am 2005-09-08 22:53:16.000000000 +0200 --- jamvm-1.4.4/src/os/linux/Makefile.am 2006-10-23 02:07:10.000000000 +0200
+++ jamvm-1.4.0/src/os/linux/Makefile.am 2005-11-24 23:05:44.000000000 +0100 +++ jamvm-1.4.4.new/src/os/linux/Makefile.am 2006-12-09 21:04:13.000000000 +0100
@@ -1,5 +1,5 @@ @@ -1,5 +1,5 @@
SUBDIRS = @arch@ SUBDIRS = @arch@
-DIST_SUBDIRS = powerpc arm i386 x86_64 -DIST_SUBDIRS = powerpc arm i386 x86_64 parisc
+DIST_SUBDIRS = powerpc arm i386 x86_64 mips +DIST_SUBDIRS = powerpc arm i386 x86_64 parisc mips
noinst_LIBRARIES = libos.a noinst_LTLIBRARIES = libos.la
libos_a_SOURCES = dll_os.c libos_la_SOURCES = os.c
diff -urN jamvm-1.4.0-orig/src/os/linux/Makefile.in jamvm-1.4.0/src/os/linux/Makefile.in diff -urN jamvm-1.4.4/src/os/linux/Makefile.in jamvm-1.4.4.new/src/os/linux/Makefile.in
--- jamvm-1.4.0-orig/src/os/linux/Makefile.in 2005-11-20 08:18:50.000000000 +0100 --- jamvm-1.4.4/src/os/linux/Makefile.in 2006-11-03 02:47:58.000000000 +0100
+++ jamvm-1.4.0/src/os/linux/Makefile.in 2005-11-27 17:04:10.000000000 +0100 +++ jamvm-1.4.4.new/src/os/linux/Makefile.in 2006-12-09 21:04:43.000000000 +0100
@@ -163,7 +163,7 @@ @@ -181,7 +181,7 @@
use_zip_yes = @use_zip_yes@ use_zip_yes = @use_zip_yes@
with_classpath_install_dir = @with_classpath_install_dir@ with_classpath_install_dir = @with_classpath_install_dir@
SUBDIRS = @arch@ SUBDIRS = @arch@
-DIST_SUBDIRS = powerpc arm i386 x86_64 -DIST_SUBDIRS = powerpc arm i386 x86_64 parisc
+DIST_SUBDIRS = powerpc arm i386 x86_64 mips +DIST_SUBDIRS = powerpc arm i386 x86_64 parisc mips
noinst_LIBRARIES = libos.a noinst_LTLIBRARIES = libos.la
libos_a_SOURCES = dll_os.c libos_la_SOURCES = os.c
EXTRA_DIST = dll_os.c AM_CPPFLAGS = -I$(top_builddir)/src
diff -urN jamvm-1.4.0-orig/src/os/linux/mips/init.c jamvm-1.4.0/src/os/linux/mips/init.c diff -urN jamvm-1.4.4/src/os/linux/mips/Makefile.am jamvm-1.4.4.new/src/os/linux/mips/Makefile.am
--- jamvm-1.4.0-orig/src/os/linux/mips/init.c 1970-01-01 01:00:00.000000000 +0100 --- jamvm-1.4.4/src/os/linux/mips/Makefile.am 1970-01-01 01:00:00.000000000 +0100
+++ jamvm-1.4.0/src/os/linux/mips/init.c 2005-11-02 22:42:21.000000000 +0100 +++ jamvm-1.4.4.new/src/os/linux/mips/Makefile.am 2006-12-09 21:05:27.000000000 +0100
@@ -0,0 +1,23 @@
+/*
+ * Copyright (C) 2003, 2004 Robert Lougher <rob@lougher.demon.co.uk>.
+ *
+ * This file is part of JamVM.
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2,
+ * or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+ */
+
+void initialisePlatform() {
+ /* Nothing to do for mips */
+}
diff -urN jamvm-1.4.0-orig/src/os/linux/mips/Makefile.am jamvm-1.4.0/src/os/linux/mips/Makefile.am
--- jamvm-1.4.0-orig/src/os/linux/mips/Makefile.am 1970-01-01 01:00:00.000000000 +0100
+++ jamvm-1.4.0/src/os/linux/mips/Makefile.am 2005-09-05 02:03:01.000000000 +0200
@@ -0,0 +1,4 @@ @@ -0,0 +1,4 @@
+noinst_LIBRARIES = libnative.a +noinst_LIBRARIES = libnative.a
+libnative_a_SOURCES = init.c +libnative_a_SOURCES = init.c
+ +
+AM_CPPFLAGS = -I$(top_builddir)/src +AM_CPPFLAGS = -I$(top_builddir)/src
diff -urN jamvm-1.4.0-orig/src/os/linux/mips/Makefile.in jamvm-1.4.0/src/os/linux/mips/Makefile.in diff -urN jamvm-1.4.4/src/os/linux/mips/Makefile.in jamvm-1.4.4.new/src/os/linux/mips/Makefile.in
--- jamvm-1.4.0-orig/src/os/linux/mips/Makefile.in 1970-01-01 01:00:00.000000000 +0100 --- jamvm-1.4.4/src/os/linux/mips/Makefile.in 1970-01-01 01:00:00.000000000 +0100
+++ jamvm-1.4.0/src/os/linux/mips/Makefile.in 2005-11-27 17:04:11.000000000 +0100 +++ jamvm-1.4.4.new/src/os/linux/mips/Makefile.in 2006-12-09 21:05:27.000000000 +0100
@@ -0,0 +1,391 @@ @@ -0,0 +1,391 @@
+# Makefile.in generated by automake 1.9.6 from Makefile.am. +# Makefile.in generated by automake 1.9.6 from Makefile.am.
+# @configure_input@ +# @configure_input@
@ -590,3 +563,30 @@ diff -urN jamvm-1.4.0-orig/src/os/linux/mips/Makefile.in jamvm-1.4.0/src/os/linu
+# Tell versions [3.59,3.63) of GNU make to not export all variables. +# Tell versions [3.59,3.63) of GNU make to not export all variables.
+# Otherwise a system limit (for SysV at least) may be exceeded. +# Otherwise a system limit (for SysV at least) may be exceeded.
+.NOEXPORT: +.NOEXPORT:
diff -urN jamvm-1.4.4/src/os/linux/mips/init.c jamvm-1.4.4.new/src/os/linux/mips/init.c
--- jamvm-1.4.4/src/os/linux/mips/init.c 1970-01-01 01:00:00.000000000 +0100
+++ jamvm-1.4.4.new/src/os/linux/mips/init.c 2006-12-09 21:05:27.000000000 +0100
@@ -0,0 +1,23 @@
+/*
+ * Copyright (C) 2003, 2004 Robert Lougher <rob@lougher.demon.co.uk>.
+ *
+ * This file is part of JamVM.
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2,
+ * or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+ */
+
+void initialisePlatform() {
+ /* Nothing to do for mips */
+}

View File

@ -0,0 +1,24 @@
--- jamvm-1.4.4/src/os/linux/os.c 2006-10-29 23:56:43.000000000 +0100
+++ jamvm-1.4.4.new/src/os/linux/os.c 2006-12-09 21:17:43.000000000 +0100
@@ -31,15 +31,18 @@
pthread_attr_t attr;
void *addr;
int size;
-
+#if 0
+/* Not implemented in uClibc yet */
pthread_getattr_np(pthread_self(), &attr);
- pthread_attr_getstack(&attr, &addr, &size);
+#endif
+ pthread_attr_getstackaddr(&attr, &addr);
return addr+size;
}
int nativeAvailableProcessors() {
- return get_nprocs();
+/* We assume embedded systems concerned are mono-processor only */
+ return 1;
}
char *nativeLibPath() {