netperf: Update build file to v2.6.0, pass --enable-demo to configure.
This makes this version of netperf work with the netperf-wrapper testing tool used for testing for bufferbloat. Patch by: Toke Høiland-Jørgensen <toke@toke.dk> git-svn-id: svn://svn.openwrt.org/openwrt/packages@36341 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
58262c6392
commit
9ff7875519
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=netperf
|
||||
PKG_VERSION:=2.4.5
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.6.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.netperf.org/netperf/
|
||||
PKG_MD5SUM:=5cfaae1d024551161b8eafbd48faedf4
|
||||
PKG_MD5SUM:=9654ffdfd4c4f2c93ce3733cd9ed9236
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -24,6 +24,8 @@ define Package/netperf
|
||||
URL:=http://www.netperf.org/
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += --enable-demo
|
||||
|
||||
define Package/netperf/install
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/netserver.init $(1)/etc/init.d/netserver
|
||||
|
@ -1,38 +0,0 @@
|
||||
[PATCH] fix build on systems where IPROTO_DCCP is defined, but SOCK_DCCP isn't
|
||||
|
||||
On some systems (E.G. uClibc 0.9.31) IPROTO_DCCP is defined, but SOCK_DCCP
|
||||
isn't - Causing the build to break. Fix it by checking for both before
|
||||
using.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
---
|
||||
src/netsh.c | 2 +-
|
||||
src/nettest_bsd.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
Index: netperf-2.4.5/src/netsh.c
|
||||
===================================================================
|
||||
--- netperf-2.4.5.orig/src/netsh.c
|
||||
+++ netperf-2.4.5/src/netsh.c
|
||||
@@ -452,7 +452,7 @@ parse_protocol(char protocol_string[])
|
||||
return IPPROTO_SDP;
|
||||
}
|
||||
#endif
|
||||
-#ifdef IPPROTO_DCCP
|
||||
+#if defined(IPPROTO_DCCP) && defined(SOCK_DCCP)
|
||||
if (!strcasecmp(temp,"dccp")) {
|
||||
socket_type = SOCK_DCCP;
|
||||
return IPPROTO_DCCP;
|
||||
Index: netperf-2.4.5/src/nettest_bsd.c
|
||||
===================================================================
|
||||
--- netperf-2.4.5.orig/src/nettest_bsd.c
|
||||
+++ netperf-2.4.5/src/nettest_bsd.c
|
||||
@@ -712,7 +712,7 @@ complete_addrinfo(char *controlhost, cha
|
||||
that we did this so the code for the Solaris kludge can do
|
||||
the fix-up for us. also flip error over to EAI_AGAIN and
|
||||
make sure we don't "count" this time around the loop. */
|
||||
-#if defined(IPPROTO_DCCP)
|
||||
+#if defined(IPPROTO_DCCP) && defined(SOCK_DCCP)
|
||||
/* only tweak on this one the second time around, after we've
|
||||
kludged the ai_protocol field */
|
||||
if ((hints.ai_socktype == SOCK_DCCP) &&
|
Loading…
x
Reference in New Issue
Block a user