[packages] appweb: update to 3.2.2-1 (closes: #6979), add dependency on libpthread, cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22469 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
2e84576340
commit
a060772ba0
@ -1,12 +1,12 @@
|
||||
#
|
||||
# Makefile for the Appweb Web Server
|
||||
# Copyright (C) 2009-2010 OpenWrt.org
|
||||
# Copyright (C) 2009 Embedthis Software
|
||||
#
|
||||
# Copyright (C) 2009 Embedthis Software
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# This software is licensed under the GPLv2. Commercial and other licenses
|
||||
# are available from http://www.embedthis.com.
|
||||
# Commercial and other licenses are available from http://www.embedthis.com/.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
@ -14,41 +14,42 @@ PKG_NAME:=appweb
|
||||
PKG_RELEASE:=1
|
||||
|
||||
#
|
||||
# Build 3.0B.3
|
||||
# Build stable
|
||||
#
|
||||
PKG_SOURCE_URL:=http://www.appwebserver.org/software/
|
||||
PKG_VERSION:=3.0B.2-3
|
||||
PKG_MD5SUM:=b54a99d388a5588a9af33aa1c6354e06
|
||||
PKG_VERSION:=3.2.2-1
|
||||
PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.appwebserver.org/software/
|
||||
PKG_MD5SUM:=060d43c8194fa6a119cada966fc807a7
|
||||
|
||||
#
|
||||
# Build the latest snapshot from the default trunk
|
||||
#
|
||||
# PKG_SOURCE:=tip.tar.gz
|
||||
# PKG_SOURCE_URL:= http://hg.embedthis.com/appweb/archive/
|
||||
# PKG_VERSION:=default
|
||||
# PKG_MD5SUM:=
|
||||
#PKG_VERSION:=default
|
||||
#PKG_SOURCE:=tip.tar.gz
|
||||
#PKG_SOURCE_URL:= http://hg.embedthis.com/appweb/archive/
|
||||
#PKG_MD5SUM:=
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
CONFIGURE_ARGS += -q --defaults=release --shared --tune=size --without-php \
|
||||
--without-ssl --disable-angel --disable-samples --disable-access-log \
|
||||
--disable-complete-native --disable-complete-cross --webdir=/www \
|
||||
--logdir=/var/log --port=8000 --sslPort=8443 --config=flat
|
||||
|
||||
define Package/appweb
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=Appweb Web Server
|
||||
VERSION:=$(PKG_VERSION)
|
||||
URL:=http://www.appwebserver.org/
|
||||
DEPENDS:=@!avr32
|
||||
DEPENDS:=@!avr32 +libpthread
|
||||
endef
|
||||
|
||||
define Package/appweb/description
|
||||
Appweb is a powerful, compact embedded web server designed for dynamic web
|
||||
applications.
|
||||
Appweb is a powerful, compact embedded web server designed for dynamic web
|
||||
applications.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
-q --defaults=release --shared --tune=size --without-php \
|
||||
--without-ssl --disable-angel --disable-samples --disable-access-log \
|
||||
--disable-complete-native --disable-complete-cross --webdir=/www \
|
||||
--logdir=/var/log --port=8000 --sslPort=8443 --config=flat
|
||||
|
||||
define Build/Prepare
|
||||
tar xzf "$(DL_DIR)/$(PKG_SOURCE)" --strip-components 1 -C "$(PKG_BUILD_DIR)"
|
||||
endef
|
||||
@ -68,4 +69,3 @@ define Package/appweb/install
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,appweb))
|
||||
|
||||
|
@ -1,17 +0,0 @@
|
||||
--- a/src/ejs/ejsLib.c
|
||||
+++ b/src/ejs/ejsLib.c
|
||||
@@ -21544,11 +21544,13 @@ EjsVar *ejsThrowInternalError(Ejs *ejs,
|
||||
|
||||
EjsVar *ejsThrowMemoryError(Ejs *ejs)
|
||||
{
|
||||
+ va_list fmtArgs;
|
||||
+
|
||||
/*
|
||||
* Don't do double exceptions for memory errors
|
||||
*/
|
||||
if (ejs->exception == 0) {
|
||||
- return ejsCreateException(ejs, ES_MemoryError, 0, 0);
|
||||
+ return ejsCreateException(ejs, ES_MemoryError, NULL, fmtArgs);
|
||||
}
|
||||
return ejs->exception;
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user