[package] add vips library (#7866)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23478 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fec91899af
commit
a0da64f7aa
77
libs/vips/Makefile
Normal file
77
libs/vips/Makefile
Normal file
@ -0,0 +1,77 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2010 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=vips
|
||||||
|
PKG_VERSION:=7.22.4
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://www.vips.ecs.soton.ac.uk/supported/7.22/
|
||||||
|
PKG_MD5SUM:=852913223ce5dc115bc7088e7c9d1596
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
PKG_INSTALL=1
|
||||||
|
|
||||||
|
define Package/vips/Default
|
||||||
|
TITLE:=vips
|
||||||
|
URL:=http://www.vips.ecs.soton.ac.uk/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/vips
|
||||||
|
$(call Package/vips/Default)
|
||||||
|
SECTION:=multimedia
|
||||||
|
CATEGORY:=Multimedia
|
||||||
|
DEPENDS:=+libjpeg +libintl +glib2 +libxml2
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/vips/description
|
||||||
|
An image manipulation library.
|
||||||
|
endef
|
||||||
|
|
||||||
|
TARGET_CFLAGS+= \
|
||||||
|
-I$(STAGING_DIR)/usr/lib/libintl/include
|
||||||
|
|
||||||
|
TARGET_LDFLAGS+= \
|
||||||
|
-L$(STAGING_DIR)/usr/lib/libintl/lib
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
( cd "$(PKG_BUILD_DIR)" && aclocal && libtoolize --force && autoconf )
|
||||||
|
$(call Build/Configure/Default, \
|
||||||
|
--disable-cxx \
|
||||||
|
--disable-threads \
|
||||||
|
--without-liboil \
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) $(1)/usr/include/vips
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/include/* \
|
||||||
|
$(1)/usr/include/
|
||||||
|
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib/
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/*.so* \
|
||||||
|
$(1)/usr/lib/
|
||||||
|
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
|
||||||
|
$(INSTALL_DATA) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
|
||||||
|
$(1)/usr/lib/pkgconfig/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/vips/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib/
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/*.so* \
|
||||||
|
$(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,vips))
|
49
libs/vips/patches/001-embedded_build.patch
Normal file
49
libs/vips/patches/001-embedded_build.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
diff -u --recursive --new-file vips-7.22.2-vanilla/configure.in vips-7.22.2/configure.in
|
||||||
|
--- vips-7.22.2-vanilla/configure.in 2010-09-13 16:03:33.945285002 -0500
|
||||||
|
+++ vips-7.22.2/configure.in 2010-09-13 16:13:36.848285002 -0500
|
||||||
|
@@ -142,6 +142,7 @@
|
||||||
|
AC_PROG_AWK
|
||||||
|
AC_PROG_CC
|
||||||
|
AC_PROG_CC_STDC
|
||||||
|
+AC_PROG_CXX
|
||||||
|
AC_C_CONST
|
||||||
|
AC_C_RESTRICT
|
||||||
|
AC_PROG_RANLIB
|
||||||
|
@@ -157,7 +158,6 @@
|
||||||
|
AS_HELP_STRING([--enable-cxx], [build C++ components (default: enabled)]))
|
||||||
|
|
||||||
|
if test x"$enable_cxx" != "xno"; then
|
||||||
|
- AC_PROG_CXX
|
||||||
|
AC_DEFINE(ENABLE_CXX,1,[build C++ components])
|
||||||
|
AM_CONDITIONAL(ENABLE_CXX, true)
|
||||||
|
enable_cxx=yes
|
||||||
|
@@ -273,9 +273,6 @@
|
||||||
|
enable_threads=yes
|
||||||
|
fi
|
||||||
|
|
||||||
|
-# check for gtk-doc
|
||||||
|
-GTK_DOC_CHECK(1.9)
|
||||||
|
-
|
||||||
|
# optional supporting libraries
|
||||||
|
|
||||||
|
# we can wrap fftw3 and fftw2 ... but just look for fftw3, since we can do
|
||||||
|
@@ -633,9 +630,6 @@
|
||||||
|
swig/vipsCC/Makefile
|
||||||
|
swig/python/setup.py
|
||||||
|
man/Makefile
|
||||||
|
- doc/Makefile
|
||||||
|
- doc/reference/Makefile
|
||||||
|
- doc/reference/libvips-docs.sgml
|
||||||
|
po/Makefile.in
|
||||||
|
])
|
||||||
|
|
||||||
|
diff -u --recursive --new-file vips-7.22.2-vanilla/Makefile.am vips-7.22.2/Makefile.am
|
||||||
|
--- vips-7.22.2-vanilla/Makefile.am 2010-09-13 16:03:33.946285002 -0500
|
||||||
|
+++ vips-7.22.2/Makefile.am 2010-09-13 16:10:27.306284973 -0500
|
||||||
|
@@ -24,7 +24,6 @@
|
||||||
|
tools \
|
||||||
|
man \
|
||||||
|
po \
|
||||||
|
- doc \
|
||||||
|
$(C_COMPILE_DIR) \
|
||||||
|
$(P_COMPILE_DIR)
|
Loading…
x
Reference in New Issue
Block a user