Update aprx to 0.99 (#3805)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@11918 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-07-24 14:06:26 +00:00
parent 0d25c00b5d
commit a14070d187
3 changed files with 37 additions and 5 deletions

View File

@ -4,17 +4,17 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id: $
# $Id: Makefile 2 07/06/2008 18:59:01Z jrhopper@gmail.com$
include $(TOPDIR)/rules.mk
PKG_NAME:=aprx
PKG_VERSION:=0.22
PKG_RELEASE:=svn115
PKG_VERSION:=0.99
PKG_RELEASE:=svn121
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).$(PKG_RELEASE).tar.gz
PKG_SOURCE_URL:=http://ham.zmailer.org/oh2mqk/aprx
PKG_MD5SUM:=e376bb1c420858b5053584bae00d498d
PKG_MD5SUM:=095ec0aa24432196002ae717593bfe5c
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).$(PKG_RELEASE)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@ -33,7 +33,15 @@ define Package/aprx/description
It then forwards appropriate packets to APRS-IS servers.
endef
define Build/Configure
$(call Build/Configure/Default, \
--with-embedded \
)
endef
define Package/aprx/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/aprx.init $(1)/etc/init.d/aprx
$(INSTALL_DIR) $(1)/etc
$(INSTALL_CONF) $(PKG_BUILD_DIR)/aprx.conf $(1)/etc/
$(INSTALL_DIR) $(1)/usr/sbin

23
net/aprx/files/aprx.init Normal file
View File

@ -0,0 +1,23 @@
#!/bin/sh /etc/rc.common
#Init script for aprx
START=99
APRX_BIN="/usr/sbin/aprx"
APRX_LOG_DIR="/var/log/aprx"
system_config() {
local cfg="$1"
config_get hostname "$cfg" hostname
}
start() {
[ -x "$APRX_BIN" ] || return 1
[ -d "$APRX_LOG_DIR" ] || mkdir -p $APRX_LOG_DIR
$APRX_BIN
}
stop() {
killall aprx
}

View File

@ -1,13 +1,14 @@
diff -ruN aprx-0.22.svn115.orig/Makefile.in aprx-0.22.svn115/Makefile.in
--- aprx-0.22.svn115.orig/Makefile.in 2008-07-06 17:28:27.000000000 -0400
+++ aprx-0.22.svn115/Makefile.in 2008-07-06 17:29:42.000000000 -0400
@@ -25,7 +25,7 @@
@@ -25,7 +25,8 @@
CFLAGS= @CFLAGS@ $(DEFS)
# Linker and flags
-LD= @LD@
+LD= @CC@
LDFLAGS= @LDFLAGS@
+datarootdir = @datarootdir@
INSTALL= $(srcdir)/install-sh
@@ -75,10 +75,10 @@