[package] xtables-addons: update to 1.45

This patch updates xtables-addons and removes the 3.3 compatibility patch and
the powerpc include as it is not required.

Signed-off-by: Oliver Smith <olipro@8.c.9.b.0.7.4.0.1.0.0.2.ip6.arpa>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@33792 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2012-10-16 15:55:43 +00:00
parent 054208e419
commit a2eda5b7d1
3 changed files with 3 additions and 28 deletions

View File

@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=xtables-addons
PKG_VERSION:=1.42
PKG_RELEASE:=3
PKG_VERSION:=1.45
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_MD5SUM:=7c996a0400667b57ab4fb53a013ae742
PKG_MD5SUM:=802d2f556a5e545f44e4b69937bf8490
PKG_SOURCE_URL:=@SF/xtables-addons
PKG_BUILD_DEPENDS:=iptables
PKG_INSTALL:=1
@ -147,5 +147,3 @@ $(eval $(call BuildTemplate,rawnat,RAWNAT,xt_RAWDNAT xt_RAWSNAT,xt_RAWNAT,46,+km
$(eval $(call BuildTemplate,steal,STEAL,xt_STEAL,xt_STEAL,46,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,sysrq,SYSRQ,xt_SYSRQ,xt_SYSRQ,46,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,46,+kmod-ipt-compat-xtables))
$(eval $(call BuildPackage,iptaccount))

View File

@ -1,11 +0,0 @@
--- a/extensions/compat_xtables.h
+++ b/extensions/compat_xtables.h
@@ -102,6 +102,8 @@
# define nf_nat_ipv4_multi_range_compat nf_nat_multi_range_compat
# define nf_nat_ipv4_range nf_nat_range
# define NF_NAT_RANGE_MAP_IPS IP_NAT_RANGE_MAP_IPS
+# define NF_NAT_MANIP_SRC IP_NAT_MANIP_SRC
+# define NF_NAT_MANIP_DST IP_NAT_MANIP_DST
#endif
#if !defined(NIP6) && !defined(NIP6_FMT)

View File

@ -1,12 +0,0 @@
Index: xtables-addons-1.42/extensions/xt_ECHO.c
===================================================================
--- xtables-addons-1.42.orig/extensions/xt_ECHO.c 2012-08-12 20:33:11.000000000 +0200
+++ xtables-addons-1.42/extensions/xt_ECHO.c 2012-08-12 20:33:24.000000000 +0200
@@ -20,6 +20,7 @@
#include <net/ip.h>
#include <net/ip6_route.h>
#include <net/route.h>
+#include <net/ip6_checksum.h>
#include "compat_xtables.h"
static unsigned int