Update XOrg to 7.3 the second
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12470 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3fea517e4b
commit
a3479b3391
@ -1,17 +1,17 @@
|
||||
#
|
||||
# Copyright (C) 2007-2008 OpenWrt.org
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# blogic@openwrt.org
|
||||
# blogic@openwrt.org
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_BASE_NAME:=libxkbui
|
||||
PKG_NAME:=libxkbui
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=X11R7.1-1.0.2
|
||||
PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.2/src/lib/
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.0.2
|
||||
PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.3/src/lib/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
|
||||
|
||||
@ -21,27 +21,27 @@ define Package/libxkbui
|
||||
SECTION:=xorg-libraries
|
||||
CATEGORY:=Xorg
|
||||
SUBMENU:=libraries
|
||||
DEPENDS:=+xorg-headers-native +util-macros +libXt +libxkbfile @DISPLAY_SUPPORT
|
||||
DEPENDS:=+xorg-headers-native +util-macros @DISPLAY_SUPPORT
|
||||
TITLE:=libxkbui
|
||||
URL:=http://xorg.freedesktop.org/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
DESTDIR=$(1) $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
|
||||
DESTDIR=$(STAGING_DIR) $(MAKE) -C $(PKG_BUILD_DIR)/ $(MAKE_FLAGS) install
|
||||
endef
|
||||
|
||||
ifeq (libxkbui,libX11)
|
||||
CONFIGURE_ARGS_XTRA=--without-xcb
|
||||
CONFIGURE_ARGS+=--without-xcb
|
||||
endif
|
||||
|
||||
define libX11/Compile
|
||||
$(MAKE_VARS) \
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src/util CFLAGS="" LDFLAGS="" CC="cc" makekeys
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src/util CFLAGS="" LDFLAGS="" CC="cc" makekeys
|
||||
endef
|
||||
|
||||
define libXt/Compile
|
||||
$(MAKE_VARS) \
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/util CFLAGS="" LDFLAGS="" CC="cc"
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/util CFLAGS="" LDFLAGS="" CC="cc"
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
@ -53,21 +53,12 @@ define Build/Compile
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
|
||||
if [ -x $(CONFIGURE_CMD) ]; then \
|
||||
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
|
||||
$(CONFIGURE_VARS) \
|
||||
$(CONFIGURE_CMD) \
|
||||
$(CONFIGURE_ARGS_XTRA) \
|
||||
$(CONFIGURE_ARGS) \
|
||||
--enable-malloc0returnsnull; \
|
||||
fi \
|
||||
)
|
||||
$(call Build/Configure/Default, --enable-malloc0returnsnull)
|
||||
endef
|
||||
|
||||
define Package/libxkbui/install/Default
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
find $(PKG_INSTALL_DIR)/usr/lib/ -name lib*so* | $(XARGS) -I % -t cp -P % $(1)/usr/lib
|
||||
find $(PKG_INSTALL_DIR)/usr/lib/ -name lib*so* | $(XARGS) -i -t cp -P {} $(1)/usr/lib
|
||||
endef
|
||||
|
||||
define Package/libxkbui/install
|
||||
@ -80,8 +71,7 @@ define Package/libXaw/install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(STAGING_DIR)
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libxkbui))
|
||||
|
@ -1,177 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# blogic@openwrt.org
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=xorg-server
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=X11R7.2-1.2.0
|
||||
PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.2/src/xserver/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/server/xorg-server-$(PKG_VERSION)/
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
EXTRA_CFLAGS+= -I${STAGING_DIR}/usr/include/X11/GL -I${STAGING_DIR}/usr/include/X11/dri/ -I${STAGING_DIR}/usr/include/X11/ -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||
|
||||
#CONFIGURE_ARGS_KDRIVE=--enable-composite --enable-kdrive \
|
||||
# --disable-dga --disable-dri --disable-xinerama \
|
||||
# --disable-xf86misc --disable-xf86vidmode \
|
||||
# --disable-xorg --disable-xorgcfg \
|
||||
# --disable-xkb --disable-xnest --disable-xvfb \
|
||||
# --disable-xevie --disable-xprint --disable-xtrap \
|
||||
# --disable-dmx --disable-w100 \
|
||||
# --with-default-font-path=built-ins \
|
||||
# --enable-tslib --enable-xcalibrate
|
||||
|
||||
CONFIGURE_VARS+=ac_cv_file__usr_share_sgml_X11_defs_ent=yes
|
||||
#CONFIGURE_ARGS+=$(if $(CONFIG_XORG_BUILD_KDRIVE), $(CONFIGURE_ARGS_KDRIVE))
|
||||
|
||||
DEPENDS_SERVER:=+calibrateproto \
|
||||
+compositeproto \
|
||||
+damageproto \
|
||||
+fixesproto \
|
||||
+recordproto \
|
||||
+resourceproto \
|
||||
+scrnsaverproto \
|
||||
+videoproto \
|
||||
+xextproto \
|
||||
+xproto \
|
||||
+libXext \
|
||||
+libXdmcp \
|
||||
+libXfont \
|
||||
+libXrandr \
|
||||
+xtrans \
|
||||
+libX11 \
|
||||
+glproto \
|
||||
+xf86driproto \
|
||||
+applewmproto \
|
||||
+dmxproto \
|
||||
+printproto \
|
||||
+windowswmproto \
|
||||
+xf86rushproto \
|
||||
+xproxymanagementprotocol \
|
||||
+libdrm \
|
||||
+xf86miscproto \
|
||||
+xf86vidmodeproto \
|
||||
+xf86dgaproto \
|
||||
+trapproto \
|
||||
+xineramaproto \
|
||||
+evieext \
|
||||
+libxkbfile \
|
||||
+libXt \
|
||||
+libSM \
|
||||
+libxkbui \
|
||||
+libXxf86misc \
|
||||
+libXxf86vm \
|
||||
+libXaw \
|
||||
+libXmu \
|
||||
+libXpm \
|
||||
+libnotimpl \
|
||||
+Mesa \
|
||||
@DISPLAY_SUPPORT
|
||||
|
||||
#DEPENDS_KDRIVE:=+calibrateproto \
|
||||
# +compositeproto \
|
||||
# +damageproto \
|
||||
# +fixesproto \
|
||||
# +recordproto \
|
||||
# +resourceproto \
|
||||
# +scrnsaverproto \
|
||||
# +videoproto \
|
||||
# +xextproto \
|
||||
# +xproto \
|
||||
# +libXext \
|
||||
# +libXdmcp \
|
||||
# +libXfont \
|
||||
# +libXrandr \
|
||||
# +xtrans \
|
||||
# +libX11 \
|
||||
# @DISPLAY_SUPPORT
|
||||
|
||||
|
||||
ifeq ($(CONFIG_TARGET_olpc),y)
|
||||
XORG_CONFIG_FILE=xorg-olpc.conf
|
||||
else
|
||||
XORG_CONFIG_FILE=xorg.conf
|
||||
endif
|
||||
|
||||
#define Package/xorg-server/config
|
||||
# config XORG_BUILD_KDRIVE
|
||||
# bool "Build kdrive instead of xserver"
|
||||
# depends PACKAGE_xorg-server || BROKEN
|
||||
#endef
|
||||
|
||||
define Package/xorg-server/Default
|
||||
SECTION:=xorg-server
|
||||
CATEGORY:=Xorg
|
||||
URL:=http://xorg.freedesktop.org/
|
||||
endef
|
||||
|
||||
define Package/xorg-server
|
||||
$(call Package/xorg-server/Default)
|
||||
TITLE:=Xorg server
|
||||
MENU:=1
|
||||
DEPENDS:=$(if $(CONFIG_XORG_BUILD_KDRIVE), $(DEPENDS_KDRIVE), $(DEPENDS_SERVER))
|
||||
endef
|
||||
|
||||
define Package/xorg-server-config
|
||||
$(call Package/xorg-server/Default)
|
||||
TITLE:=Xorg server configuration tools
|
||||
DEPENDS:=xorg-server
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR) \
|
||||
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
|
||||
$(CONFIGURE_VARS) \
|
||||
$(CONFIGURE_CMD) \
|
||||
$(CONFIGURE_ARGS_XTRA) \
|
||||
$(CONFIGURE_ARGS) \
|
||||
--with-default-font-path=built-ins \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
|
||||
|
||||
endef
|
||||
|
||||
define Package/xorg-server/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/Xorg $(1)/usr/bin/
|
||||
cd $(1)/usr/bin; ln -sf Xorg X
|
||||
$(INSTALL_DIR) $(1)/usr/share
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/* $(1)/usr/share/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/xserver
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/xserver/* $(1)/usr/lib/xserver
|
||||
$(INSTALL_DIR) $(1)/usr/lib/xorg/
|
||||
$(CP) -r $(PKG_INSTALL_DIR)/usr/lib/xorg/* $(1)/usr/lib/xorg/
|
||||
find $(1)/usr/lib/xorg/ -name *.la | xargs rm -rf
|
||||
$(INSTALL_DIR) $(1)/usr/lib/X11/
|
||||
$(CP) -r $(PKG_INSTALL_DIR)/usr/lib/X11/* $(1)/usr/lib/X11/
|
||||
rm -rf $(1)/usr/share/X11 $(1)/usr/lib/X11/xserver
|
||||
$(INSTALL_DIR) $(1)/var/log/
|
||||
$(INSTALL_DIR) $(1)/etc/X11/
|
||||
$(CP) files/$(XORG_CONFIG_FILE) $(1)/etc/X11/xorg.conf
|
||||
endef
|
||||
|
||||
define Packages/xorg-server-config/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xorgconfig $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
||||
$(CP) $(PKG_BUILD_DIR)/xorg-server.pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,xorg-server))
|
||||
$(eval $(call BuildPackage,xorg-server-config))
|
@ -1,73 +0,0 @@
|
||||
# xorg configuration
|
||||
|
||||
Section "ServerLayout"
|
||||
Identifier "Default Layout"
|
||||
Screen 0 "Screen0" 0 0
|
||||
InputDevice "Mouse0" "CorePointer"
|
||||
InputDevice "Keyboard0" "CoreKeyboard"
|
||||
EndSection
|
||||
|
||||
Section "Files"
|
||||
FontPath "/usr/lib/X11/fonts/misc"
|
||||
EndSection
|
||||
|
||||
Section "Module"
|
||||
Load "dbe"
|
||||
Load "extmod"
|
||||
Load "fbdevhw"
|
||||
# Load "glx"
|
||||
Load "record"
|
||||
Load "freetype"
|
||||
Load "type1"
|
||||
EndSection
|
||||
|
||||
Section "InputDevice"
|
||||
Identifier "Keyboard0"
|
||||
Driver "keyboard"
|
||||
Option "XkbModel" "pc105"
|
||||
Option "XkbLayout" "us"
|
||||
EndSection
|
||||
|
||||
Section "InputDevice"
|
||||
Identifier "Mouse0"
|
||||
Driver "mouse"
|
||||
Option "Protocol" "PS/2"
|
||||
# Option "Protocol" "IMPS/2"
|
||||
Option "Device" "/dev/psaux"
|
||||
# Option "Device" "/dev/input/mice"
|
||||
Option "ZAxisMapping" "4 5"
|
||||
Option "Emulate3Buttons" "yes"
|
||||
EndSection
|
||||
|
||||
Section "Monitor"
|
||||
Identifier "Monitor0"
|
||||
VendorName "Monitor Vendor"
|
||||
ModelName "OWRT"
|
||||
Option "dpms"
|
||||
EndSection
|
||||
|
||||
Section "Device"
|
||||
Identifier "FBDev"
|
||||
Driver "fbdev"
|
||||
#Option "shadowfb" "off"
|
||||
VideoRam 4096
|
||||
EndSection
|
||||
|
||||
Section "Screen"
|
||||
Identifier "Screen0"
|
||||
Device "FBDev"
|
||||
Monitor "Monitor0"
|
||||
DefaultDepth 16
|
||||
|
||||
SubSection "Display"
|
||||
Depth 16
|
||||
Modes "1200x900"
|
||||
EndSubsection
|
||||
|
||||
EndSection
|
||||
|
||||
Section "DRI"
|
||||
Group 0
|
||||
Mode 0666
|
||||
EndSection
|
||||
|
@ -1,93 +0,0 @@
|
||||
# xorg configuration
|
||||
|
||||
Section "ServerLayout"
|
||||
Identifier "Default Layout"
|
||||
Screen 0 "Screen0" 0 0
|
||||
InputDevice "Mouse0" "CorePointer"
|
||||
InputDevice "Keyboard0" "CoreKeyboard"
|
||||
EndSection
|
||||
|
||||
Section "Files"
|
||||
FontPath "/usr/lib/X11/fonts/misc"
|
||||
EndSection
|
||||
|
||||
Section "Module"
|
||||
Load "dbe"
|
||||
Load "extmod"
|
||||
Load "fbdevhw"
|
||||
# Load "glx"
|
||||
Load "record"
|
||||
Load "freetype"
|
||||
Load "type1"
|
||||
EndSection
|
||||
|
||||
Section "InputDevice"
|
||||
Identifier "Keyboard0"
|
||||
Driver "keyboard"
|
||||
Option "XkbModel" "pc105"
|
||||
Option "XkbLayout" "us"
|
||||
EndSection
|
||||
|
||||
Section "InputDevice"
|
||||
Identifier "Mouse0"
|
||||
Driver "mouse"
|
||||
Option "Protocol" "PS/2"
|
||||
# Option "Protocol" "IMPS/2"
|
||||
Option "Device" "/dev/psaux"
|
||||
# Option "Device" "/dev/input/mice"
|
||||
Option "ZAxisMapping" "4 5"
|
||||
Option "Emulate3Buttons" "yes"
|
||||
EndSection
|
||||
|
||||
Section "Monitor"
|
||||
Identifier "Monitor0"
|
||||
VendorName "Monitor Vendor"
|
||||
ModelName "OWRT"
|
||||
Option "dpms"
|
||||
EndSection
|
||||
|
||||
Section "Device"
|
||||
Identifier "Videocard0"
|
||||
Driver "vesa"
|
||||
VendorName "Videocard vendor"
|
||||
BoardName "Vesa driver"
|
||||
EndSection
|
||||
|
||||
Section "Device"
|
||||
Identifier "FBDev"
|
||||
Driver "fbdev"
|
||||
#Option "shadowfb" "off"
|
||||
VideoRam 4096
|
||||
EndSection
|
||||
|
||||
Section "Screen"
|
||||
Identifier "Screen0"
|
||||
Device "Videocard0"
|
||||
Monitor "Monitor0"
|
||||
# DefaultDepth 8
|
||||
DefaultDepth 16
|
||||
# DefaultDepth 24
|
||||
|
||||
SubSectionSub "Display"
|
||||
Depth 8
|
||||
Modes "1024x768" "800x600" "640x480"
|
||||
EndSubsection
|
||||
|
||||
SubSectionSub "Display"
|
||||
Depth 16
|
||||
Modes "1024x768" "800x600" "640x480"
|
||||
EndSubsection
|
||||
|
||||
SubSectionSub "Display"
|
||||
Depth 24
|
||||
FbBpp 32
|
||||
Modes "1024x768" "800x600" "640x480"
|
||||
EndSubsection
|
||||
|
||||
EndSection
|
||||
|
||||
Section "DRI"
|
||||
Group 0
|
||||
Mode 0666
|
||||
EndSection
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- xorg-server-X11R7.2-1.2.0/config.sub.orig 2008-05-14 22:56:34.000000000 -0500
|
||||
+++ xorg-server-X11R7.2-1.2.0/config.sub 2008-05-14 22:57:00.000000000 -0500
|
||||
@@ -228,7 +228,7 @@
|
||||
| a29k \
|
||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
||||
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
||||
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
||||
| c4x | clipper \
|
||||
| d10v | d30v | dlx | dsp16xx \
|
||||
| fr30 | frv \
|
||||
@@ -295,7 +295,7 @@
|
||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
||||
- | avr-* \
|
||||
+ | avr-* | avr32-* \
|
||||
| bs2000-* \
|
||||
| c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
|
||||
| clipper-* | cydra-* \
|
@ -1,12 +0,0 @@
|
||||
diff -urN xorg-server-X11R7.2-1.2.0.orig/hw/xfree86/utils/gtf/Makefile.in xorg-server-X11R7.2-1.2.0/hw/xfree86/utils/gtf/Makefile.in
|
||||
--- xorg-server-X11R7.2-1.2.0.orig/hw/xfree86/utils/gtf/Makefile.in 2007-09-14 21:23:18.000000000 +0200
|
||||
+++ xorg-server-X11R7.2-1.2.0/hw/xfree86/utils/gtf/Makefile.in 2007-09-14 21:23:42.000000000 +0200
|
||||
@@ -576,7 +576,7 @@
|
||||
xpconfigdir = @xpconfigdir@
|
||||
gtf_SOURCES = gtf.c
|
||||
gtf_CFLAGS = $(XORG_CFLAGS)
|
||||
-gtf_LDADD = -lm
|
||||
+gtf_LDADD = -lm -lnotimpl
|
||||
appmandir = $(APP_MAN_DIR)
|
||||
appman_PRE = gtf.man
|
||||
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
|
Loading…
x
Reference in New Issue
Block a user