add Content-Disposition workaround (closes: #2048), bump release number
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8458 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
11a3275e32
commit
a40b28faa0
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=haserl
|
||||
PKG_VERSION:=0.8.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/haserl
|
||||
|
18
utils/haserl/patches/101-ignore_content_disposition.patch
Normal file
18
utils/haserl/patches/101-ignore_content_disposition.patch
Normal file
@ -0,0 +1,18 @@
|
||||
Index: haserl-0.8.0/src/haserl.c
|
||||
===================================================================
|
||||
--- haserl-0.8.0.orig/src/haserl.c 2007-06-04 13:22:30.973146648 +0200
|
||||
+++ haserl-0.8.0/src/haserl.c 2007-06-04 13:22:31.039136616 +0200
|
||||
@@ -479,9 +479,12 @@
|
||||
line=LineToStr(&qs[offset], cl-offset);
|
||||
if (strncasecmp(&qs[offset], "Content-Disposition", 19) != 0) {
|
||||
/* hmm... content disposition was not where we expected it */
|
||||
+ /* Be kind to Opera 9.10 and just ignore this block */
|
||||
+ /*
|
||||
PrintParseError ("Content-Disposition Missing", 0);
|
||||
free(ct);
|
||||
- return(-1);
|
||||
+ */
|
||||
+ continue;
|
||||
}
|
||||
/* Found it, so let's go find "name=" */
|
||||
if (!(envname=strstr(&qs[offset], "name="))) {
|
Loading…
x
Reference in New Issue
Block a user