Patch to make gettext usable when uClibc is compiled without locale support.This patch unlocks the functions of gettext to work on systems without locale support. On an default OpenWrt the uClibc is compiled with only a dummy
support for locale, which is unusable and makes so the gettext library completely unusable on this systems. git-svn-id: svn://svn.openwrt.org/openwrt/packages@13057 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
431e372ee5
commit
a42a5c3017
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gettext
|
||||
PKG_VERSION:=0.16.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/gettext
|
||||
|
13
libs/gettext/patches/120-uclibc-nolocale.patch
Normal file
13
libs/gettext/patches/120-uclibc-nolocale.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: gettext-0.16.1/gettext-runtime/intl/localename.c
|
||||
===================================================================
|
||||
--- gettext-0.16.1.orig/gettext-runtime/intl/localename.c 2007-12-29 22:51:09.363903016 +0100
|
||||
+++ gettext-0.16.1/gettext-runtime/intl/localename.c 2008-10-26 16:57:14.048169957 +0100
|
||||
@@ -988,7 +988,7 @@
|
||||
{
|
||||
/* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
|
||||
On some systems this can be done by the 'setlocale' function itself. */
|
||||
-#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL
|
||||
+#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL && (!defined __UCLIBC__ || defined __UCLIBC_HAS_LOCALE__)
|
||||
return setlocale (category, NULL);
|
||||
#else
|
||||
const char *retval;
|
Loading…
x
Reference in New Issue
Block a user