[package] update bind to 9.6.1-P1 (#5888)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17708 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ecfdb9995f
commit
a53137f79d
@ -8,14 +8,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=bind
|
PKG_NAME:=bind
|
||||||
PKG_VERSION:=9.6.0-P1
|
PKG_VERSION:=9.6.1-P1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
||||||
http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
||||||
PKG_MD5SUM:=886b7eae55cfdc8cd8d2ca74a2f99c6e
|
PKG_MD5SUM:=e6ce3b355c4e6bf5d66ef100f555da3f
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -50,7 +50,7 @@ define Package/bind-tools
|
|||||||
$(call Package/bind/Default)
|
$(call Package/bind/Default)
|
||||||
TITLE+= administration tools (all)
|
TITLE+= administration tools (all)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/bind-rndc
|
define Package/bind-rndc
|
||||||
$(call Package/bind/Default)
|
$(call Package/bind/Default)
|
||||||
TITLE+= administration tools (rndc and rndc-confgen only)
|
TITLE+= administration tools (rndc and rndc-confgen only)
|
||||||
@ -99,7 +99,6 @@ define Build/Compile
|
|||||||
LIBS="" \
|
LIBS="" \
|
||||||
gen
|
gen
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
all install
|
all install
|
||||||
endef
|
endef
|
||||||
|
@ -1,36 +1,34 @@
|
|||||||
Index: bind-9.6.0-P1/configure
|
--- a/configure
|
||||||
===================================================================
|
+++ b/configure
|
||||||
--- bind-9.6.0-P1.orig/configure 2008-05-06 02:33:33.000000000 +0100
|
@@ -22023,8 +22023,7 @@ $as_echo_n "checking epoll support... "
|
||||||
+++ bind-9.6.0-P1/configure 2008-07-12 08:23:25.000000000 +0100
|
{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||||
@@ -5449,8 +5449,7 @@
|
|
||||||
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&5
|
See \`config.log' for more details." >&5
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
$as_echo "$as_me: error: cannot run test program while cross compiling
|
||||||
-See \`config.log' for more details." >&2;}
|
-See \`config.log' for more details." >&2;}
|
||||||
- { (exit 1); exit 1; }; }
|
- { (exit 1); exit 1; }; }
|
||||||
+See \`config.log' for more details." >&2;} }
|
+See \`config.log' for more details." >&2;} }
|
||||||
else
|
else
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
cat >conftest.$ac_ext <<_ACEOF
|
||||||
/* confdefs.h. */
|
/* confdefs.h. */
|
||||||
@@ -6791,8 +6790,7 @@
|
@@ -23564,8 +23563,7 @@ if { as_var=$as_ac_File; eval "test \"\$
|
||||||
else
|
else
|
||||||
test "$cross_compiling" = yes &&
|
test "$cross_compiling" = yes &&
|
||||||
{ { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
{ { $as_echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
-$as_echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||||
- { (exit 1); exit 1; }; }
|
- { (exit 1); exit 1; }; }
|
||||||
+echo "$as_me: error: cannot check for file existence when cross compiling" >&2;} }
|
+$as_echo "$as_me: error: cannot check for file existence when cross compiling" >&2;} }
|
||||||
if test -r "$devrandom"; then
|
if test -r "$devrandom"; then
|
||||||
eval "$as_ac_File=yes"
|
eval "$as_ac_File=yes"
|
||||||
else
|
else
|
||||||
@@ -25535,195 +25533,6 @@
|
@@ -27069,73 +27067,6 @@ rm -f core conftest.err conftest.$ac_obj
|
||||||
# which provides some (all?) of the desired functions.
|
# which provides some (all?) of the desired functions.
|
||||||
#
|
#
|
||||||
|
|
||||||
-{ echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
|
-{ $as_echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
|
||||||
-echo $ECHO_N "checking for inet_ntop with IPv6 support... $ECHO_C" >&6; }
|
-$as_echo_n "checking for inet_ntop with IPv6 support... " >&6; }
|
||||||
-if test "$cross_compiling" = yes; then
|
-if test "$cross_compiling" = yes; then
|
||||||
- { echo "$as_me:$LINENO: result: assuming inet_ntop needed" >&5
|
- { $as_echo "$as_me:$LINENO: result: assuming inet_ntop needed" >&5
|
||||||
-echo "${ECHO_T}assuming inet_ntop needed" >&6; }
|
-$as_echo "assuming inet_ntop needed" >&6; }
|
||||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
||||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
||||||
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
||||||
@ -55,166 +53,44 @@ Index: bind-9.6.0-P1/configure
|
|||||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||||
- *) ac_try_echo=$ac_try;;
|
- *) ac_try_echo=$ac_try;;
|
||||||
-esac
|
-esac
|
||||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||||
|
-$as_echo "$ac_try_echo") >&5
|
||||||
- (eval "$ac_link") 2>&5
|
- (eval "$ac_link") 2>&5
|
||||||
- ac_status=$?
|
- ac_status=$?
|
||||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||||
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
|
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
|
||||||
- { (case "(($ac_try" in
|
- { (case "(($ac_try" in
|
||||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||||
- *) ac_try_echo=$ac_try;;
|
- *) ac_try_echo=$ac_try;;
|
||||||
-esac
|
-esac
|
||||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
||||||
|
-$as_echo "$ac_try_echo") >&5
|
||||||
- (eval "$ac_try") 2>&5
|
- (eval "$ac_try") 2>&5
|
||||||
- ac_status=$?
|
- ac_status=$?
|
||||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||||
- (exit $ac_status); }; }; then
|
- (exit $ac_status); }; }; then
|
||||||
- { echo "$as_me:$LINENO: result: yes" >&5
|
- { $as_echo "$as_me:$LINENO: result: yes" >&5
|
||||||
-echo "${ECHO_T}yes" >&6; }
|
-$as_echo "yes" >&6; }
|
||||||
- ISC_PLATFORM_NEEDNTOP="#undef ISC_PLATFORM_NEEDNTOP"
|
- ISC_PLATFORM_NEEDNTOP="#undef ISC_PLATFORM_NEEDNTOP"
|
||||||
-else
|
-else
|
||||||
- echo "$as_me: program exited with status $ac_status" >&5
|
- $as_echo "$as_me: program exited with status $ac_status" >&5
|
||||||
-echo "$as_me: failed program was:" >&5
|
-$as_echo "$as_me: failed program was:" >&5
|
||||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||||
-
|
-
|
||||||
-( exit $ac_status )
|
-( exit $ac_status )
|
||||||
-{ echo "$as_me:$LINENO: result: no" >&5
|
-{ $as_echo "$as_me:$LINENO: result: no" >&5
|
||||||
-echo "${ECHO_T}no" >&6; }
|
-$as_echo "no" >&6; }
|
||||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
||||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
||||||
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
||||||
-fi
|
-fi
|
||||||
|
-rm -rf conftest.dSYM
|
||||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||||
-fi
|
-fi
|
||||||
-
|
-
|
||||||
-
|
-
|
||||||
-
|
-
|
||||||
-
|
-
|
||||||
-# On NetBSD 1.4.2 and maybe others, inet_pton() incorrectly accepts
|
# On NetBSD 1.4.2 and maybe others, inet_pton() incorrectly accepts
|
||||||
-# addresses with less than four octets, like "1.2.3". Also leading
|
# addresses with less than four octets, like "1.2.3". Also leading
|
||||||
-# zeros should also be rejected.
|
# zeros should also be rejected.
|
||||||
-
|
|
||||||
-{ echo "$as_me:$LINENO: checking for working inet_pton with IPv6 support" >&5
|
|
||||||
-echo $ECHO_N "checking for working inet_pton with IPv6 support... $ECHO_C" >&6; }
|
|
||||||
-if test "$cross_compiling" = yes; then
|
|
||||||
- { echo "$as_me:$LINENO: result: assuming target platform has working inet_pton" >&5
|
|
||||||
-echo "${ECHO_T}assuming target platform has working inet_pton" >&6; }
|
|
||||||
- ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
|
|
||||||
-else
|
|
||||||
- cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
-/* confdefs.h. */
|
|
||||||
-_ACEOF
|
|
||||||
-cat confdefs.h >>conftest.$ac_ext
|
|
||||||
-cat >>conftest.$ac_ext <<_ACEOF
|
|
||||||
-/* end confdefs.h. */
|
|
||||||
-
|
|
||||||
-#include <sys/types.h>
|
|
||||||
-#include <sys/socket.h>
|
|
||||||
-#include <netinet/in.h>
|
|
||||||
-#include <arpa/inet.h>
|
|
||||||
-main() { char a[16]; return (inet_pton(AF_INET, "1.2.3", a) == 1 ? 1 :
|
|
||||||
- inet_pton(AF_INET, "1.2.3.04", a) == 1 ? 1 :
|
|
||||||
- (inet_pton(AF_INET6, "::1.2.3.4", a) != 1)); }
|
|
||||||
-_ACEOF
|
|
||||||
-rm -f conftest$ac_exeext
|
|
||||||
-if { (ac_try="$ac_link"
|
|
||||||
-case "(($ac_try" in
|
|
||||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
||||||
- *) ac_try_echo=$ac_try;;
|
|
||||||
-esac
|
|
||||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
||||||
- (eval "$ac_link") 2>&5
|
|
||||||
- ac_status=$?
|
|
||||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
||||||
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
|
|
||||||
- { (case "(($ac_try" in
|
|
||||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
||||||
- *) ac_try_echo=$ac_try;;
|
|
||||||
-esac
|
|
||||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
||||||
- (eval "$ac_try") 2>&5
|
|
||||||
- ac_status=$?
|
|
||||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
||||||
- (exit $ac_status); }; }; then
|
|
||||||
- { echo "$as_me:$LINENO: result: yes" >&5
|
|
||||||
-echo "${ECHO_T}yes" >&6; }
|
|
||||||
- ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
|
|
||||||
-else
|
|
||||||
- echo "$as_me: program exited with status $ac_status" >&5
|
|
||||||
-echo "$as_me: failed program was:" >&5
|
|
||||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
||||||
-
|
|
||||||
-( exit $ac_status )
|
|
||||||
-{ echo "$as_me:$LINENO: result: no" >&5
|
|
||||||
-echo "${ECHO_T}no" >&6; }
|
|
||||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_pton.$O"
|
|
||||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_pton.c"
|
|
||||||
- ISC_PLATFORM_NEEDPTON="#define ISC_PLATFORM_NEEDPTON 1"
|
|
||||||
-fi
|
|
||||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-{ echo "$as_me:$LINENO: checking for inet_aton" >&5
|
|
||||||
-echo $ECHO_N "checking for inet_aton... $ECHO_C" >&6; }
|
|
||||||
-cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
-/* confdefs.h. */
|
|
||||||
-_ACEOF
|
|
||||||
-cat confdefs.h >>conftest.$ac_ext
|
|
||||||
-cat >>conftest.$ac_ext <<_ACEOF
|
|
||||||
-/* end confdefs.h. */
|
|
||||||
-
|
|
||||||
-#include <sys/types.h>
|
|
||||||
-#include <netinet/in.h>
|
|
||||||
-#include <arpa/inet.h>
|
|
||||||
-int
|
|
||||||
-main ()
|
|
||||||
-{
|
|
||||||
-struct in_addr in; inet_aton(0, &in); return (0);
|
|
||||||
- ;
|
|
||||||
- return 0;
|
|
||||||
-}
|
|
||||||
-_ACEOF
|
|
||||||
-rm -f conftest.$ac_objext conftest$ac_exeext
|
|
||||||
-if { (ac_try="$ac_link"
|
|
||||||
-case "(($ac_try" in
|
|
||||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
||||||
- *) ac_try_echo=$ac_try;;
|
|
||||||
-esac
|
|
||||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
|
||||||
- (eval "$ac_link") 2>conftest.er1
|
|
||||||
- ac_status=$?
|
|
||||||
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
||||||
- rm -f conftest.er1
|
|
||||||
- cat conftest.err >&5
|
|
||||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
||||||
- (exit $ac_status); } && {
|
|
||||||
- test -z "$ac_c_werror_flag" ||
|
|
||||||
- test ! -s conftest.err
|
|
||||||
- } && test -s conftest$ac_exeext &&
|
|
||||||
- $as_test_x conftest$ac_exeext; then
|
|
||||||
- { echo "$as_me:$LINENO: result: yes" >&5
|
|
||||||
-echo "${ECHO_T}yes" >&6; }
|
|
||||||
- ISC_PLATFORM_NEEDATON="#undef ISC_PLATFORM_NEEDATON"
|
|
||||||
-else
|
|
||||||
- echo "$as_me: failed program was:" >&5
|
|
||||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
||||||
-
|
|
||||||
- { echo "$as_me:$LINENO: result: no" >&5
|
|
||||||
-echo "${ECHO_T}no" >&6; }
|
|
||||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_aton.$O"
|
|
||||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_aton.c"
|
|
||||||
- ISC_PLATFORM_NEEDATON="#define ISC_PLATFORM_NEEDATON 1"
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
-rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
|
|
||||||
- conftest$ac_exeext conftest.$ac_ext
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-
|
|
||||||
#
|
|
||||||
# Look for a 4.4BSD-style sa_len member in struct sockaddr.
|
|
||||||
#
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user