[package] update curl to 7.19.5 (#5219)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16105 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
57d9f58efe
commit
a56c3039d7
@ -8,7 +8,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=curl
|
||||
PKG_VERSION:=7.19.4
|
||||
PKG_VERSION:=7.19.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
|
||||
ftp://ftp.planetmirror.com/pub/curl/ \
|
||||
http://www.mirrormonster.com/curl/download/ \
|
||||
http://curl.mirrors.cyberservers.net/download/
|
||||
PKG_MD5SUM:=2734167c1e5f7ce6be99b75d2d371d85
|
||||
PKG_MD5SUM:=426d161661dce70c8ea9ad8f553363a3
|
||||
|
||||
PKG_FIXUP = libtool
|
||||
|
||||
@ -75,6 +75,7 @@ CONFIGURE_ARGS += \
|
||||
--without-krb4 \
|
||||
--without-libidn \
|
||||
--without-nss \
|
||||
--without-libssh2 \
|
||||
--with-zlib="$(STAGING_DIR)/usr" \
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
|
@ -1,8 +1,8 @@
|
||||
Index: curl-7.17.1/configure
|
||||
Index: curl-7.19.5/configure
|
||||
===================================================================
|
||||
--- curl-7.17.1.orig/configure 2008-04-02 11:38:36.800178755 +0200
|
||||
+++ curl-7.17.1/configure 2008-04-02 11:39:49.124300271 +0200
|
||||
@@ -26922,16 +26922,6 @@
|
||||
--- curl-7.19.5.orig/configure 2009-05-25 10:09:06.000000000 +0400
|
||||
+++ curl-7.19.5/configure 2009-05-25 10:09:06.000000000 +0400
|
||||
@@ -25173,16 +25173,6 @@
|
||||
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
fi
|
||||
|
||||
@ -11,76 +11,42 @@ Index: curl-7.17.1/configure
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
|
||||
- export LD_LIBRARY_PATH
|
||||
- { echo "$as_me:$LINENO: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&5
|
||||
-echo "$as_me: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&6;}
|
||||
- { $as_echo "$as_me:$LINENO: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&5
|
||||
-$as_echo "$as_me: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&6;}
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
|
||||
@@ -27551,15 +27541,6 @@
|
||||
{ (exit 1); exit 1; }; }
|
||||
fi
|
||||
|
||||
- if test "$LIBSSH2_ENABLED" = "1"; then
|
||||
- if test -n "$LIB_LIBSSH2"; then
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_LIBSSH2"
|
||||
- export LD_LIBRARY_PATH
|
||||
- { echo "$as_me:$LINENO: Added $LIB_LIBSSH2 to LD_LIBRARY_PATH" >&5
|
||||
-echo "$as_me: Added $LIB_LIBSSH2 to LD_LIBRARY_PATH" >&6;}
|
||||
- fi
|
||||
- fi
|
||||
fi
|
||||
|
||||
|
||||
@@ -25704,18 +25685,6 @@
|
||||
@@ -26177,19 +26167,6 @@
|
||||
fi
|
||||
|
||||
|
||||
- if test "x$USE_GNUTLS" = "xyes"; then
|
||||
- { echo "$as_me:$LINENO: detected GnuTLS version $version" >&5
|
||||
-echo "$as_me: detected GnuTLS version $version" >&6;}
|
||||
- { $as_echo "$as_me:$LINENO: detected GnuTLS version $version" >&5
|
||||
-$as_echo "$as_me: detected GnuTLS version $version" >&6;}
|
||||
-
|
||||
- if test -n "$gtlslib"; then
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
|
||||
- export LD_LIBRARY_PATH
|
||||
- { echo "$as_me:$LINENO: Added $gtlslib to LD_LIBRARY_PATH" >&5
|
||||
-echo "$as_me: Added $gtlslib to LD_LIBRARY_PATH" >&6;}
|
||||
- { $as_echo "$as_me:$LINENO: Added $gtlslib to LD_LIBRARY_PATH" >&5
|
||||
-$as_echo "$as_me: Added $gtlslib to LD_LIBRARY_PATH" >&6;}
|
||||
- fi
|
||||
- fi
|
||||
|
||||
fi
|
||||
|
||||
@@ -27951,17 +27920,6 @@
|
||||
fi
|
||||
|
||||
|
||||
- if test "x$USE_NSS" = "xyes"; then
|
||||
- { echo "$as_me:$LINENO: detected NSS version $version" >&5
|
||||
-echo "$as_me: detected NSS version $version" >&6;}
|
||||
-
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$nssprefix/lib$libsuff"
|
||||
- export LD_LIBRARY_PATH
|
||||
- { echo "$as_me:$LINENO: Added $nssprefix/lib$libsuff to LD_LIBRARY_PATH" >&5
|
||||
-echo "$as_me: Added $nssprefix/lib$libsuff to LD_LIBRARY_PATH" >&6;}
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
fi
|
||||
Index: curl-7.17.1/configure.ac
|
||||
Index: curl-7.19.5/configure.ac
|
||||
===================================================================
|
||||
--- curl-7.17.1.orig/configure.ac 2008-04-02 11:37:43.137120670 +0200
|
||||
+++ curl-7.17.1/configure.ac 2008-04-02 11:38:33.383984077 +0200
|
||||
@@ -1215,19 +1215,6 @@
|
||||
AC_MSG_RESULT([no])
|
||||
--- curl-7.19.5.orig/configure.ac 2009-05-25 10:40:49.000000000 +0400
|
||||
+++ curl-7.19.5/configure.ac 2009-05-25 10:40:49.000000000 +0400
|
||||
@@ -1340,18 +1340,6 @@
|
||||
])
|
||||
fi
|
||||
-
|
||||
|
||||
- if test "$OPENSSL_ENABLED" = "1"; then
|
||||
- if test -n "$LIB_OPENSSL"; then
|
||||
- dnl when the ssl shared libs were found in a path that the run-time
|
||||
@ -96,25 +62,7 @@ Index: curl-7.17.1/configure.ac
|
||||
fi
|
||||
|
||||
dnl **********************************************************************
|
||||
@@ -1364,17 +1351,6 @@
|
||||
AC_MSG_ERROR([libSSH2 libs and/or directories were not found where specified!])
|
||||
fi
|
||||
|
||||
- if test "$LIBSSH2_ENABLED" = "1"; then
|
||||
- if test -n "$LIB_LIBSSH2"; then
|
||||
- dnl when the libssh2 shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
|
||||
- dnl to prevent further configure tests to fail due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_LIBSSH2"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $LIB_LIBSSH2 to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
- fi
|
||||
fi
|
||||
|
||||
dnl **********************************************************************
|
||||
@@ -1610,20 +1586,6 @@
|
||||
@@ -1615,21 +1603,6 @@
|
||||
CPPFLAGS="$CLEANCPPFLAGS"
|
||||
])
|
||||
|
||||
@ -131,27 +79,8 @@ Index: curl-7.17.1/configure.ac
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
- fi
|
||||
|
||||
fi
|
||||
|
||||
@@ -1544,19 +1507,6 @@
|
||||
CPPFLAGS="$CLEANCPPFLAGS"
|
||||
])
|
||||
|
||||
- if test "x$USE_NSS" = "xyes"; then
|
||||
- AC_MSG_NOTICE([detected NSS version $version])
|
||||
-
|
||||
- dnl when shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to
|
||||
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
|
||||
- dnl due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$nssprefix/lib$libsuff"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $nssprefix/lib$libsuff to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
fi dnl NSS not disabled
|
||||
fi dnl GNUTLS not disabled
|
||||
|
Loading…
x
Reference in New Issue
Block a user