[package] update owfs to 2.8p1, patch from Nicolas Leonard

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22896 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2010-09-04 16:11:45 +00:00
parent 1245f038bc
commit a6cb3f59be
2 changed files with 20 additions and 79 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=owfs PKG_NAME:=owfs
PKG_VERSION:=2.7p21 PKG_VERSION:=2.8p1
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME) PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=8aea6f3bb0dc9fdb52ed3f0e9d84fa79 PKG_MD5SUM:=1f7e5482e86d7c2a916fc020b8d4d584
PKG_FIXUP:=libtool PKG_FIXUP:=libtool
PKG_INSTALL:=1 PKG_INSTALL:=1
@ -33,18 +33,18 @@ define Package/$(PKG_NAME)/Default
endef endef
define Package/$(PKG_NAME)/Default/description define Package/$(PKG_NAME)/Default/description
OWFS is a suite of programs that designed to make the 1-wire bus and its OWFS is a suite of programs that designed to make the 1-wire bus and its
devices easily accessible. The underlying priciple is to create a virtual devices easily accessible. The underlying priciple is to create a virtual
filesystem, with the unique ID being the directory, and the individual filesystem, with the unique ID being the directory, and the individual
properties of the device are represented as simple files that can be read properties of the device are represented as simple files that can be read
and written. and written.
Details of the individual slave or master design are hidden behind a Details of the individual slave or master design are hidden behind a
consistent interface. The goal is to provide an easy set of tools for a consistent interface. The goal is to provide an easy set of tools for a
software designer to create monitoring or control applications. There are software designer to create monitoring or control applications. There are
some performance enhancements in the implementation, including data caching, some performance enhancements in the implementation, including data caching,
parallel access to bus masters, and aggregation of device communication. parallel access to bus masters, and aggregation of device communication.
Still the fundemental goal has been ease of use, flexibility and correctness Still the fundemental goal has been ease of use, flexibility and correctness
rather than speed. rather than speed.
endef endef
@ -78,7 +78,7 @@ endef
define Package/libow/description define Package/libow/description
$(call Package/$(PKG_NAME)/Default/description) $(call Package/$(PKG_NAME)/Default/description)
This package contains the OWFS library. This package contains the OWFS library.
endef endef
@ -90,7 +90,7 @@ endef
define Package/libow-capi/description define Package/libow-capi/description
$(call Package/$(PKG_NAME)/Default/description) $(call Package/$(PKG_NAME)/Default/description)
This package contains the OWFS C-API library. This package contains the OWFS C-API library.
endef endef
@ -105,7 +105,7 @@ endef
define Package/owshell/description define Package/owshell/description
$(call Package/$(PKG_NAME)/Default/description) $(call Package/$(PKG_NAME)/Default/description)
This package contains the OWFS shell utilities. This package contains the OWFS shell utilities.
endef endef
@ -118,7 +118,7 @@ endef
define Package/owfs/description define Package/owfs/description
$(call Package/$(PKG_NAME)/Default/description) $(call Package/$(PKG_NAME)/Default/description)
This package contains the OWFS fuse filesystem. This package contains the OWFS fuse filesystem.
endef endef
@ -133,7 +133,7 @@ endef
define Package/owhttpd/description define Package/owhttpd/description
$(call Package/$(PKG_NAME)/Default/description) $(call Package/$(PKG_NAME)/Default/description)
This package contains the OWFS http server. This package contains the OWFS http server.
endef endef
@ -144,7 +144,7 @@ endef
define Package/owftpd/description define Package/owftpd/description
$(call Package/$(PKG_NAME)/Default/description) $(call Package/$(PKG_NAME)/Default/description)
This package contains the OWFS ftp server. This package contains the OWFS ftp server.
endef endef
@ -155,7 +155,7 @@ endef
define Package/owserver/description define Package/owserver/description
$(call Package/$(PKG_NAME)/Default/description) $(call Package/$(PKG_NAME)/Default/description)
This package contains the OWFS network server. This package contains the OWFS network server.
endef endef
@ -185,11 +185,6 @@ CONFIGURE_VARS += \
lt_cv_sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \ lt_cv_sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
shrext_cmds=".so" \ shrext_cmds=".so" \
define Build/Configure
(cd $(PKG_BUILD_DIR); ./bootstrap)
$(call Build/Configure/Default)
endef
define Build/InstallDev define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR)/usr/include $(INSTALL_DIR) $(STAGING_DIR)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/ow{capi,fs_config}.h $(STAGING_DIR)/usr/include/ $(CP) $(PKG_INSTALL_DIR)/usr/include/ow{capi,fs_config}.h $(STAGING_DIR)/usr/include/

View File

@ -1,54 +0,0 @@
--- owfs-2.2p0RC/configure.orig 2006-02-02 04:18:08.000000000 +0100
+++ owfs-2.2p0RC/configure 2006-02-08 20:30:34.000000000 +0100
@@ -8035,6 +8035,12 @@
else
sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
fi
+if test "x$lt_sys_lib_search_path_spec" != "x"; then
+ sys_lib_search_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
+fi
+if test "x$lt_sys_lib_dlsearch_path_spec" != "x"; then
+ sys_lib_dlsearch_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
+fi
need_lib_prefix=unknown
hardcode_into_libs=no
@@ -11827,6 +11833,12 @@
else
sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
fi
+if test "x$lt_sys_lib_search_path_spec" != "x"; then
+ sys_lib_search_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
+fi
+if test "x$lt_sys_lib_dlsearch_path_spec" != "x"; then
+ sys_lib_dlsearch_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
+fi
need_lib_prefix=unknown
hardcode_into_libs=no
@@ -15100,6 +15112,12 @@
else
sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
fi
+if test "x$lt_sys_lib_search_path_spec" != "x"; then
+ sys_lib_search_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
+fi
+if test "x$lt_sys_lib_dlsearch_path_spec" != "x"; then
+ sys_lib_dlsearch_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
+fi
need_lib_prefix=unknown
hardcode_into_libs=no
@@ -17574,6 +17592,12 @@
else
sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
fi
+if test "x$lt_sys_lib_search_path_spec" != "x"; then
+ sys_lib_search_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
+fi
+if test "x$lt_sys_lib_dlsearch_path_spec" != "x"; then
+ sys_lib_dlsearch_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
+fi
need_lib_prefix=unknown
hardcode_into_libs=no