[packages] net/shorewall: removed obsolete package. use the modular shorewall packages instead
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14129 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
589253e380
commit
a6cccf9185
@ -1,50 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2007 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
# $Id$
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=shorewall
|
|
||||||
PKG_VERSION:=3.4.8
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://www1.shorewall.net/pub/$(PKG_NAME)/3.4/$(PKG_NAME)-$(PKG_VERSION)/
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
||||||
PKG_MD5SUM:=9e56da17a2b6319d3d99c891f2dc1a60
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/shorewall
|
|
||||||
SECTION:=net
|
|
||||||
CATEGORY:=Network
|
|
||||||
DEPENDS:=+iptables +iptables-mod-extra +ip
|
|
||||||
TITLE:=Shorewall firewall
|
|
||||||
URL:=http://www.shorewall.net/
|
|
||||||
SUBMENU:=firewall
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/shorewall/description
|
|
||||||
Shorewall Firewall is an iptables-based firewall for Linux.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
rm -rf $(PKG_INSTALL_DIR)
|
|
||||||
mkdir -p $(PKG_INSTALL_DIR)
|
|
||||||
PREFIX=$(PKG_INSTALL_DIR) $(PKG_BUILD_DIR)/install.sh
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/shorewall/install
|
|
||||||
$(INSTALL_DIR) $(1)/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/$(PKG_NAME) $(1)/sbin
|
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
|
||||||
$(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
|
|
||||||
$(INSTALL_DIR) $(1)/usr/share
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall $(1)/usr/share
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/etc/shorewall $(1)/etc
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,shorewall))
|
|
@ -1,24 +0,0 @@
|
|||||||
#!/bin/sh /etc/rc.common
|
|
||||||
|
|
||||||
START=46
|
|
||||||
start() {
|
|
||||||
touch /var/log/messages
|
|
||||||
mkdir -p /var/lock/subsys
|
|
||||||
/sbin/shorewall -f start 1>/dev/null &
|
|
||||||
}
|
|
||||||
|
|
||||||
stop() {
|
|
||||||
/sbin/shorewall stop 1>/dev/null
|
|
||||||
}
|
|
||||||
|
|
||||||
restart() {
|
|
||||||
if [ -f /var/lib/shorewall/restore ] ; then
|
|
||||||
/sbin/shorewall restore
|
|
||||||
else
|
|
||||||
/sbin/shorewall restart 1>/dev/null
|
|
||||||
fi
|
|
||||||
}
|
|
||||||
clear() {
|
|
||||||
/sbin/shorewall clear
|
|
||||||
}
|
|
||||||
|
|
@ -1,31 +0,0 @@
|
|||||||
--- a/install.sh
|
|
||||||
+++ b/install.sh
|
|
||||||
@@ -676,28 +676,6 @@
|
|
||||||
fi
|
|
||||||
|
|
||||||
#
|
|
||||||
-# Install the Man Pages
|
|
||||||
-#
|
|
||||||
-
|
|
||||||
-cd manpages
|
|
||||||
-
|
|
||||||
-for f in *.5; do
|
|
||||||
- gzip -c $f > $f.gz
|
|
||||||
- run_install -D -m 0444 $f.gz ${PREFIX}/usr/share/man/man5/$f.gz
|
|
||||||
- echo "Man page $f.gz installed to /usr/share/man/man5/$f.gz"
|
|
||||||
-done
|
|
||||||
-
|
|
||||||
-for f in *.8; do
|
|
||||||
- gzip -c $f > $f.gz
|
|
||||||
- run_install -D -m 0444 $f.gz ${PREFIX}/usr/share/man/man8/$f.gz
|
|
||||||
- echo "Man page $f.gz installed to /usr/share/man/man8/$f.gz"
|
|
||||||
-done
|
|
||||||
-
|
|
||||||
-cd ..
|
|
||||||
-
|
|
||||||
-echo "Man Pages Installed"
|
|
||||||
-
|
|
||||||
-#
|
|
||||||
# Install the firewall script
|
|
||||||
#
|
|
||||||
install_file firewall ${PREFIX}/usr/share/shorewall/firewall 0555
|
|
Loading…
x
Reference in New Issue
Block a user