[packages] openntpd:
- don't check directory permissions, we can't make /var 0700 (#9258) - fix init script after r26148, use service_kill instead of killall -9 (#9258) - bump pkg revision git-svn-id: svn://svn.openwrt.org/openwrt/packages@26717 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
27081c4456
commit
a6d46ff650
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openntpd
|
||||
PKG_VERSION:=3.9p1
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
|
||||
|
@ -1,5 +1,5 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
|
||||
START=60
|
||||
|
||||
@ -8,12 +8,11 @@ boot() {
|
||||
}
|
||||
|
||||
start() {
|
||||
mkdir -p `awk -F: '/^ntp:/{print $6}' /etc/passwd`
|
||||
mkdir -p `awk -F: '/^network:/{print $6}' /etc/passwd`
|
||||
mkdir -p /var/db/
|
||||
/usr/sbin/ntpd -s
|
||||
}
|
||||
|
||||
stop() {
|
||||
# -1 seems insufficient to kill one of the two underlying processes.
|
||||
killall -9 ntpd
|
||||
service_kill ntpd
|
||||
}
|
||||
|
11
net/openntpd/patches/003-no_permission_check.patch
Normal file
11
net/openntpd/patches/003-no_permission_check.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/ntp.c
|
||||
+++ b/ntp.c
|
||||
@@ -111,8 +111,6 @@ ntp_main(int pipe_prnt[2], struct ntpd_c
|
||||
|
||||
if (stat(chrootdir, &stb) == -1)
|
||||
fatal("stat");
|
||||
- if (stb.st_uid != 0 || (stb.st_mode & (S_IWGRP|S_IWOTH)) != 0)
|
||||
- fatal("bad privsep dir permissions");
|
||||
if (chroot(chrootdir) == -1)
|
||||
fatal("chroot");
|
||||
if (chdir("/") == -1)
|
Loading…
x
Reference in New Issue
Block a user