motion: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41869 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
807f8090a8
commit
a729acf9d9
@ -1,52 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2008-2011 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=motion
|
|
||||||
PKG_VERSION:=20110826-051001
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
|
|
||||||
@SF/motion
|
|
||||||
PKG_MD5SUM:=e703fce57ae2215cb05f25e3027f5818
|
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/motion
|
|
||||||
SECTION:=multimedia
|
|
||||||
CATEGORY:=Multimedia
|
|
||||||
DEPENDS:=+libjpeg +libpthread
|
|
||||||
TITLE:=webcam motion sensing and logging
|
|
||||||
URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/motion/conffiles
|
|
||||||
/etc/motion.conf
|
|
||||||
endef
|
|
||||||
|
|
||||||
CONFIGURE_ARGS+= \
|
|
||||||
--without-optimizecpu \
|
|
||||||
--without-ffmpeg \
|
|
||||||
--without-jpeg-mmx \
|
|
||||||
--without-sdl \
|
|
||||||
--without-mysql \
|
|
||||||
--without-pgsql \
|
|
||||||
--without-sqlite3 \
|
|
||||||
|
|
||||||
define Package/motion/install
|
|
||||||
$(INSTALL_DIR) $(1)/etc
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
|
|
||||||
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,motion))
|
|
@ -1,19 +0,0 @@
|
|||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -31,6 +31,7 @@ examplesdir = $(datadir)/@PACKAGE_NAME@-
|
|
||||||
# install. #
|
|
||||||
################################################################################
|
|
||||||
CFLAGS = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\" -Dsysconfdir=\"$(sysconfdir)\"
|
|
||||||
+CPPFLAGS = @CPPFLAGS@
|
|
||||||
LDFLAGS = @LDFLAGS@
|
|
||||||
LIBS = @LIBS@
|
|
||||||
VIDEO_OBJ = @VIDEO@
|
|
||||||
@@ -118,7 +119,7 @@ endif
|
|
||||||
################################################################################
|
|
||||||
$(DEPEND_FILE): *.h $(SRC)
|
|
||||||
@echo "Generating dependencies, please wait..."
|
|
||||||
- @$(CC) $(CFLAGS) -M $(SRC) > .tmp
|
|
||||||
+ @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
|
|
||||||
@mv -f .tmp $(DEPEND_FILE)
|
|
||||||
@echo
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user