Update xterm to 242.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@14798 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
lars 2009-03-09 00:58:58 +00:00
parent 4656f4ad7e
commit a73c64c79c
3 changed files with 24 additions and 9 deletions

View File

@ -9,11 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=xterm
PKG_VERSION:=223
PKG_VERSION:=242
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.2/src/extras/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://mirror1.openwrt.org/
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@ -26,7 +27,7 @@ define Package/xterm
endef
define Build/Configure
sed -e "s%/usr/contrib/X11R6%${STAGING_DIR}/usr/lib%g" -i $(PKG_BUILD_DIR)/configure
# sed -e "s%/usr/contrib/X11R6%${STAGING_DIR}/usr/lib%g" -i $(PKG_BUILD_DIR)/configure
cd $(PKG_BUILD_DIR)/; $(TARGET_CONFIGURE_OPTS) $(CONFIGURE_VARS) \
$(CONFIGURE_CMD) \
$(CONFIGURE_ARGS_XTRA) \
@ -37,11 +38,6 @@ define Build/Configure
LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
endef
define Package/xterm/install
$(INSTALL_DIR) $(1)/usr/
$(CP) $(PKG_INSTALL_DIR)/usr/bin $(1)/usr/

View File

@ -0,0 +1,19 @@
diff --git a/Makefile.in b/Makefile.in
index 62a2882..159755b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -160,10 +160,10 @@ resize$x : $(OBJS2)
charproc$o : main.h @CHARPROC_DEPS@
################################################################################
-actual_xterm = `echo xterm| sed '$(transform)'`
-actual_resize = `echo resize| sed '$(transform)'`
-actual_uxterm = `echo uxterm| sed '$(transform)'`
-actual_k8term = `echo koi8rxterm| sed '$(transform)'`
+actual_xterm = xterm
+actual_resize = resize
+actual_uxterm = uxterm
+actual_k8term = koi8rxterm
binary_xterm = $(actual_xterm)$x
binary_resize = $(actual_resize)$x