[packages] collectd: fix iwinfo station count (#11639)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@32167 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-06-10 18:34:54 +00:00
parent 3259bec42c
commit a7444d99f7
2 changed files with 4 additions and 3 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=collectd
PKG_VERSION:=4.10.7
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://collectd.org/files/

View File

@ -97,7 +97,7 @@
The I<Java> plugin makes it possible to write extensions for collectd in Java.
--- /dev/null
+++ b/src/iwinfo.c
@@ -0,0 +1,149 @@
@@ -0,0 +1,150 @@
+/**
+ * collectd - src/iwinfo.c
+ * Copyright (C) 2011 Jo-Philipp Wich
@ -198,7 +198,8 @@
+
+ if (iw->assoclist(ifname, buf, &val))
+ val = 0;
+ iwinfo_submit(ifname, "stations", val);
+ iwinfo_submit(ifname, "stations",
+ val / sizeof(struct iwinfo_assoclist_entry));
+ }
+
+ iwinfo_finish();