[packages] znc: Fix a memory leak in CChan::AddNick()
Backport upstream fix reported by Olipro. Thanks! git-svn-id: svn://svn.openwrt.org/openwrt/packages@27798 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
247118515f
commit
a7a60f18ba
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=znc
|
||||
PKG_VERSION:=0.098
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://znc.in/releases
|
||||
|
14
net/znc/patches/004-fix_memleak.patch
Normal file
14
net/znc/patches/004-fix_memleak.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- a/Chan.cpp
|
||||
+++ b/Chan.cpp
|
||||
@@ -417,9 +417,10 @@ bool CChan::AddNick(const CString& sNick
|
||||
// Get the nick
|
||||
sTmp = sTmp.Token(0, false, "!");
|
||||
|
||||
+ CNick tmpNick(sTmp);
|
||||
CNick* pNick = FindNick(sTmp);
|
||||
if (!pNick) {
|
||||
- pNick = new CNick(sTmp);
|
||||
+ pNick = &tmpNick;
|
||||
pNick->SetUser(m_pUser);
|
||||
}
|
||||
|
Loading…
x
Reference in New Issue
Block a user