[package] update python to 2.6.4 (#6407, fixes #6192)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@18969 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-12-29 22:35:12 +00:00
parent 93cb4aae35
commit a87ce4ebce
3 changed files with 23 additions and 9 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python
PKG_VERSION:=2.6.1
PKG_VERSION:=2.6.4
PKG_RELEASE:=2
PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
PKG_MD5SUM:=e81c2f0953aa60f8062c05a4673f2be0
PKG_MD5SUM:=fee5408634a54e721a93531aba37f8c1
PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)

View File

@ -1,8 +1,8 @@
diff --git a/Lib/distutils/command/build_scripts.py b/Lib/distutils/command/build_scripts.py
index c0d8f70..d36e29c 100644
Index: build_scripts.py
===================================================================
--- a/Lib/distutils/command/build_scripts.py
+++ b/Lib/distutils/command/build_scripts.py
@@ -51,10 +51,7 @@ class build_scripts (Command):
@@ -52,10 +52,7 @@
def copy_scripts (self):
@ -10,11 +10,11 @@ index c0d8f70..d36e29c 100644
- Python script in the Unix way (first line matches 'first_line_re',
- ie. starts with "\#!" and contains "python"), then adjust the first
- line to refer to the current Python interpreter as we copy.
+ """Copy each script listed in 'self.scripts';
+ """Copy each script listed in 'self.scripts'
"""
self.mkpath(self.build_dir)
outfiles = []
@@ -77,41 +74,9 @@ class build_scripts (Command):
@@ -78,41 +75,9 @@
if not self.dry_run:
raise
f = None
@ -42,8 +42,8 @@ index c0d8f70..d36e29c 100644
- outf.write("#!%s%s\n" %
- (os.path.join(
- sysconfig.get_config_var("BINDIR"),
- "python" + sysconfig.get_config_var("VERSION")
- + sysconfig.get_config_var("EXE")),
- "python%s%s" % (sysconfig.get_config_var("VERSION"),
- sysconfig.get_config_var("EXE"))),
- post_interp))
- outf.writelines(f.readlines())
- outf.close()

View File

@ -0,0 +1,14 @@
Index: Lib/ctypes/__init__.py
===================================================================
--- a/Lib/ctypes/__init__.py (revision 77004)
+++ b/Lib/ctypes/__init__.py (working copy)
@@ -538,9 +538,3 @@
elif sizeof(kind) == 4: c_uint32 = kind
elif sizeof(kind) == 8: c_uint64 = kind
del(kind)
-
-# XXX for whatever reasons, creating the first instance of a callback
-# function is needed for the unittests on Win64 to succeed. This MAY
-# be a compiler bug, since the problem occurs only when _ctypes is
-# compiled with the MS SDK compiler. Or an uninitialized variable?
-CFUNCTYPE(c_int)(lambda: None)