python-imaging-library: moved to github
Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@43724 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b4cac959b0
commit
a89422f567
@ -1,59 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2011 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=python-imaging-library
|
|
||||||
PKG_VERSION:=1.1.7
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=Imaging-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://effbot.org/downloads
|
|
||||||
PKG_MD5SUM:=fc14a54e1ce02a0225be8854bfba478e
|
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/Imaging-$(PKG_VERSION)
|
|
||||||
PKG_BUILD_DEPENDS:=python
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
$(call include_mk, python-package.mk)
|
|
||||||
|
|
||||||
define Package/python-imaging-library
|
|
||||||
SECTION:=language-python
|
|
||||||
CATEGORY:=Languages
|
|
||||||
SUBMENU:=Python
|
|
||||||
TITLE:=Python Imaging Library (PIL)
|
|
||||||
URL:=http://www.pythonware.com/products/pil/
|
|
||||||
DEPENDS:=+python +libfreetype +libjpeg +zlib
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/python-imaging-library/description
|
|
||||||
The Python Imaging Library adds image processing capabilities to your
|
|
||||||
Python interpreter.
|
|
||||||
.
|
|
||||||
This library provides extensive file format support, an efficient
|
|
||||||
internal representation, and fairly powerful image processing
|
|
||||||
capabilities.
|
|
||||||
.
|
|
||||||
The core image library is designed for fast access to data stored in a
|
|
||||||
few basic pixel formats. It should provide a solid foundation for a
|
|
||||||
general image processing tool.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(call Build/Compile/PyMod,., \
|
|
||||||
install --prefix="/usr" --root="$(PKG_INSTALL_DIR)", \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/python-imaging-library/install
|
|
||||||
$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
|
|
||||||
$(CP) \
|
|
||||||
$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
|
|
||||||
$(1)$(PYTHON_PKG_DIR)/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,python-imaging-library))
|
|
@ -1,33 +0,0 @@
|
|||||||
--- a/setup.py 2011-11-15 01:06:00.000000000 +0100
|
|
||||||
+++ b/setup.py 2011-11-15 01:07:32.000000000 +0100
|
|
||||||
@@ -147,7 +147,6 @@
|
|
||||||
add_directory(library_dirs, "/opt/local/lib")
|
|
||||||
add_directory(include_dirs, "/opt/local/include")
|
|
||||||
|
|
||||||
- add_directory(library_dirs, "/usr/local/lib")
|
|
||||||
# FIXME: check /opt/stuff directories here?
|
|
||||||
|
|
||||||
prefix = sysconfig.get_config_var("prefix")
|
|
||||||
@@ -199,22 +198,6 @@
|
|
||||||
add_directory(include_dirs, include_root)
|
|
||||||
|
|
||||||
#
|
|
||||||
- # add standard directories
|
|
||||||
-
|
|
||||||
- # look for tcl specific subdirectory (e.g debian)
|
|
||||||
- if _tkinter:
|
|
||||||
- tcl_dir = "/usr/include/tcl" + TCL_VERSION
|
|
||||||
- if os.path.isfile(os.path.join(tcl_dir, "tk.h")):
|
|
||||||
- add_directory(include_dirs, tcl_dir)
|
|
||||||
-
|
|
||||||
- # standard locations
|
|
||||||
- add_directory(library_dirs, "/usr/local/lib")
|
|
||||||
- add_directory(include_dirs, "/usr/local/include")
|
|
||||||
-
|
|
||||||
- add_directory(library_dirs, "/usr/lib")
|
|
||||||
- add_directory(include_dirs, "/usr/include")
|
|
||||||
-
|
|
||||||
- #
|
|
||||||
# insert new dirs *before* default libs, to avoid conflicts
|
|
||||||
# between Python PYD stub libs and real libraries
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user