[packages] usbutils: Fix zlib support (#9216)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26660 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
443a725c57
commit
a8963bfdda
27
utils/usbutils/patches/120-fix-zlib-support.patch
Normal file
27
utils/usbutils/patches/120-fix-zlib-support.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
Index: usbutils-002/Makefile.am
|
||||||
|
===================================================================
|
||||||
|
--- usbutils-002.orig/Makefile.am 2011-04-14 14:33:22.000000000 +0300
|
||||||
|
+++ usbutils-002/Makefile.am 2011-04-14 14:33:32.000000000 +0300
|
||||||
|
@@ -6,9 +6,6 @@
|
||||||
|
|
||||||
|
data_DATA = \
|
||||||
|
usb.ids
|
||||||
|
-if HAVE_ZLIB
|
||||||
|
-data_DATA += usb.ids.gz
|
||||||
|
-endif
|
||||||
|
|
||||||
|
bin_PROGRAMS = \
|
||||||
|
lsusb
|
||||||
|
@@ -35,6 +32,12 @@
|
||||||
|
lsusb_LDADD = \
|
||||||
|
$(LIBUSB_LIBS)
|
||||||
|
|
||||||
|
+if HAVE_ZLIB
|
||||||
|
+data_DATA += usb.ids.gz
|
||||||
|
+lsusb_CPPFLAGS += -DHAVE_LIBZ
|
||||||
|
+lsusb_LDADD += -lz
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
man_MANS = \
|
||||||
|
lsusb.8 \
|
||||||
|
usb-devices.1
|
Loading…
x
Reference in New Issue
Block a user