[packages] 6tunnel: fix initalization of optc on arm, based on patch by Maxim Osipov <maxim.osipov@gmail.com>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@29809 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-01-19 16:08:49 +00:00
parent 979ab4aaf4
commit a8f17dd19d
2 changed files with 13 additions and 2 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007 OpenWrt.org
# Copyright (C) 2007-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=6tunnel
PKG_VERSION:=0.11rc2
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_MD5SUM:=74e02d4f0704b3083a01feda66033449
PKG_SOURCE_URL:=http://toxygen.net/6tunnel/

View File

@ -0,0 +1,11 @@
--- a/6tunnel.c
+++ b/6tunnel.c
@@ -508,7 +508,7 @@ int main(int argc, char **argv)
{
int force = 0, lsock, csock, one = 0, jeden = 1, local_port;
int detach = 1, listen6 = 0, sa_len, conn_limit = 0;
- char optc, *username = NULL, *bind_host = NULL;
+ char optc = -1, *username = NULL, *bind_host = NULL;
struct sockaddr *sa;
struct sockaddr_in laddr, caddr;
struct sockaddr_in6 laddr6;