packages: znc: update to 0.204
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29875 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d45ef2c11a
commit
a9c65a441f
@ -8,13 +8,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=znc
|
||||
PKG_VERSION:=0.202
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.204
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://znc.in/releases \
|
||||
http://znc.in/releases/archive
|
||||
PKG_MD5SUM:=3c6ff4620e139e3d9745cd53111bab20
|
||||
PKG_MD5SUM:=7c7247423fc08b0c5c62759a50a9bca3
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
@ -137,9 +137,6 @@ $(eval $(call module,adminlog,Log user connects and disconnects and failed \
|
||||
|
||||
$(eval $(call module,autoattach,Reattaches you to channels on activity.))
|
||||
|
||||
$(eval $(call module,autocycle,Cycles a channel when you are the only one in \
|
||||
there and you don't have op.))
|
||||
|
||||
$(eval $(call module,autoop,Auto op the good guys.))
|
||||
|
||||
$(eval $(call module,autoreply,Gives a automatic reply if someone messages you \
|
||||
@ -215,6 +212,9 @@ $(eval $(call module,watch,Monitor activity for specific text patterns from \
|
||||
|
||||
$(eval $(call module,antiidle,Hides your idle time.,extra/))
|
||||
|
||||
$(eval $(call module,autocycle,Cycles a channel when you are the only one in \
|
||||
there and you don't have op.,extra/))
|
||||
|
||||
$(eval $(call module,autovoice,Autovoices everyone who joins some channel., \
|
||||
extra/))
|
||||
|
||||
|
@ -9,7 +9,7 @@ Subject: [PATCH] Move the root check to after config parsing
|
||||
|
||||
--- a/main.cpp
|
||||
+++ b/main.cpp
|
||||
@@ -194,19 +194,6 @@ int main(int argc, char** argv) {
|
||||
@@ -211,19 +211,6 @@ int main(int argc, char** argv) {
|
||||
}
|
||||
#endif
|
||||
|
||||
@ -29,7 +29,7 @@ Subject: [PATCH] Move the root check to after config parsing
|
||||
if (bMakeConf) {
|
||||
if (!pZNC->WriteNewConfig(sConfig)) {
|
||||
delete pZNC;
|
||||
@@ -227,6 +214,20 @@ int main(int argc, char** argv) {
|
||||
@@ -244,6 +231,20 @@ int main(int argc, char** argv) {
|
||||
return 1;
|
||||
}
|
||||
|
||||
|
@ -23,7 +23,7 @@ Subject: [PATCH] Add a uClibc++ build workaround
|
||||
|
||||
/* Stuff to be able to write this:
|
||||
// i will be name of local variable, see below
|
||||
@@ -58,7 +60,7 @@ class CWebAdminMod : public CGlobalModul
|
||||
@@ -55,7 +57,7 @@ class CWebAdminMod : public CGlobalModul
|
||||
public:
|
||||
GLOBALMODCONSTRUCTOR(CWebAdminMod) {
|
||||
VPair vParams;
|
||||
|
@ -21,7 +21,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
|
||||
$(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MMD -MF .depend/$@.dep
|
||||
--- a/modules/Makefile.in
|
||||
+++ b/modules/Makefile.in
|
||||
@@ -114,7 +114,7 @@ install_metadirs: create_install_dir
|
||||
@@ -114,7 +114,7 @@ install_datadir:
|
||||
clean:
|
||||
rm -rf $(CLEAN)
|
||||
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- a/modules/bouncedcc.cpp
|
||||
+++ b/modules/bouncedcc.cpp
|
||||
@@ -238,7 +238,7 @@ class CBounceDCCMod : public CModule {
|
||||
CDCCBounce* pSock = (CDCCBounce*) *it;
|
||||
|
||||
if (pSock->GetLocalPort() == uResumePort) {
|
||||
- m_pUser->PutUser(":" + Nick.GetNickMask() + " PRIVMSG " + m_pClient->GetNick() + " :\001DCC " + sType + " " + sFile + " " + CString(pSock->GetUserPort()) + " " + sMessage.Token(4) + "\001");
|
||||
+ m_pUser->PutUser(":" + Nick.GetNickMask() + " PRIVMSG " + m_pUser->GetNick() + " :\001DCC " + sType + " " + sFile + " " + CString(pSock->GetUserPort()) + " " + sMessage.Token(4) + "\001");
|
||||
}
|
||||
}
|
||||
} else if (sType.Equals("ACCEPT")) {
|
||||
@@ -248,7 +248,7 @@ class CBounceDCCMod : public CModule {
|
||||
CDCCBounce* pSock = (CDCCBounce*) *it;
|
||||
|
||||
if (pSock->GetUserPort() == sMessage.Token(3).ToUShort()) {
|
||||
- m_pUser->PutUser(":" + Nick.GetNickMask() + " PRIVMSG " + m_pClient->GetNick() + " :\001DCC " + sType + " " + sFile + " " + CString(pSock->GetLocalPort()) + " " + sMessage.Token(4) + "\001");
|
||||
+ m_pUser->PutUser(":" + Nick.GetNickMask() + " PRIVMSG " + m_pUser->GetNick() + " :\001DCC " + sType + " " + sFile + " " + CString(pSock->GetLocalPort()) + " " + sMessage.Token(4) + "\001");
|
||||
}
|
||||
}
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user