miniupnpd: update v1.8.20130426 (#12997)
- pass network devices to miniupnpd - refresh patches git-svn-id: svn://svn.openwrt.org/openwrt/packages@36488 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
146c4e8891
commit
aa3a84461c
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=miniupnpd
|
PKG_NAME:=miniupnpd
|
||||||
PKG_VERSION:=1.8
|
PKG_VERSION:=1.8.20130426
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://miniupnp.free.fr/files
|
PKG_SOURCE_URL:=http://miniupnp.free.fr/files
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_MD5SUM:=0d8a8e936d5a0012cb260a3b972acbf3
|
PKG_MD5SUM:=ca5344eba200e4a6d1313849d68310f6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -106,9 +106,9 @@ start() {
|
|||||||
|
|
||||||
local iface
|
local iface
|
||||||
for iface in ${intiface:-lan}; do
|
for iface in ${intiface:-lan}; do
|
||||||
local ipnet
|
local device
|
||||||
network_get_subnet ipnet "$iface" && {
|
network_get_device device "$iface" && {
|
||||||
echo "listening_ip=$ipnet" >>$tmpconf
|
echo "listening_ip=$device" >>$tmpconf
|
||||||
}
|
}
|
||||||
done
|
done
|
||||||
|
|
||||||
|
@ -67,7 +67,7 @@
|
|||||||
|
|
||||||
if(bind(s, (struct sockaddr *)&listenname, listenname_len) < 0)
|
if(bind(s, (struct sockaddr *)&listenname, listenname_len) < 0)
|
||||||
{
|
{
|
||||||
@@ -1253,6 +1250,9 @@ main(int argc, char * * argv)
|
@@ -1254,6 +1251,9 @@ main(int argc, char * * argv)
|
||||||
int sudp = -1; /* IP v4 socket for receiving SSDP */
|
int sudp = -1; /* IP v4 socket for receiving SSDP */
|
||||||
#ifdef ENABLE_IPV6
|
#ifdef ENABLE_IPV6
|
||||||
int sudpv6 = -1; /* IP v6 socket for receiving SSDP */
|
int sudpv6 = -1; /* IP v6 socket for receiving SSDP */
|
||||||
@ -77,7 +77,7 @@
|
|||||||
#endif
|
#endif
|
||||||
#ifdef ENABLE_NATPMP
|
#ifdef ENABLE_NATPMP
|
||||||
int * snatpmp = NULL;
|
int * snatpmp = NULL;
|
||||||
@@ -1337,7 +1337,7 @@ main(int argc, char * * argv)
|
@@ -1338,7 +1338,7 @@ main(int argc, char * * argv)
|
||||||
{
|
{
|
||||||
|
|
||||||
/* open socket for HTTP connections. Listen on the 1st LAN address */
|
/* open socket for HTTP connections. Listen on the 1st LAN address */
|
||||||
@ -97,8 +97,8 @@
|
|||||||
i++;
|
i++;
|
||||||
#endif
|
#endif
|
||||||
}
|
}
|
||||||
@@ -406,6 +404,9 @@ SendSSDPNotifies(int s, const char * hos
|
@@ -495,6 +493,9 @@ SendSSDPNotifies(int s, const char * hos
|
||||||
char bufr[512];
|
int i=0;
|
||||||
char ver_str[4];
|
char ver_str[4];
|
||||||
|
|
||||||
+ if (s < 0)
|
+ if (s < 0)
|
||||||
@ -107,7 +107,7 @@
|
|||||||
memset(&sockname, 0, sizeof(sockname));
|
memset(&sockname, 0, sizeof(sockname));
|
||||||
#ifdef ENABLE_IPV6
|
#ifdef ENABLE_IPV6
|
||||||
if(ipv6)
|
if(ipv6)
|
||||||
@@ -739,6 +740,10 @@ SendSSDPGoodbye(int * sockets, int n_soc
|
@@ -868,6 +869,10 @@ SendSSDPGoodbye(int * sockets, int n_soc
|
||||||
#ifdef ENABLE_IPV6
|
#ifdef ENABLE_IPV6
|
||||||
ipv6 = j & 1;
|
ipv6 = j & 1;
|
||||||
#endif
|
#endif
|
||||||
|
Loading…
x
Reference in New Issue
Block a user