mocp: bumped version from 2.4.4 to 2.5.0-beta2 and removed obsolete patch
Added dependencies on libmagic, faad2 and libdb47 Signed-off-by: Michel Stempin <michel.stempin@wanadoo.fr> git-svn-id: svn://svn.openwrt.org/openwrt/packages@40643 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a9369e85df
commit
aa58ca3dc7
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=moc
|
PKG_NAME:=moc
|
||||||
PKG_VERSION:=2.4.4
|
PKG_VERSION:=2.5.0-beta2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=ftp://ftp.daper.net/pub/soft/moc/stable/
|
PKG_SOURCE_URL:=http://ftp.daper.net/pub/soft/moc/unstable/
|
||||||
PKG_MD5SUM:=647c770a5542a4ae5437386807a89796
|
PKG_MD5SUM:=da87b90b57934234589b63e347921458
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/nls.mk
|
|||||||
define Package/moc
|
define Package/moc
|
||||||
SECTION:=sound
|
SECTION:=sound
|
||||||
CATEGORY:=Sound
|
CATEGORY:=Sound
|
||||||
DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-utils +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg +libltdl
|
DEPENDS:=+libcurl +BUILD_PATENTED:libmad +libvorbis $(ICONV_DEPENDS) +alsa-utils +libid3tag +libflac +libsamplerate +PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libffmpeg-mini +libltdl +libmagic +faad2 +libdb47
|
||||||
TITLE:=Music On Console
|
TITLE:=Music On Console
|
||||||
URL:=http://moc.daper.net/
|
URL:=http://moc.daper.net/
|
||||||
endef
|
endef
|
||||||
@ -45,6 +45,7 @@ define Build/Configure
|
|||||||
--without-flac \
|
--without-flac \
|
||||||
--without-musepack \
|
--without-musepack \
|
||||||
--without-rcc \
|
--without-rcc \
|
||||||
|
$(if $(CONFIG_PACKAGE_libncursesw),--with-ncursesw --without-ncurses,--with-ncurses --without-ncursesw) \
|
||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -1,34 +0,0 @@
|
|||||||
--- a/decoder_plugins/ffmpeg/ffmpeg.c
|
|
||||||
+++ b/decoder_plugins/ffmpeg/ffmpeg.c
|
|
||||||
@@ -81,14 +81,14 @@ static void ffmpeg_info (const char *fil
|
|
||||||
}
|
|
||||||
|
|
||||||
if (tags_sel & TAGS_COMMENTS) {
|
|
||||||
- if (ic->track != 0)
|
|
||||||
- info->track = ic->track;
|
|
||||||
- if (ic->title[0] != 0)
|
|
||||||
- info->title = xstrdup (ic->title);
|
|
||||||
- if (ic->author[0] != 0)
|
|
||||||
- info->artist = xstrdup (ic->author);
|
|
||||||
- if (ic->album[0] != 0)
|
|
||||||
- info->album = xstrdup (ic->album);
|
|
||||||
+ if (av_metadata_get(ic->metadata, "track", NULL, 0) != NULL)
|
|
||||||
+ info->track = atoi(av_metadata_get(ic->metadata, "track", NULL, 0)->value);
|
|
||||||
+ if (av_metadata_get(ic->metadata, "title", NULL, 0) != NULL)
|
|
||||||
+ info->title = xstrdup (av_metadata_get(ic->metadata, "title", NULL, 0)->value);
|
|
||||||
+ if (av_metadata_get(ic->metadata, "author", NULL, 0) != NULL)
|
|
||||||
+ info->artist = xstrdup (av_metadata_get(ic->metadata, "author", NULL, 0)->value);
|
|
||||||
+ if (av_metadata_get(ic->metadata, "album", NULL, 0) != NULL)
|
|
||||||
+ info->album = xstrdup (av_metadata_get(ic->metadata, "album", NULL, 0)->value);
|
|
||||||
}
|
|
||||||
|
|
||||||
if (tags_sel & TAGS_TIME)
|
|
||||||
@@ -127,7 +127,7 @@ static void *ffmpeg_open (const char *fi
|
|
||||||
av_read_play (data->ic);
|
|
||||||
for (i = 0; i < data->ic->nb_streams; i++) {
|
|
||||||
data->enc = data->ic->streams[i]->codec;
|
|
||||||
- if (data->enc->codec_type == CODEC_TYPE_AUDIO) {
|
|
||||||
+ if (data->enc->codec_type == AVMEDIA_TYPE_AUDIO) {
|
|
||||||
audio_index = i;
|
|
||||||
break;
|
|
||||||
}
|
|
Loading…
x
Reference in New Issue
Block a user