[packages] elfutils: update to 0.147, use PKG_INSTALL, add MD5SUM, fix URL, cleanup (closes: #7290)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21384 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
031212daeb
commit
aaa0fef171
@ -7,11 +7,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=elfutils
|
PKG_NAME:=elfutils
|
||||||
PKG_VERSION:=0.143
|
PKG_VERSION:=0.147
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/elfutils/
|
PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/elfutils/
|
||||||
|
PKG_MD5SUM:=ccb6bba1d96c096f1b5dbd34444554a3
|
||||||
|
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -20,17 +23,16 @@ define Package/elfutils
|
|||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
DEPENDS:=+libintl
|
DEPENDS:=+libintl
|
||||||
TITLE:=ELF utilities
|
TITLE:=ELF utilities
|
||||||
URL:=https://fedorahosted.org/releases/e/l/elfutils/
|
URL:=https://fedorahosted.org/elfutils/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
CONFIGURE_OPTS += --disable-generic
|
CONFIGURE_OPTS += \
|
||||||
|
--disable-generic \
|
||||||
|
|
||||||
define Build/Compile
|
EXTRA_CPPFLAGS:=-I$(STAGING_DIR)/usr/lib/libintl/include
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/libelf \
|
EXTRA_LDFLAGS:=-L$(STAGING_DIR)/usr/lib/libintl/lib -lintl
|
||||||
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/lib/libintl/include" \
|
|
||||||
LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/libintl/lib -lintl" \
|
MAKE_PATH:=./libelf
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)"
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
$(INSTALL_DIR) $(1)/usr/include
|
||||||
@ -41,7 +43,7 @@ endef
|
|||||||
|
|
||||||
define Package/elfutils/install
|
define Package/elfutils/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_BUILD_DIR)/libelf/libelf.so* $(1)/usr/lib/
|
$(CP) $(PKG_BUILD_DIR)/libelf/libelf.so.* $(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,elfutils))
|
$(eval $(call BuildPackage,elfutils))
|
||||||
|
1298
libs/elfutils/patches/001-elfutils-portability.patch
Normal file
1298
libs/elfutils/patches/001-elfutils-portability.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,7 +1,6 @@
|
|||||||
diff -urN elfutils-0.143/Makefile.am elfutils-0.143.new/Makefile.am
|
--- a/Makefile.am
|
||||||
--- elfutils-0.143/Makefile.am 2009-02-11 02:14:48.000000000 +0100
|
+++ b/Makefile.am
|
||||||
+++ elfutils-0.143.new/Makefile.am 2010-03-14 19:32:48.000000000 +0100
|
@@ -31,7 +31,7 @@ pkginclude_HEADERS = version.h
|
||||||
@@ -31,7 +31,7 @@
|
|
||||||
|
|
||||||
# Add doc back when we have some real content.
|
# Add doc back when we have some real content.
|
||||||
SUBDIRS = config m4 lib libelf libebl libdwfl libdw libcpu libasm backends \
|
SUBDIRS = config m4 lib libelf libebl libdwfl libdw libcpu libasm backends \
|
||||||
@ -10,10 +9,9 @@ diff -urN elfutils-0.143/Makefile.am elfutils-0.143.new/Makefile.am
|
|||||||
|
|
||||||
EXTRA_DIST = elfutils.spec GPG-KEY NOTES EXCEPTION
|
EXTRA_DIST = elfutils.spec GPG-KEY NOTES EXCEPTION
|
||||||
|
|
||||||
diff -urN elfutils-0.143/Makefile.in elfutils-0.143.new/Makefile.in
|
--- a/Makefile.in
|
||||||
--- elfutils-0.143/Makefile.in 2009-09-21 17:43:49.000000000 +0200
|
+++ b/Makefile.in
|
||||||
+++ elfutils-0.143.new/Makefile.in 2010-03-14 19:32:56.000000000 +0100
|
@@ -248,7 +248,7 @@ pkginclude_HEADERS = version.h
|
||||||
@@ -246,7 +246,7 @@
|
|
||||||
|
|
||||||
# Add doc back when we have some real content.
|
# Add doc back when we have some real content.
|
||||||
SUBDIRS = config m4 lib libelf libebl libdwfl libdw libcpu libasm backends \
|
SUBDIRS = config m4 lib libelf libebl libdwfl libdw libcpu libasm backends \
|
||||||
|
@ -1,62 +1,22 @@
|
|||||||
diff -urN elfutils-0.143/src/Makefile.am elfutils-0.143.new/src/Makefile.am
|
--- a/src/Makefile.in
|
||||||
--- elfutils-0.143/src/Makefile.am 2009-07-25 21:44:03.000000000 +0200
|
+++ b/src/Makefile.in
|
||||||
+++ elfutils-0.143.new/src/Makefile.am 2010-03-14 19:41:18.000000000 +0100
|
@@ -321,7 +321,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
|
||||||
@@ -31,8 +31,8 @@
|
-I$(srcdir)/../libdw -I$(srcdir)/../libdwfl \
|
||||||
else
|
-I$(srcdir)/../libasm
|
||||||
AM_CFLAGS =
|
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||||
endif
|
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||||
-AM_CFLAGS += -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
|
+ $($(*F)_no_Werror),,) $(if \
|
||||||
- $(if $($(*F)_no_Werror),,-Werror) \
|
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||||
+AM_CFLAGS += -Wall -Wshadow -std=gnu99 -Wno-error $(native_ld_cflags) \
|
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||||
+ $(if $($(*F)_no_Werror),,) \
|
$(am__append_1)
|
||||||
$(if $($(*F)_no_Wunused),,-Wunused -Wextra) \
|
--- a/libelf/Makefile.in
|
||||||
$(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $(CFLAGS_$(*F))
|
+++ b/libelf/Makefile.in
|
||||||
|
@@ -279,7 +279,7 @@ top_srcdir = @top_srcdir@
|
||||||
diff -urN elfutils-0.143/src/Makefile.in elfutils-0.143.new/src/Makefile.in
|
|
||||||
--- elfutils-0.143/src/Makefile.in 2009-09-21 17:43:50.000000000 +0200
|
|
||||||
+++ elfutils-0.143.new/src/Makefile.in 2010-03-14 19:40:45.000000000 +0100
|
|
||||||
@@ -314,13 +314,13 @@
|
|
||||||
zip_LIBS = @zip_LIBS@
|
zip_LIBS = @zip_LIBS@
|
||||||
@MUDFLAP_FALSE@AM_CFLAGS = -Wall -Wshadow -std=gnu99 \
|
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I..
|
||||||
@MUDFLAP_FALSE@ $(native_ld_cflags) $(if \
|
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||||
-@MUDFLAP_FALSE@ $($(*F)_no_Werror),,-Werror) $(if \
|
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||||
+@MUDFLAP_FALSE@ $($(*F)_no_Werror),,) $(if \
|
+ $($(*F)_no_Werror),,) $(if \
|
||||||
@MUDFLAP_FALSE@ $($(*F)_no_Wunused),,-Wunused -Wextra) $(if \
|
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||||
@MUDFLAP_FALSE@ $($(*F)_no_Wformat),-Wno-format,-Wformat=2) \
|
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||||
@MUDFLAP_FALSE@ $(CFLAGS_$(*F))
|
$(am__append_1) $(am__append_2)
|
||||||
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap -Wall -Wshadow -std=gnu99 \
|
|
||||||
@MUDFLAP_TRUE@ $(native_ld_cflags) $(if \
|
|
||||||
-@MUDFLAP_TRUE@ $($(*F)_no_Werror),,-Werror) $(if \
|
|
||||||
+@MUDFLAP_TRUE@ $($(*F)_no_Werror),,) $(if \
|
|
||||||
@MUDFLAP_TRUE@ $($(*F)_no_Wunused),,-Wunused -Wextra) $(if \
|
|
||||||
@MUDFLAP_TRUE@ $($(*F)_no_Wformat),-Wno-format,-Wformat=2) \
|
|
||||||
@MUDFLAP_TRUE@ $(CFLAGS_$(*F))
|
|
||||||
diff -urN elfutils-0.143/libelf/Makefile.am elfutils-0.143.new/libelf/Makefile.am
|
|
||||||
--- elfutils-0.143/libelf/Makefile.am 2009-08-12 16:23:22.000000000 +0200
|
|
||||||
+++ elfutils-0.143.new/libelf/Makefile.am 2010-03-14 20:01:28.000000000 +0100
|
|
||||||
@@ -33,7 +33,7 @@
|
|
||||||
if BUILD_STATIC
|
|
||||||
AM_CFLAGS += -fpic
|
|
||||||
endif
|
|
||||||
-AM_CFLAGS += -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 -std=gnu99 \
|
|
||||||
+AM_CFLAGS += -Wall -Wshadow -Wunused -Wextra -Wformat=2 -std=gnu99 \
|
|
||||||
$($(*F)_CFLAGS)
|
|
||||||
INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
|
|
||||||
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
|
||||||
diff -urN elfutils-0.143/libelf/Makefile.in elfutils-0.143.new/libelf/Makefile.in
|
|
||||||
--- elfutils-0.143/libelf/Makefile.in 2009-09-21 17:43:50.000000000 +0200
|
|
||||||
+++ elfutils-0.143.new/libelf/Makefile.in 2010-03-14 20:01:16.000000000 +0100
|
|
||||||
@@ -274,11 +274,11 @@
|
|
||||||
top_builddir = @top_builddir@
|
|
||||||
top_srcdir = @top_srcdir@
|
|
||||||
zip_LIBS = @zip_LIBS@
|
|
||||||
-@MUDFLAP_FALSE@AM_CFLAGS = $(am__append_1) -Wall -Wshadow -Werror \
|
|
||||||
+@MUDFLAP_FALSE@AM_CFLAGS = $(am__append_1) -Wall -Wshadow \
|
|
||||||
@MUDFLAP_FALSE@ -Wunused -Wextra -Wformat=2 -std=gnu99 \
|
|
||||||
@MUDFLAP_FALSE@ $($(*F)_CFLAGS)
|
|
||||||
@MUDFLAP_TRUE@AM_CFLAGS = -fmudflap $(am__append_1) -Wall -Wshadow \
|
|
||||||
-@MUDFLAP_TRUE@ -Werror -Wunused -Wextra -Wformat=2 -std=gnu99 \
|
|
||||||
+@MUDFLAP_TRUE@ -Wunused -Wextra -Wformat=2 -std=gnu99 \
|
|
||||||
@MUDFLAP_TRUE@ $($(*F)_CFLAGS)
|
|
||||||
INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
|
|
||||||
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
|
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- elfutils-0.143/libelf/libelf.h 2009-06-14 00:24:43.000000000 +0200
|
--- a/libelf/libelf.h
|
||||||
+++ elfutils-0.143.new/libelf/libelf.h 2010-03-14 20:14:09.000000000 +0100
|
+++ b/libelf/libelf.h
|
||||||
@@ -55,6 +55,11 @@
|
@@ -55,6 +55,11 @@
|
||||||
/* Get the ELF types. */
|
/* Get the ELF types. */
|
||||||
#include <elf.h>
|
#include <elf.h>
|
||||||
|
Loading…
x
Reference in New Issue
Block a user