adds patch package
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11430 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0785e183ca
commit
ab063f17b5
@ -18,7 +18,7 @@ define Package/build-essential
|
||||
SECTION:=devel
|
||||
CATEGORY:=Development
|
||||
TITLE:=Build essentials
|
||||
DEPENDS=+gcc +make +binutils @BUILD_DEVELOPER_SYSTEM
|
||||
DEPENDS=+gcc +make +binutils +patch @BUILD_DEVELOPER_SYSTEM
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
|
43
devel/patch/Makefile
Normal file
43
devel/patch/Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
#
|
||||
# Copyright (C) 2008 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=patch
|
||||
PKG_VERSION:=2.5.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=ee5ae84d115f051d87fcaaef3b4ae782
|
||||
PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/patch/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/patch
|
||||
SECTION:=devel
|
||||
CATEGORY:=Development
|
||||
TITLE:=patch
|
||||
URL:=http://www.gnu.org/
|
||||
endef
|
||||
|
||||
define Package/patch/description
|
||||
The Patch package contains a program for modifying or creating files by applying a "patch" file typically created by the diff program.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE_VARS) $(MAKE) $(MAKE_ARGS) DESTDIR=$(PKG_INSTALL_DIR) exec_prefix=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) all install
|
||||
endef
|
||||
|
||||
define Package/patch/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/patch $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,patch))
|
18
devel/patch/patches/100-install.patch
Normal file
18
devel/patch/patches/100-install.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff -urN patch-2.5.4.orig/Makefile.in patch-2.5.4/Makefile.in
|
||||
--- patch-2.5.4.orig/Makefile.in 2008-06-11 10:08:08.000000000 +0200
|
||||
+++ patch-2.5.4/Makefile.in 2008-06-11 10:08:26.000000000 +0200
|
||||
@@ -42,12 +42,12 @@
|
||||
VERSION = @VERSION@
|
||||
|
||||
prefix = @prefix@
|
||||
-exec_prefix = @exec_prefix@
|
||||
+exec_prefix += @exec_prefix@
|
||||
|
||||
bindir = $(exec_prefix)/bin
|
||||
|
||||
# Where to put the manual pages.
|
||||
-mandir = @mandir@
|
||||
+mandir = $(exec_prefix)/@mandir@
|
||||
man1dir = $(mandir)/man1
|
||||
# Extension (including `.') for the manual page filenames.
|
||||
man1ext = .1
|
Loading…
x
Reference in New Issue
Block a user