classpath: moved to github

git-svn-id: svn://svn.openwrt.org/openwrt/packages@43864 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cyrus 2015-01-06 17:18:40 +00:00
parent 92ec35c888
commit abdea01003
2 changed files with 0 additions and 102 deletions

View File

@ -1,88 +0,0 @@
#
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=classpath
PKG_VERSION:=0.98
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/classpath
PKG_MD5SUM:=90c6571b8b0309e372faa0f9f6255ea9
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/classpath
SECTION:=libs
CATEGORY:=Libraries
TITLE:=GNU Classpath
URL:=http://www.gnu.org/software/classpath/
MAINTAINER:=Roberto Riggio <roberto.riggio@create-net.org>
DEPENDS:=+alsa-lib +libgmp +libmagic
endef
define Package/classpath/Description
GNU Classpath, Essential Libraries for Java, is a GNU project
to create free core class libraries for use with virtual
machines and compilers for the java programming language.
endef
define Package/classpath-tools
SECTION:=libs
CATEGORY:=Libraries
TITLE:=GNU Classpath tools
URL:=http://www.gnu.org/software/classpath/
MAINTAINER:=Roberto Riggio <roberto.riggio@create-net.org>
endef
define Download/antlr
URL:=http://www.antlr.org/download
FILE:=antlr-3.4-complete.jar
MD5SUM:=1b91dea1c7d480b3223f7c8a9aa0e172
endef
$(eval $(call Download,antlr))
CONFIGURE_ARGS += \
--without-x \
--disable-gtk-peer \
--disable-qt-peer \
--disable-dssi \
--disable-plugin \
--disable-gconf-peer \
--disable-gjdoc \
--with-antlr-jar=$(DL_DIR)/antlr-3.4-complete.jar
define Package/classpath/install
$(INSTALL_DIR) \
$(1)/usr/lib/classpath \
$(1)/usr/share/classpath
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/security \
$(PKG_INSTALL_DIR)/usr/lib/logging.properties \
$(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/classpath/*.so* $(1)/usr/lib/classpath/
$(CP) $(PKG_INSTALL_DIR)/usr/share/classpath/glibj.zip $(1)/usr/share/classpath/
endef
define Package/classpath-tools/install
$(INSTALL_DIR) \
$(1)/usr/bin \
$(1)/usr/share/classpath
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/share/classpath/tools.zip $(1)/usr/share/classpath/
endef
define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
endef
$(eval $(call BuildPackage,classpath))
$(eval $(call BuildPackage,classpath-tools))

View File

@ -1,14 +0,0 @@
Index: classpath-0.98/configure.ac
===================================================================
--- classpath-0.98.orig/configure.ac 2009-02-06 00:26:08.000000000 +0100
+++ classpath-0.98/configure.ac 2012-08-22 10:18:53.325876508 +0200
@@ -762,8 +762,7 @@
dnl change the name of the corresponding ac_ variable on lines 860...
if test "x${COMPILE_GMP}" = xyes; then
AC_CHECK_LIB(gmp, __gmpz_mul_si,
- [GMP_CFLAGS=-I/usr/include
- GMP_LIBS=-lgmp ],
+ [GMP_LIBS=-lgmp ],
[GMP_CFLAGS=
GMP_LIBS= ])
AC_SUBST(GMP_CFLAGS)