[packages] nprobe: fix autoreconf

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24668 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2010-12-18 17:19:17 +00:00
parent ab203870ac
commit ac8ac6235a
4 changed files with 55 additions and 86067 deletions

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,46 @@
--- /dev/null
+++ b/acinclude.m4
@@ -0,0 +1 @@
+sinclude(acinclude.m4.in)
--- a/acinclude.m4.in
+++ b/acinclude.m4.in
@@ -120,7 +120,7 @@ else
esac
fi
msg="enabled"
-AC_DEFINE(DEBUG)
+AC_DEFINE([DEBUG], [], [Enable debugging])
],[
if test ".$ac_cv_prog_gcc" = ".yes"; then
case "$CFLAGS" in
--- a/configure.in
+++ b/configure.in
@@ -13,18 +13,16 @@ AC_REVISION([1.0])
dnl> acconfig.h is deprecated
-AH_TEMPLATE([ HAVE_UINT64_T ],)
-AH_TEMPLATE([ HAVE_U_INT64_T ],)
-AH_TEMPLATE([ HAVE_U_INT32_T ],)
-AH_TEMPLATE([ HAVE_U_INT16_T ],)
-AH_TEMPLATE([ HAVE_U_INT8_T ],)
-AH_TEMPLATE([ HAVE_INT64_T ],)
-AH_TEMPLATE([ HAVE_INT32_T ],)
-AH_TEMPLATE([ HAVE_INT16_T ],)
-AH_TEMPLATE([ HAVE_INT8_T ],)
-AH_TEMPLATE([ u_int],)
-AH_TEMPLATE([ HAVE_ZLIB ], [ Define if you have zlib ])
-AH_TEMPLATE([ DEBUG ], [ Define if you want a debugging version.])
+AC_DEFINE([HAVE_UINT64_T], [], [Define if you have uint64_t])
+AC_DEFINE([HAVE_U_INT64_T], [], [Define if you have u_int64_t])
+AC_DEFINE([HAVE_U_INT32_T], [], [Define if you have u_int32_t])
+AC_DEFINE([HAVE_U_INT16_T], [], [Define if you have u_int16_t])
+AC_DEFINE([HAVE_U_INT8_T], [], [Define if you have u_int8_t])
+AC_DEFINE([HAVE_INT64_T], [], [Define if you have int64_t])
+AC_DEFINE([HAVE_INT32_T], [], [Define if you have int32_t])
+AC_DEFINE([HAVE_INT16_T], [], [Define if you have int16_t])
+AC_DEFINE([HAVE_INT8_T], [], [Define if you have int8_t])
+AC_DEFINE([HAVE_ZLIB], [], [Define if you have zlib])
echo
echo "Welcome to $PACKAGE_NAME, Version $PACKAGE_VERSION"

View File

@ -1,7 +1,7 @@
--- nProbe/configure 2007-05-07 16:42:28.041884250 -0500 --- a/configure.in
+++ nProbe.new/configure 2007-05-07 16:57:49.183452000 -0500 +++ b/configure.in
@@ -23567,8 +23567,8 @@ @@ -331,8 +331,8 @@ dnl> user defined directory passed as op
dnl>
if test ".${PCAP_ROOT}" != .; then if test ".${PCAP_ROOT}" != .; then
if test -d $PCAP_ROOT && if test -d $PCAP_ROOT &&
- test -r $PCAP_ROOT/libpcap.a && - test -r $PCAP_ROOT/libpcap.a &&

View File

@ -1,6 +1,6 @@
--- nProbe/nprobe.c 2006-06-09 05:30:39.000000000 -0500 --- a/nprobe.c
+++ nProbe.new/nprobe.c 2007-05-07 17:35:37.677224000 -0500 +++ b/nprobe.c
@@ -241,8 +241,10 @@ @@ -241,8 +241,10 @@ void processPacket(u_char *_deviceId,
u_short eth_type, off=0, numPkts = 1; u_short eth_type, off=0, numPkts = 1;
u_int8_t flags = 0, proto = 0; u_int8_t flags = 0, proto = 0;
struct ip ip; struct ip ip;
@ -11,7 +11,7 @@
struct tcphdr tp; struct tcphdr tp;
struct udphdr up; struct udphdr up;
struct icmp icmpPkt; struct icmp icmpPkt;
@@ -362,7 +364,9 @@ @@ -362,7 +364,9 @@ void processPacket(u_char *_deviceId,
isFragment = (ntohs(ip.ip_off) & 0x3fff) ? 1 : 0; isFragment = (ntohs(ip.ip_off) & 0x3fff) ? 1 : 0;
off = ntohs(ip.ip_off); off = ntohs(ip.ip_off);
@ -22,7 +22,7 @@
memcpy(&ipv6, p+ehshift, sizeof(struct ip6_hdr)); memcpy(&ipv6, p+ehshift, sizeof(struct ip6_hdr));
if(((ipv6.ip6_vfc >> 4) & 0x0f) != 6) return; /* IP v6 only */ if(((ipv6.ip6_vfc >> 4) & 0x0f) != 6) return; /* IP v6 only */
estimatedLen = sizeof(struct ip6_hdr)+ehshift+htons(ipv6.ip6_plen); estimatedLen = sizeof(struct ip6_hdr)+ehshift+htons(ipv6.ip6_plen);
@@ -392,7 +396,9 @@ @@ -392,7 +396,9 @@ void processPacket(u_char *_deviceId,
hlen += (ipv6ext.ip6e_len+1)*8; hlen += (ipv6ext.ip6e_len+1)*8;
proto = ipv6ext.ip6e_nxt; proto = ipv6ext.ip6e_nxt;
} }