gnupg:
* Update 1.4.2.1 > 1.4.7 * Cleanup Makefile * Don't build po and docs git-svn-id: svn://svn.openwrt.org/openwrt/packages@8671 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d1cb1e20ea
commit
adf3cec36b
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2007 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -9,50 +9,49 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gnupg
|
PKG_NAME:=gnupg
|
||||||
PKG_VERSION:=1.4.2.1
|
PKG_VERSION:=1.4.7
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
|
PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
|
||||||
ftp://ftp.gnupg.org/gcrypt/gnupg
|
ftp://ftp.gnupg.org/gcrypt/gnupg
|
||||||
PKG_MD5SUM:=2d59ed50d92f69994dbfbe00fe1612e4
|
PKG_MD5SUM:=b06a141cca5cd1a55bbdd25ab833303c
|
||||||
PKG_CAT:=bzcat
|
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/gnupg
|
define Package/gnupg
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
TITLE:=GNU Privacy Guard
|
DEPENDS:=+zlib +libncurses +libreadline
|
||||||
DESCRIPTION:=\
|
TITLE:=GNU privacy guard - a free PGP replacement
|
||||||
GPG is an encryption program.
|
|
||||||
URL:=http://www.gnupg.org/
|
URL:=http://www.gnupg.org/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
define Package/gnupg/description
|
||||||
$(call Build/Configure/Default, \
|
GnuPG is GNU's tool for secure communication and data storage.
|
||||||
--disable-rpath \
|
It can be used to encrypt data and to create digital signatures.
|
||||||
--disable-asm \
|
It includes an advanced key management facility and is compliant
|
||||||
--disable-gnupg-iconv \
|
with the proposed OpenPGP Internet standard as described in RFC2440.
|
||||||
--disable-card-support \
|
|
||||||
--disable-agent-support \
|
GnuPG does not use any patented algorithms so it cannot be compatible
|
||||||
--disable-bzip2 \
|
with PGP2 because it uses IDEA (which is patented worldwide).
|
||||||
--disable-exec \
|
|
||||||
--disable-ldap \
|
|
||||||
--disable-hkp \
|
|
||||||
--disable-finger \
|
|
||||||
--disable-ftp \
|
|
||||||
--disable-dns-srv \
|
|
||||||
--enable-fake-curl \
|
|
||||||
--disable-regex \
|
|
||||||
)
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
CONFIGURE_ARGS += \
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
--disable-rpath \
|
||||||
endef
|
--disable-asm \
|
||||||
|
--disable-gnupg-iconv \
|
||||||
|
--disable-card-support \
|
||||||
|
--disable-agent-support \
|
||||||
|
--disable-bzip2 \
|
||||||
|
--disable-exec \
|
||||||
|
--disable-ldap \
|
||||||
|
--disable-hkp \
|
||||||
|
--disable-finger \
|
||||||
|
--disable-ftp \
|
||||||
|
--disable-dns-srv \
|
||||||
|
--enable-fake-curl \
|
||||||
|
--disable-regex \
|
||||||
|
|
||||||
define Package/gnupg/install
|
define Package/gnupg/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
13
utils/gnupg/patches/001-no_po_and_docs.patch
Normal file
13
utils/gnupg/patches/001-no_po_and_docs.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: gnupg-1.4.7/Makefile.in
|
||||||
|
===================================================================
|
||||||
|
--- gnupg-1.4.7.orig/Makefile.in 2007-09-07 18:53:42.000000000 +0200
|
||||||
|
+++ gnupg-1.4.7/Makefile.in 2007-09-07 18:53:42.000000000 +0200
|
||||||
|
@@ -311,7 +311,7 @@
|
||||||
|
AUTOMAKE_OPTIONS = dist-bzip2 filename-length-max=99
|
||||||
|
@CROSS_COMPILING_FALSE@checks = checks
|
||||||
|
@CROSS_COMPILING_TRUE@checks =
|
||||||
|
-SUBDIRS = m4 intl zlib util mpi cipher tools g10 keyserver po doc ${checks}
|
||||||
|
+SUBDIRS = m4 intl zlib util mpi cipher tools g10 keyserver ${checks}
|
||||||
|
EXTRA_DIST = scripts/config.rpath PROJECTS BUGS config.h.in autogen.sh
|
||||||
|
DISTCLEANFILES =
|
||||||
|
all: config.h
|
Loading…
x
Reference in New Issue
Block a user