[packages] gstreamer: update grammar.y to build with bison 3
In gstreamer's gst/parse/grammar.y, YYLEX_PARAM is no longer supported in bison 3. Replace YYLEX_PARAM with %lex-param. Signed-off-by John Vogel <jvogel4@stny.rr.com> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39182 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d14777943b
commit
aeed132f50
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2008-2012 OpenWrt.org
|
||||
# Copyright (C) 2008-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gstreamer
|
||||
PKG_VERSION:=0.10.36
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
|
||||
@ -190,4 +190,3 @@ $(eval $(call GstBuildLibrary,net,network classes))
|
||||
$(eval $(call BuildPackage,gstreamer))
|
||||
$(eval $(call BuildPackage,gstreamer-utils))
|
||||
$(eval $(call BuildPackage,libgstreamer))
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
||||
common
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -445,7 +445,6 @@ aclocaldir = $(datadir)/aclocal
|
||||
@@ -469,7 +469,6 @@ aclocaldir = $(datadir)/aclocal
|
||||
aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
|
||||
SUBDIRS = pkgconfig \
|
||||
gst libs plugins tools tests \
|
||||
@ -26,7 +26,7 @@
|
||||
po \
|
||||
m4 \
|
||||
common
|
||||
@@ -454,7 +453,6 @@ SUBDIRS = pkgconfig \
|
||||
@@ -478,7 +477,6 @@ SUBDIRS = pkgconfig \
|
||||
# These are all the possible subdirs
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
gst libs plugins tools tests \
|
||||
|
@ -19,7 +19,7 @@
|
||||
common
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -444,7 +444,7 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk
|
||||
@@ -468,7 +468,7 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk
|
||||
aclocaldir = $(datadir)/aclocal
|
||||
aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
|
||||
SUBDIRS = pkgconfig \
|
||||
@ -28,7 +28,7 @@
|
||||
po \
|
||||
m4 \
|
||||
common
|
||||
@@ -452,7 +452,7 @@ SUBDIRS = pkgconfig \
|
||||
@@ -476,7 +476,7 @@ SUBDIRS = pkgconfig \
|
||||
|
||||
# These are all the possible subdirs
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -695,7 +695,6 @@ libs/gst/net/Makefile
|
||||
@@ -763,7 +763,6 @@ libs/gst/net/Makefile
|
||||
plugins/Makefile
|
||||
plugins/indexers/Makefile
|
||||
plugins/elements/Makefile
|
||||
@ -27,7 +27,7 @@
|
||||
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -445,7 +445,6 @@ aclocaldir = $(datadir)/aclocal
|
||||
@@ -469,7 +469,6 @@ aclocaldir = $(datadir)/aclocal
|
||||
aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
|
||||
SUBDIRS = pkgconfig \
|
||||
gst libs plugins tools \
|
||||
@ -35,7 +35,7 @@
|
||||
m4 \
|
||||
common
|
||||
|
||||
@@ -453,7 +452,6 @@ SUBDIRS = pkgconfig \
|
||||
@@ -477,7 +476,6 @@ SUBDIRS = pkgconfig \
|
||||
# These are all the possible subdirs
|
||||
DIST_SUBDIRS = pkgconfig \
|
||||
gst libs plugins tools \
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- gstreamer-0.10.36/gst/gstinfo.c 2011-12-30 02:14:34.000000000 +0100
|
||||
+++ gstreamer-0.10.36.modified/gst/gstinfo.c 2013-01-03 14:01:37.000000000 +0100
|
||||
@@ -462,6 +462,39 @@
|
||||
--- a/gst/gstinfo.c
|
||||
+++ b/gst/gstinfo.c
|
||||
@@ -462,6 +462,39 @@ gst_debug_log (GstDebugCategory * catego
|
||||
va_end (var_args);
|
||||
}
|
||||
|
||||
@ -40,4 +40,3 @@
|
||||
#ifdef _MSC_VER
|
||||
/* based on g_basename(), which we can't use because it was deprecated */
|
||||
static inline const gchar *
|
||||
|
||||
|
@ -0,0 +1,27 @@
|
||||
From 60516f4798894f958fc53b470e1283318d0f8706 Mon Sep 17 00:00:00 2001
|
||||
From: Kerrick Staley <kerrick@kerrickstaley.com>
|
||||
Date: Wed, 21 Aug 2013 06:59:29 +0000
|
||||
Subject: parse: make grammar.y work with Bison 3
|
||||
|
||||
YYLEX_PARAM is no longer supported in Bison 3.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=706462
|
||||
---
|
||||
--- a/gst/parse/grammar.y
|
||||
+++ b/gst/parse/grammar.y
|
||||
@@ -26,7 +26,6 @@
|
||||
*/
|
||||
|
||||
#define YYERROR_VERBOSE 1
|
||||
-#define YYLEX_PARAM scanner
|
||||
|
||||
#define YYENABLE_NLS 0
|
||||
|
||||
@@ -648,6 +647,7 @@ static int yyerror (void *scanner, graph
|
||||
%right '.'
|
||||
%left '!' '='
|
||||
|
||||
+%lex-param { void *scanner }
|
||||
%parse-param { void *scanner }
|
||||
%parse-param { graph_t *graph }
|
||||
%pure-parser
|
Loading…
x
Reference in New Issue
Block a user