click: broken for ages, moved to abandoned github feed
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@44474 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
93cb95ff09
commit
af46a17980
@ -1,75 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2010 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=click
|
|
||||||
PKG_VERSION:=20101020
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
PKG_REV:=8f521a2dcd58ea8205b3b6070be605a21fb9154b
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=git://read.cs.ucla.edu/git/click
|
|
||||||
PKG_SOURCE_PROTO:=git
|
|
||||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_MD5SUM:=c3cba1c923d0a034cc518720b5ba7b40
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/click
|
|
||||||
SECTION:=net
|
|
||||||
CATEGORY:=Network
|
|
||||||
DEPENDS:=@BROKEN
|
|
||||||
TITLE:=Click Modular Router
|
|
||||||
URL:=http://read.cs.ucla.edu/click
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/click/Description
|
|
||||||
The Click Modular Router userspace package
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += "-static -O2 -MD"
|
|
||||||
TARGET_CXXFLAGS += "-static -O2 -MD"
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
(cd $(PKG_BUILD_DIR); \
|
|
||||||
rm -rf config.{cache,status} ; \
|
|
||||||
./configure \
|
|
||||||
--prefix=/usr \
|
|
||||||
--target=$(GNU_TARGET_NAME) \
|
|
||||||
--host=$(GNU_HOST_NAME) \
|
|
||||||
--build=$(GNU_BUILD_NAME) \
|
|
||||||
--enable-tools=mixed \
|
|
||||||
--enable-userlevel \
|
|
||||||
--enable-wifi \
|
|
||||||
--enable-fixincludes \
|
|
||||||
--disable-linuxmodule \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
|
||||||
tools elementmap.xml
|
|
||||||
(cd $(PKG_BUILD_DIR)/userlevel; \
|
|
||||||
../tools/click-mkmindriver/click-mkmindriver -p $(PKG_NAME) -C .. \
|
|
||||||
-f $(PKG_BUILD_DIR)/conf/wifi/dump.click \
|
|
||||||
-A --all -E Discard -E Print; \
|
|
||||||
)
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) MINDRIVER=$(PKG_NAME)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/click/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(INSTALL_DIR) $(1)/usr/share/click
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/userlevel/$(PKG_NAME)click $(1)/usr/bin/click
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/tools/click-align/click-align $(1)/usr/bin/click-align
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/elementmap.xml $(1)/usr/share/click/elementmap.xml
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,click))
|
|
@ -1,15 +0,0 @@
|
|||||||
#!/bin/sh /etc/rc.common
|
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
|
||||||
START=50
|
|
||||||
|
|
||||||
start() {
|
|
||||||
killall -q click
|
|
||||||
cp /usr/bin/srcr.click /tmp
|
|
||||||
sh /usr/bin/gen_config_roofnet.sh > /tmp/unaligned.click
|
|
||||||
click-align /tmp/unaligned.click > /tmp/roofnet.click
|
|
||||||
/usr/bin/click /tmp/roofnet.click > /tmp/roofnet.log 2>&1 &
|
|
||||||
}
|
|
||||||
|
|
||||||
stop() {
|
|
||||||
killall click
|
|
||||||
}
|
|
@ -1,22 +0,0 @@
|
|||||||
--- a/tools/click-mkmindriver/Makefile.in
|
|
||||||
+++ b/tools/click-mkmindriver/Makefile.in
|
|
||||||
@@ -60,7 +60,7 @@ DEPCFLAGS = @DEPCFLAGS@
|
|
||||||
DEFS = @DEFS@
|
|
||||||
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
|
|
||||||
-I$(top_srcdir)/tools/lib -I$(srcdir)
|
|
||||||
-LDFLAGS = @LDFLAGS@
|
|
||||||
+LDFLAGS = @LDFLAGS@ -lrt
|
|
||||||
LIBS = @LIBS@ @POSIX_CLOCK_LIBS@ $(DL_LIBS)
|
|
||||||
|
|
||||||
CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CXXFLAGS) $(DEPCFLAGS)
|
|
||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -7135,7 +7135,7 @@ fi
|
|
||||||
$as_echo "$ac_cv_va_list_addr" >&6; }
|
|
||||||
if test "x$ac_cv_va_list_addr" = xyes; then
|
|
||||||
|
|
||||||
-$as_echo "#define HAVE_ADDRESSABLE_VA_LIST 1" >>confdefs.h
|
|
||||||
+$as_echo "#define HAVE_ADDRESSABLE_VA_LIST 0" >>confdefs.h
|
|
||||||
|
|
||||||
fi
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
--- a/lib/master.cc
|
|
||||||
+++ b/lib/master.cc
|
|
||||||
@@ -409,7 +409,9 @@ Master::process_pending(RouterThread *th
|
|
||||||
while (Task *t = Task::pending_to_task(my_pending)) {
|
|
||||||
my_pending = t->_pending_nextptr;
|
|
||||||
t->_pending_nextptr = 0;
|
|
||||||
+# if HAVE_MULTITHREAD
|
|
||||||
click_master_mb();
|
|
||||||
+# endif
|
|
||||||
t->process_pending(thread);
|
|
||||||
}
|
|
||||||
}
|
|
Loading…
x
Reference in New Issue
Block a user