[packages] openswan: update to v2.6.33 (#8924)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25676 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
018d2eb264
commit
af636c4d52
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=openswan
|
||||
PKG_VERSION:=2.6.29
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.6.33
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.openswan.org/download
|
||||
PKG_MD5SUM:=cd6c127585ec6db63780e9a40d5387fb
|
||||
PKG_MD5SUM:=7e9c28585307b7ad4f59737debb0d940
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
@ -49,6 +49,7 @@ define KernelPackage/openswan
|
||||
$(call Package/openswan/Default)
|
||||
SUBMENU:=Network Support
|
||||
TITLE+= (kernel module)
|
||||
DEPENDS+=+PACKAGE_kmod-ipv6:kmod-ipv6
|
||||
FILES:=$(PKG_BUILD_DIR)/modobj*/ipsec.$(LINUX_KMOD_SUFFIX)
|
||||
endef
|
||||
|
||||
|
@ -4,7 +4,7 @@
|
||||
|
||||
--- a/linux/include/openswan/ipsec_kversion.h
|
||||
+++ b/linux/include/openswan/ipsec_kversion.h
|
||||
@@ -366,6 +366,12 @@
|
||||
@@ -387,6 +387,12 @@
|
||||
# endif
|
||||
#endif
|
||||
|
||||
|
@ -1,58 +0,0 @@
|
||||
---
|
||||
linux/net/ipsec/ipsec_xmit.c | 21 +++++++++++++++++++++
|
||||
1 file changed, 21 insertions(+)
|
||||
|
||||
--- a/linux/net/ipsec/ipsec_xmit.c
|
||||
+++ b/linux/net/ipsec/ipsec_xmit.c
|
||||
@@ -105,6 +105,15 @@ static __u32 zeroes[64];
|
||||
int ipsec_xmit_trap_count = 0;
|
||||
int ipsec_xmit_trap_sendcount = 0;
|
||||
|
||||
+#ifndef NIPQUAD
|
||||
+#define NIPQUAD(addr) \
|
||||
+ ((unsigned char *)&addr)[0], \
|
||||
+ ((unsigned char *)&addr)[1], \
|
||||
+ ((unsigned char *)&addr)[2], \
|
||||
+ ((unsigned char *)&addr)[3]
|
||||
+#define NIPQUAD_FMT "%u.%u.%u.%u"
|
||||
+#endif
|
||||
+
|
||||
#define dmp(_x,_y,_z) if(debug_xmit && sysctl_ipsec_debug_verbose) ipsec_dmp_block(_x,_y,_z)
|
||||
|
||||
#if !defined(SKB_COPY_EXPAND) || defined(KLIPS_UNIT_TESTS)
|
||||
@@ -2085,7 +2094,11 @@ ipsec_xmit_send(struct ipsec_xmit_state*
|
||||
return IPSEC_XMIT_ROUTEERR;
|
||||
}
|
||||
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,36)
|
||||
+ if(ixs->dev == ixs->route->dst.dev) {
|
||||
+#else
|
||||
if(ixs->dev == ixs->route->u.dst.dev) {
|
||||
+#endif
|
||||
ip_rt_put(ixs->route);
|
||||
/* This is recursion, drop it. */
|
||||
if (ixs->stats)
|
||||
@@ -2098,7 +2111,11 @@ ipsec_xmit_send(struct ipsec_xmit_state*
|
||||
}
|
||||
|
||||
skb_dst_drop(ixs->skb);
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,36)
|
||||
+ skb_dst_set(ixs->skb, &ixs->route->dst);
|
||||
+#else
|
||||
skb_dst_set(ixs->skb, &ixs->route->u.dst);
|
||||
+#endif
|
||||
if(ixs->stats) {
|
||||
ixs->stats->tx_bytes += ixs->skb->len;
|
||||
}
|
||||
@@ -2139,7 +2156,11 @@ ipsec_xmit_send(struct ipsec_xmit_state*
|
||||
|
||||
else
|
||||
err = NF_HOOK(PF_INET, OSW_NF_INET_LOCAL_OUT, ixs->skb, NULL,
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,36)
|
||||
+ ixs->route->dst.dev,
|
||||
+#else
|
||||
ixs->route->u.dst.dev,
|
||||
+#endif
|
||||
ipsec_xmit_send2);
|
||||
|
||||
if(err != NET_XMIT_SUCCESS && err != NET_XMIT_CN) {
|
@ -1,11 +0,0 @@
|
||||
--- a/programs/pluto/adns.c
|
||||
+++ b/programs/pluto/adns.c
|
||||
@@ -187,7 +187,7 @@ write_pipe(int fd, const unsigned char *
|
||||
res_query(dname, class, type, answer, anslen)
|
||||
# define res_nclose(statp) res_close()
|
||||
|
||||
-static struct __res_state *statp = &_res;
|
||||
+#define statp ((struct __res_state *)(&_res))
|
||||
|
||||
#else /* !OLD_RESOLVER */
|
||||
|
Loading…
x
Reference in New Issue
Block a user