[packages] openssh: update to 6.5p1
Signed-off-by: Peter Wagner <tripolar@gmx.at> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39843 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
30a944610f
commit
b10a2bc55a
@ -8,15 +8,15 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openssh
|
||||
PKG_VERSION:=6.4p1
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=6.5p1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
|
||||
ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
|
||||
ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
|
||||
ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
|
||||
PKG_MD5SUM:=a62b88b884df0b09b8a8c5789ac9e51b
|
||||
PKG_MD5SUM:=a084e7272b8cbd25afe0f5dce4802fef
|
||||
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/cipher.c
|
||||
+++ b/cipher.c
|
||||
@@ -76,8 +76,10 @@ static const struct Cipher ciphers[] = {
|
||||
@@ -80,8 +80,10 @@ static const struct Cipher ciphers[] = {
|
||||
{ "3des-cbc", SSH_CIPHER_SSH2, 8, 24, 0, 0, 0, 1, EVP_des_ede3_cbc },
|
||||
{ "blowfish-cbc",
|
||||
SSH_CIPHER_SSH2, 8, 16, 0, 0, 0, 1, EVP_bf_cbc },
|
||||
|
@ -44,7 +44,7 @@
|
||||
{
|
||||
int status;
|
||||
|
||||
@@ -508,7 +508,7 @@ sshpam_thread(void *ctxtp)
|
||||
@@ -510,7 +510,7 @@ sshpam_thread(void *ctxtp)
|
||||
/* XXX - can't do much about an error here */
|
||||
ssh_msg_send(ctxt->pam_csock, sshpam_err, &buffer);
|
||||
buffer_free(&buffer);
|
||||
@ -53,7 +53,7 @@
|
||||
|
||||
auth_fail:
|
||||
buffer_put_cstring(&buffer,
|
||||
@@ -519,7 +519,7 @@ sshpam_thread(void *ctxtp)
|
||||
@@ -521,7 +521,7 @@ sshpam_thread(void *ctxtp)
|
||||
else
|
||||
ssh_msg_send(ctxt->pam_csock, PAM_AUTH_ERR, &buffer);
|
||||
buffer_free(&buffer);
|
||||
@ -62,7 +62,7 @@
|
||||
|
||||
return (NULL); /* Avoid warning for non-pthread case */
|
||||
}
|
||||
@@ -531,8 +531,8 @@ sshpam_thread_cleanup(void)
|
||||
@@ -533,8 +533,8 @@ sshpam_thread_cleanup(void)
|
||||
|
||||
debug3("PAM: %s entering", __func__);
|
||||
if (ctxt != NULL && ctxt->pam_thread != 0) {
|
||||
@ -73,7 +73,7 @@
|
||||
close(ctxt->pam_psock);
|
||||
close(ctxt->pam_csock);
|
||||
memset(ctxt, 0, sizeof(*ctxt));
|
||||
@@ -696,7 +696,7 @@ sshpam_init_ctx(Authctxt *authctxt)
|
||||
@@ -698,7 +698,7 @@ sshpam_init_ctx(Authctxt *authctxt)
|
||||
}
|
||||
ctxt->pam_psock = socks[0];
|
||||
ctxt->pam_csock = socks[1];
|
||||
|
@ -9,7 +9,7 @@
|
||||
+#IPQoS AF21 AF11
|
||||
--- a/sshd_config
|
||||
+++ b/sshd_config
|
||||
@@ -120,6 +120,9 @@ UsePrivilegeSeparation sandbox # Defaul
|
||||
@@ -122,6 +122,9 @@ UsePrivilegeSeparation sandbox # Defaul
|
||||
# no default banner path
|
||||
#Banner none
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user