Upgrade bind to 9.4.1 (#1977)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8714 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
294aa9c5ea
commit
b1dc91cb90
@ -9,14 +9,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=bind
|
PKG_NAME:=bind
|
||||||
PKG_VERSION:=9.3.2-P2
|
PKG_VERSION:=9.4.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
||||||
http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
||||||
PKG_MD5SUM:=948101be324deb15ff94a5b6a639ea39
|
PKG_MD5SUM:=09b54d35036cb0423b2e618f21766285
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
@ -73,8 +73,9 @@ define Package/bind-dig
|
|||||||
TITLE+= DNS excavation tool
|
TITLE+= DNS excavation tool
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/Build/Configure
|
export BUILD_CC="$(TARGET_CC)"
|
||||||
$(call Build/Configure/Default,\
|
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
--enable-shared \
|
--enable-shared \
|
||||||
--enable-static \
|
--enable-static \
|
||||||
--enable-ipv6 \
|
--enable-ipv6 \
|
||||||
@ -82,19 +83,21 @@ define Package/Build/Configure
|
|||||||
--disable-threads \
|
--disable-threads \
|
||||||
--with-openssl="$(STAGING_DIR)/usr" \
|
--with-openssl="$(STAGING_DIR)/usr" \
|
||||||
--with-libtool \
|
--with-libtool \
|
||||||
)
|
, \
|
||||||
endef
|
BUILD_CC="$(TARGET_CC)" \
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
rm -rf $(PKG_INSTALL_DIR)
|
rm -rf $(PKG_INSTALL_DIR)
|
||||||
mkdir -p $(PKG_INSTALL_DIR)
|
mkdir -p $(PKG_INSTALL_DIR)
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
|
$(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
|
||||||
|
BUILD_CC="$(HOSTCC)" \
|
||||||
CC="$(HOSTCC)" \
|
CC="$(HOSTCC)" \
|
||||||
CFLAGS="-O2" \
|
CFLAGS="-O2" \
|
||||||
LIBS="" \
|
LIBS="" \
|
||||||
gen
|
gen
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
all install
|
all install
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -1,15 +1,8 @@
|
|||||||
--- bind-9.3.2-P1/configure 2005-10-21 01:57:38.000000000 +0200
|
Index: bind-9.4.1/configure
|
||||||
+++ bind-9.3.2-P1.new/configure 2006-10-16 21:43:12.000000000 +0200
|
===================================================================
|
||||||
@@ -4816,7 +4816,7 @@
|
--- bind-9.4.1.orig/configure 2007-06-26 21:11:45.000000000 +0200
|
||||||
use_openssl="auto"
|
+++ bind-9.4.1/configure 2007-06-26 21:12:33.000000000 +0200
|
||||||
fi;
|
@@ -5262,8 +5262,7 @@
|
||||||
|
|
||||||
-openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
|
|
||||||
+openssldirs="-I$STAGING_DIR/usr/include"
|
|
||||||
if test "$use_openssl" = "auto"
|
|
||||||
then
|
|
||||||
for d in $openssldirs
|
|
||||||
@@ -5357,8 +5357,7 @@
|
|
||||||
else
|
else
|
||||||
test "$cross_compiling" = yes &&
|
test "$cross_compiling" = yes &&
|
||||||
{ { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
{ { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||||
@ -19,7 +12,7 @@
|
|||||||
if test -r "$devrandom"; then
|
if test -r "$devrandom"; then
|
||||||
eval "$as_ac_File=yes"
|
eval "$as_ac_File=yes"
|
||||||
else
|
else
|
||||||
@@ -23747,176 +23746,6 @@
|
@@ -24165,176 +24164,6 @@
|
||||||
# which provides some (all?) of the desired functions.
|
# which provides some (all?) of the desired functions.
|
||||||
#
|
#
|
||||||
|
|
||||||
@ -196,19 +189,10 @@
|
|||||||
#
|
#
|
||||||
# Look for a 4.4BSD-style sa_len member in struct sockaddr.
|
# Look for a 4.4BSD-style sa_len member in struct sockaddr.
|
||||||
#
|
#
|
||||||
--- bind-9.3.2-P1/configure.in 2005-10-21 01:47:25.000000000 +0200
|
Index: bind-9.4.1/lib/bind/configure
|
||||||
+++ bind-9.3.2-P1.new/configure.in 2006-10-16 21:36:09.000000000 +0200
|
===================================================================
|
||||||
@@ -363,7 +363,7 @@
|
--- bind-9.4.1.orig/lib/bind/configure 2007-06-26 21:11:45.000000000 +0200
|
||||||
(Required for DNSSEC)],
|
+++ bind-9.4.1/lib/bind/configure 2007-06-26 21:12:33.000000000 +0200
|
||||||
use_openssl="$withval", use_openssl="auto")
|
|
||||||
|
|
||||||
-openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
|
|
||||||
+openssldirs="$STAGING_DIR/usr/include $STAGING_DIR/include"
|
|
||||||
if test "$use_openssl" = "auto"
|
|
||||||
then
|
|
||||||
for d in $openssldirs
|
|
||||||
--- bind-9.3.2-P1/lib/bind/configure 2005-10-14 03:44:50.000000000 +0200
|
|
||||||
+++ bind-9.3.2-P1.new/lib/bind/configure 2006-10-16 21:46:45.000000000 +0200
|
|
||||||
@@ -4461,6 +4461,7 @@
|
@@ -4461,6 +4461,7 @@
|
||||||
if eval "test \"\${$as_ac_File+set}\" = set"; then
|
if eval "test \"\${$as_ac_File+set}\" = set"; then
|
||||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -urN bind-9.3.2-P1/lib/dns/Makefile.in bind-9.3.2-P1.new/lib/dns/Makefile.in
|
|
||||||
--- bind-9.3.2-P1/lib/dns/Makefile.in 2004-12-09 05:07:15.000000000 +0100
|
|
||||||
+++ bind-9.3.2-P1.new/lib/dns/Makefile.in 2006-10-16 21:38:46.000000000 +0200
|
|
||||||
@@ -156,7 +156,7 @@
|
|
||||||
./gen -s ${srcdir} > code.h
|
|
||||||
|
|
||||||
gen: gen.c
|
|
||||||
- ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ ${srcdir}/gen.c ${LIBS}
|
|
||||||
+ ${CC} ${ALL_CFLAGS} -o $@ ${srcdir}/gen.c ${LIBS}
|
|
||||||
|
|
||||||
rbtdb64.@O@: rbtdb.c
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user