Add libdbi

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13943 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-01-08 23:06:25 +00:00
parent 8306e50704
commit b2e35d863d
2 changed files with 76 additions and 0 deletions

52
libs/libdbi/Makefile Normal file
View File

@ -0,0 +1,52 @@
#
# Copyright (C) 2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id: $
include $(TOPDIR)/rules.mk
PKG_NAME:=libdbi
PKG_VERSION:=0.8.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/libdbi
PKG_MD5SUM:=
include $(INCLUDE_DIR)/package.mk
define Package/libdbi
NAME:=libdbi
SECTION:=libs
CATEGORY:=Libraries
TITLE+= (library)
endef
define Package/libdbi/description
SQLite is a small C library that implements a self-contained, embeddable,
zero-configuration SQL database engine. This package contains the SQLite
(v3.x) shared library, used by other programs.
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
endef
define Build/InstallDev
mkdir -p $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/dbi $(1)/usr/include/
mkdir -p $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdbi.{a,so*} $(1)/usr/lib/
endef
define Package/libdbi/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdbi.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libdbi))

View File

@ -0,0 +1,24 @@
diff -urN libdbi-0.8.3/Makefile.am libdbi-0.8.3.new/Makefile.am
--- libdbi-0.8.3/Makefile.am 2006-05-18 22:27:50.000000000 +0200
+++ libdbi-0.8.3.new/Makefile.am 2009-01-09 00:06:34.000000000 +0100
@@ -2,7 +2,7 @@
AUTOMAKE_OPTIONS = foreign dist-zip
-SUBDIRS = src include @docs_subdirs@
+SUBDIRS = src include
EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README README.win32 README.osx TODO NEWS libdbi.spec.in config.h.in Makefile.w32 autogen.sh drivers/example/AUTHORS drivers/example/Makefile.am drivers/example/README drivers/example/TODO drivers/example/.cvsignore drivers/example/dbd_example.c drivers/example/dbd_example.h drivers/example/dbd_example.sgml
diff -urN libdbi-0.8.3/Makefile.in libdbi-0.8.3.new/Makefile.in
--- libdbi-0.8.3/Makefile.in 2008-02-06 20:40:10.000000000 +0100
+++ libdbi-0.8.3.new/Makefile.in 2009-01-09 00:06:28.000000000 +0100
@@ -180,7 +180,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
AUTOMAKE_OPTIONS = foreign dist-zip
-SUBDIRS = src include @docs_subdirs@
+SUBDIRS = src include
EXTRA_DIST = AUTHORS COPYING ChangeLog INSTALL README README.win32 README.osx TODO NEWS libdbi.spec.in config.h.in Makefile.w32 autogen.sh drivers/example/AUTHORS drivers/example/Makefile.am drivers/example/README drivers/example/TODO drivers/example/.cvsignore drivers/example/dbd_example.c drivers/example/dbd_example.h drivers/example/dbd_example.sgml
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive