[package] update pure-ftpd to 1.0.27 (#6355)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18783 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3f60382991
commit
b305deb9d4
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=pure-ftpd
|
PKG_NAME:=pure-ftpd
|
||||||
PKG_VERSION:=1.0.22
|
PKG_VERSION:=1.0.27
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://download.pureftpd.org/pub/pure-ftpd/releases/snapshots/
|
PKG_SOURCE_URL:=http://download.pureftpd.org/pub/pure-ftpd/releases
|
||||||
PKG_MD5SUM:=68308d7143aea092356f910859785e4a
|
PKG_MD5SUM:=7d18544384aa1649d483ba86518ed34e
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -34,13 +34,17 @@ define Package/pure-ftpd/description
|
|||||||
personal users as well as hosting providers.
|
personal users as well as hosting providers.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/pure-ftpd/conffiles
|
||||||
|
/etc/config/pure-ftpd
|
||||||
|
endef
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--with-everything \
|
--with-everything \
|
||||||
--with-virtualchroot \
|
--with-virtualchroot \
|
||||||
|
|
||||||
define Package/pure-ftpd/install
|
define Package/pure-ftpd/install
|
||||||
$(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d $(1)/usr/sbin
|
||||||
$(INSTALL_DATA) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
|
$(INSTALL_CONF) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
|
||||||
$(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
|
$(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptracetest $(1)/usr/sbin
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptracetest $(1)/usr/sbin
|
||||||
$(INSTALL_BIN) $(foreach i,ftpd pw ftpwho mrtginfo pwconvert quotacheck statsdecode uploadscript authd, \
|
$(INSTALL_BIN) $(foreach i,ftpd pw ftpwho mrtginfo pwconvert quotacheck statsdecode uploadscript authd, \
|
||||||
|
@ -1,112 +0,0 @@
|
|||||||
Index: pure-ftpd-1.0.22.orig/configure
|
|
||||||
===================================================================
|
|
||||||
--- pure-ftpd-1.0.22.orig/configure 2006-04-25 10:39:45.000000000 +0300
|
|
||||||
+++ pure-ftpd-1.0.22/configure 2008-09-26 20:01:04.000000000 +0300
|
|
||||||
@@ -9286,7 +9286,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -9700,7 +9700,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -10114,7 +10114,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -10528,7 +10528,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -10942,7 +10942,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -21513,7 +21513,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -21587,7 +21587,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -21655,7 +21655,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -21761,7 +21761,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -21830,7 +21830,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -22624,7 +22624,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
||||||
@@ -23031,7 +23031,7 @@
|
|
||||||
See \`config.log' for more details." >&5
|
|
||||||
echo "$as_me: error: cannot run test program while cross compiling
|
|
||||||
See \`config.log' for more details." >&2;}
|
|
||||||
- { (exit 1); exit 1; }; }
|
|
||||||
+ }
|
|
||||||
else
|
|
||||||
cat >conftest.$ac_ext <<_ACEOF
|
|
||||||
/* confdefs.h. */
|
|
Loading…
x
Reference in New Issue
Block a user