[packages] httping: update to 2.3.4
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40523 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a787157cf8
commit
b3a48eaba4
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,17 +8,18 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=httping
|
||||
PKG_VERSION:=1.5.2
|
||||
PKG_VERSION:=2.3.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=http://www.vanheusden.com/httping
|
||||
PKG_MD5SUM:=49f72b124afb8a60f152ec674a162ad6
|
||||
PKG_MD5SUM:=7a71ed513f9f22fe331b783a3d36767e
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
|
||||
define Package/httping/Default
|
||||
SECTION:=net
|
||||
@ -56,11 +57,17 @@ define Package/httping-nossl/description
|
||||
This package is built without SSL support.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -D_GNU_SOURCE
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
MAKE_FLAGS += \
|
||||
DEBUG="no" \
|
||||
FW="no" \
|
||||
NC="no" \
|
||||
TFO="no"
|
||||
|
||||
ifeq ($(BUILD_VARIANT),nossl)
|
||||
MAKE_FLAGS += SSL="no"
|
||||
TARGET_CFLAGS += -DNO_SSL
|
||||
endif
|
||||
|
||||
define Package/httping/install
|
||||
|
12
net/httping/patches/001-no_strip.patch
Normal file
12
net/httping/patches/001-no_strip.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -113,9 +113,6 @@ install: $(TARGET) $(TRANSLATIONS)
|
||||
$(INSTALLMAN) $(MAN_NL) $(DESTDIR)/$(MANDIR)/nl/man1
|
||||
$(INSTALLDIR) $(DESTDIR)/$(DOCDIR)
|
||||
$(INSTALLDOC) $(DOCS) $(DESTDIR)/$(DOCDIR)
|
||||
-ifneq ($(DEBUG),yes)
|
||||
- $(STRIP) $(DESTDIR)/$(BINDIR)/$(TARGET)
|
||||
-endif
|
||||
mkdir -p $(DESTDIR)/$(PREFIX)/share/locale/nl/LC_MESSAGES
|
||||
cp nl.mo $(DESTDIR)/$(PREFIX)/share/locale/nl/LC_MESSAGES/httping.mo
|
||||
|
@ -1,29 +0,0 @@
|
||||
--- a/main.c
|
||||
+++ b/main.c
|
||||
@@ -41,6 +41,8 @@
|
||||
#include "utils.h"
|
||||
#include "error.h"
|
||||
|
||||
+#define VERSION "1.5.2"
|
||||
+
|
||||
static volatile int stop = 0;
|
||||
|
||||
int quiet = 0;
|
||||
@@ -52,7 +54,7 @@ char last_error[ERROR_BUFFER_SIZE];
|
||||
|
||||
void version(void)
|
||||
{
|
||||
- fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2011 folkert@vanheusden.com\n");
|
||||
+ fprintf(stderr, "HTTPing v%s (C) 2003-2011 folkert@vanheusden.com\n", VERSION);
|
||||
#ifndef NO_SSL
|
||||
fprintf(stderr, "SSL support included\n");
|
||||
#endif
|
||||
@@ -639,7 +641,7 @@ int main(int argc, char *argv[])
|
||||
if (useragent)
|
||||
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
|
||||
else
|
||||
- sprintf(&request[strlen(request)], "User-Agent: HTTPing v" VERSION "\r\n");
|
||||
+ sprintf(&request[strlen(request)], "User-Agent: HTTPing v%s\r\n", VERSION);
|
||||
sprintf(&request[strlen(request)], "Host: %s\r\n", hostname);
|
||||
if (referer)
|
||||
sprintf(&request[strlen(request)], "Referer: %s\r\n", referer);
|
Loading…
x
Reference in New Issue
Block a user