Update gd to 2.0.35 (#3569)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13403 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3054dbd8fb
commit
b3b9446b61
@ -9,12 +9,14 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gd
|
||||
PKG_VERSION:=2.0.33
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.0.35
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.boutell.com/gd/http
|
||||
PKG_MD5SUM:=be0a6d326cd8567e736fbc75df0a5c45
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.libgd.org/releases
|
||||
PKG_MD5SUM:=6c6c3dbb7bf079e0bb5fbbfd3bb8a71c
|
||||
|
||||
PKG_FIXUP = libtool
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -26,6 +28,11 @@ define Package/libgd
|
||||
URL:=http://www.boutell.com/gd/
|
||||
endef
|
||||
|
||||
define Package/libgd/description
|
||||
GD is an open source code library for the dynamic creation of images by
|
||||
programmers. GD creates PNG, JPEG and GIF images, among other formats.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
|
@ -1,26 +1,147 @@
|
||||
diff -urN gd-2.0.33.old/configure gd-2.0.33.dev/configure
|
||||
--- gd-2.0.33.old/configure 2004-11-04 00:14:47.000000000 +0100
|
||||
+++ gd-2.0.33.dev/configure 2005-05-05 15:06:26.000000000 +0200
|
||||
@@ -7217,8 +7217,6 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -9454,21 +9454,6 @@
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
-sys_lib_dlsearch_path_spec="/lib /usr/lib"
|
||||
-sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
|
||||
-if test "$GCC" = yes; then
|
||||
- sys_lib_search_path_spec=`$CC -print-search-dirs | grep "^libraries:" | $SED -e "s/^libraries://" -e "s,=/,/,g"`
|
||||
- if echo "$sys_lib_search_path_spec" | grep ';' >/dev/null ; then
|
||||
- # if the path contains ";" then we assume it to be the separator
|
||||
- # otherwise default to the standard path separator (i.e. ":") - it is
|
||||
- # assumed that no part of a normal pathname contains ";" but that should
|
||||
- # okay in the real world where ";" in dirpaths is itself problematic.
|
||||
- sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e 's/;/ /g'`
|
||||
- else
|
||||
- sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e "s/$PATH_SEPARATOR/ /g"`
|
||||
- fi
|
||||
-else
|
||||
- sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
|
||||
-fi
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
case $host_os in
|
||||
aix3*)
|
||||
@@ -7481,8 +7479,6 @@
|
||||
*)
|
||||
;;
|
||||
esac
|
||||
- sys_lib_dlsearch_path_spec="/lib${libsuff} /usr/lib${libsuff}"
|
||||
- sys_lib_search_path_spec="/lib${libsuff} /usr/lib${libsuff} /usr/local/lib${libsuff}"
|
||||
;;
|
||||
@@ -9816,12 +9801,6 @@
|
||||
# before this can be enabled.
|
||||
hardcode_into_libs=yes
|
||||
|
||||
- # Append ld.so.conf contents to the search path
|
||||
- if test -f /etc/ld.so.conf; then
|
||||
- lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
- fi
|
||||
-
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
# powerpc, because MkLinux only supported shared libraries with the
|
||||
# GNU dynamic linker. Since this was broken with cross compilers,
|
||||
@@ -13364,21 +13343,6 @@
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
-sys_lib_dlsearch_path_spec="/lib /usr/lib"
|
||||
-if test "$GCC" = yes; then
|
||||
- sys_lib_search_path_spec=`$CC -print-search-dirs | grep "^libraries:" | $SED -e "s/^libraries://" -e "s,=/,/,g"`
|
||||
- if echo "$sys_lib_search_path_spec" | grep ';' >/dev/null ; then
|
||||
- # if the path contains ";" then we assume it to be the separator
|
||||
- # otherwise default to the standard path separator (i.e. ":") - it is
|
||||
- # assumed that no part of a normal pathname contains ";" but that should
|
||||
- # okay in the real world where ";" in dirpaths is itself problematic.
|
||||
- sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e 's/;/ /g'`
|
||||
- else
|
||||
- sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e "s/$PATH_SEPARATOR/ /g"`
|
||||
- fi
|
||||
-else
|
||||
- sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
|
||||
-fi
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
@@ -13726,12 +13690,6 @@
|
||||
# before this can be enabled.
|
||||
hardcode_into_libs=yes
|
||||
|
||||
- # Append ld.so.conf contents to the search path
|
||||
- if test -f /etc/ld.so.conf; then
|
||||
- lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
- fi
|
||||
-
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
# powerpc, because MkLinux only supported shared libraries with the
|
||||
# GNU dynamic linker. Since this was broken with cross compilers,
|
||||
@@ -15936,21 +15894,6 @@
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
-sys_lib_dlsearch_path_spec="/lib /usr/lib"
|
||||
-if test "$GCC" = yes; then
|
||||
- sys_lib_search_path_spec=`$CC -print-search-dirs | grep "^libraries:" | $SED -e "s/^libraries://" -e "s,=/,/,g"`
|
||||
- if echo "$sys_lib_search_path_spec" | grep ';' >/dev/null ; then
|
||||
- # if the path contains ";" then we assume it to be the separator
|
||||
- # otherwise default to the standard path separator (i.e. ":") - it is
|
||||
- # assumed that no part of a normal pathname contains ";" but that should
|
||||
- # okay in the real world where ";" in dirpaths is itself problematic.
|
||||
- sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e 's/;/ /g'`
|
||||
- else
|
||||
- sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e "s/$PATH_SEPARATOR/ /g"`
|
||||
- fi
|
||||
-else
|
||||
- sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
|
||||
-fi
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
@@ -16298,12 +16241,6 @@
|
||||
# before this can be enabled.
|
||||
hardcode_into_libs=yes
|
||||
|
||||
- # Append ld.so.conf contents to the search path
|
||||
- if test -f /etc/ld.so.conf; then
|
||||
- lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
- fi
|
||||
-
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
# powerpc, because MkLinux only supported shared libraries with the
|
||||
# GNU dynamic linker. Since this was broken with cross compilers,
|
||||
@@ -18515,21 +18452,6 @@
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
-sys_lib_dlsearch_path_spec="/lib /usr/lib"
|
||||
-if test "$GCC" = yes; then
|
||||
- sys_lib_search_path_spec=`$CC -print-search-dirs | grep "^libraries:" | $SED -e "s/^libraries://" -e "s,=/,/,g"`
|
||||
- if echo "$sys_lib_search_path_spec" | grep ';' >/dev/null ; then
|
||||
- # if the path contains ";" then we assume it to be the separator
|
||||
- # otherwise default to the standard path separator (i.e. ":") - it is
|
||||
- # assumed that no part of a normal pathname contains ";" but that should
|
||||
- # okay in the real world where ";" in dirpaths is itself problematic.
|
||||
- sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e 's/;/ /g'`
|
||||
- else
|
||||
- sys_lib_search_path_spec=`echo "$sys_lib_search_path_spec" | $SED -e "s/$PATH_SEPARATOR/ /g"`
|
||||
- fi
|
||||
-else
|
||||
- sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
|
||||
-fi
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
@@ -18877,12 +18799,6 @@
|
||||
# before this can be enabled.
|
||||
hardcode_into_libs=yes
|
||||
|
||||
- # Append ld.so.conf contents to the search path
|
||||
- if test -f /etc/ld.so.conf; then
|
||||
- lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
- fi
|
||||
-
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
# powerpc, because MkLinux only supported shared libraries with the
|
||||
# GNU dynamic linker. Since this was broken with cross compilers,
|
||||
@@ -22026,14 +21942,14 @@
|
||||
|
||||
netbsd*)
|
||||
@@ -11032,14 +11028,14 @@
|
||||
fi
|
||||
|
||||
if test -n "$LIBPNG12_CONFIG"; then
|
||||
- libpng_CPPFLAGS=`libpng12-config --cflags`
|
||||
@ -38,3 +159,14 @@ diff -urN gd-2.0.33.old/configure gd-2.0.33.dev/configure
|
||||
libpng_LDFLAGS=`echo " $libpng_LDFLAGS" | sed 's/ -l[^ ][^ ]*//g'`
|
||||
elif test -d "$withval"; then
|
||||
libpng_CPPFLAGS="-I$withval/include"
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -61,7 +61,7 @@
|
||||
AC_HEADER_STDC
|
||||
AC_CHECK_HEADERS([errno.h limits.h stddef.h stdlib.h string.h unistd.h])
|
||||
|
||||
-AM_ICONV
|
||||
+m4_pattern_allow([AM_ICONV])
|
||||
# if test -n "$LIBICONV" ; then
|
||||
# LIBS="$LIBS $LIBICONV"
|
||||
# fi
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -urN gd-2.0.33.orig/config/config.sub gd-2.0.33/config/config.sub
|
||||
--- gd-2.0.33.orig/config/config.sub 2004-10-27 16:22:07.000000000 +0200
|
||||
+++ gd-2.0.33/config/config.sub 2008-04-14 16:34:00.000000000 +0200
|
||||
@@ -228,7 +228,7 @@
|
||||
| a29k \
|
||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
||||
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
||||
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
||||
| clipper \
|
||||
| d10v | d30v | dlx | dsp16xx \
|
||||
| fr30 | frv \
|
||||
@@ -292,7 +292,7 @@
|
||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
||||
- | avr-* \
|
||||
+ | avr-* | avr32-* \
|
||||
| bs2000-* \
|
||||
| c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* \
|
||||
| clipper-* | cydra-* \
|
Loading…
x
Reference in New Issue
Block a user