[packages] dibbler: update to 0.8.1
* switch to uclibcxx * add requestor package, init scripts & conffiles * drop obsolete patches git-svn-id: svn://svn.openwrt.org/openwrt/packages@30425 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
74433b1d29
commit
b3bd07a145
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2010 OpenWrt.org
|
# Copyright (C) 2006-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,23 +8,19 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dibbler
|
PKG_NAME:=dibbler
|
||||||
PKG_VERSION:=0.7.3
|
PKG_VERSION:=0.8.1
|
||||||
PKG_RELEASE:=6
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://klub.com.pl/dhcpv6/dibbler/
|
PKG_SOURCE_URL:=http://klub.com.pl/dhcpv6/dibbler
|
||||||
PKG_MD5SUM:=39be72da38c2e6d33fd43a2811a276b1
|
PKG_MD5SUM:=0e52acedd838c43a264441a933780ead
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
|
||||||
PKG_LIBTOOL_PATHS:=poslib
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
# add dependency on 2.6 since recent dibbler needs <linux/ip_mp_alg.h>
|
|
||||||
define Package/dibbler/Default
|
define Package/dibbler/Default
|
||||||
SECTION:=ipv6
|
SECTION:=ipv6
|
||||||
CATEGORY:=IPv6
|
CATEGORY:=IPv6
|
||||||
DEPENDS:=+libstdcpp +libpthread
|
DEPENDS:=+uclibcxx +libpthread
|
||||||
TITLE:=Dibbler, a portable DHCPv6 implementation
|
TITLE:=Dibbler, a portable DHCPv6 implementation
|
||||||
URL:=http://klub.com.pl/dhcpv6/
|
URL:=http://klub.com.pl/dhcpv6/
|
||||||
endef
|
endef
|
||||||
@ -35,24 +31,18 @@ define Package/dibbler/Default/description
|
|||||||
autoconfiguration for IPv6.
|
autoconfiguration for IPv6.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/dibbler-poslib
|
|
||||||
$(call Package/dibbler/Default)
|
|
||||||
TITLE+= (helper lib)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/dibbler-poslib/description
|
|
||||||
$(call Package/dibbler/Default/description)
|
|
||||||
This package contains the pos library.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/dibbler-client
|
define Package/dibbler-client
|
||||||
$(call Package/dibbler/Default)
|
$(call Package/dibbler/Default)
|
||||||
TITLE+= (client)
|
TITLE+= (client)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/dibbler-client/conffiles
|
||||||
|
/etc/dibbler/client.conf
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/dibbler-client/description
|
define Package/dibbler-client/description
|
||||||
$(call Package/dibbler/Default/description)
|
$(call Package/dibbler/Default/description)
|
||||||
This package contains the dibbler client.
|
This package contains the dibbler client.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/dibbler-relay
|
define Package/dibbler-relay
|
||||||
@ -60,82 +50,86 @@ define Package/dibbler-relay
|
|||||||
TITLE+= (relay)
|
TITLE+= (relay)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/dibbler-relay/conffiles
|
||||||
|
/etc/dibbler/relay.conf
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/dibbler-relay/description
|
define Package/dibbler-relay/description
|
||||||
$(call Package/dibbler/Default/description)
|
$(call Package/dibbler/Default/description)
|
||||||
This package contains the dibbler relay.
|
This package contains the dibbler relay.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dibbler-requestor
|
||||||
|
$(call Package/dibbler/Default)
|
||||||
|
TITLE+= (requestor)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dibbler-requestor/description
|
||||||
|
$(call Package/dibbler/Default/description)
|
||||||
|
This package contains the dibbler requestor.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/dibbler-server
|
define Package/dibbler-server
|
||||||
$(call Package/dibbler/Default)
|
$(call Package/dibbler/Default)
|
||||||
DEPENDS += +dibbler-poslib
|
|
||||||
TITLE+= (server)
|
TITLE+= (server)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/dibbler-server/conffiles
|
||||||
|
/etc/dibbler/server.conf
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/dibbler-server/description
|
define Package/dibbler-server/description
|
||||||
$(call Package/dibbler/Default/description)
|
$(call Package/dibbler/Default/description)
|
||||||
This package contains the dibbler server.
|
This package contains the dibbler server.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
TARGET_CXX = $(STAGING_DIR)/host/bin/g++-uc
|
||||||
(cd $(PKG_BUILD_DIR)/poslib; \
|
|
||||||
$(TARGET_CONFIGURE_OPTS) \
|
|
||||||
CFLAGS="$(TARGET_CFLAGS)" \
|
|
||||||
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
|
||||||
LDFLAGS="$(TARGET_LDFLAGS)" \
|
|
||||||
./configure \
|
|
||||||
--target=$(GNU_TARGET_NAME) \
|
|
||||||
--host=$(GNU_TARGET_NAME) \
|
|
||||||
--build=$(GNU_HOST_NAME) \
|
|
||||||
--program-prefix="" \
|
|
||||||
--program-suffix="" \
|
|
||||||
--prefix=/usr \
|
|
||||||
--exec-prefix=/usr \
|
|
||||||
--bindir=/usr/bin \
|
|
||||||
--datadir=/usr/share \
|
|
||||||
--includedir=/usr/include \
|
|
||||||
--infodir=/usr/share/info \
|
|
||||||
--libdir=/usr/lib \
|
|
||||||
--libexecdir=/usr/lib \
|
|
||||||
--localstatedir=/var \
|
|
||||||
--mandir=/usr/share/man \
|
|
||||||
--sbindir=/usr/sbin \
|
|
||||||
--sysconfdir=/etc \
|
|
||||||
$(DISABLE_NLS) \
|
|
||||||
);
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
|
||||||
$(TARGET_CONFIGURE_OPTS) \
|
|
||||||
PORT_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
|
|
||||||
PORT_LDFLAGS="$(TARGET_LDFLAGS)" \
|
|
||||||
DEBUGINFO= \
|
|
||||||
server client relay
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/dibbler-poslib/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/./poslib/poslib/.libs/libposlib.so* $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/dibbler-client/install
|
define Package/dibbler-client/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-client $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-client $(1)/usr/sbin/
|
||||||
|
$(INSTALL_DIR) $(1)/etc/dibbler
|
||||||
|
$(INSTALL_CONF) \
|
||||||
|
$(PKG_BUILD_DIR)/doc/examples/client.conf \
|
||||||
|
$(1)/etc/dibbler/
|
||||||
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
|
$(INSTALL_BIN) \
|
||||||
|
./files/dibbler-client.init \
|
||||||
|
$(1)/etc/init.d/dibbler-client
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/dibbler-relay/install
|
define Package/dibbler-relay/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-relay $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-relay $(1)/usr/sbin/
|
||||||
|
$(INSTALL_DIR) $(1)/etc/dibbler
|
||||||
|
$(INSTALL_CONF) \
|
||||||
|
$(PKG_BUILD_DIR)/doc/examples/relay.conf \
|
||||||
|
$(1)/etc/dibbler/
|
||||||
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
|
$(INSTALL_BIN) \
|
||||||
|
./files/dibbler-relay.init \
|
||||||
|
$(1)/etc/init.d/dibbler-relay
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dibbler-requestor/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-requestor $(1)/usr/sbin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/dibbler-server/install
|
define Package/dibbler-server/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-server $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dibbler-server $(1)/usr/sbin/
|
||||||
|
$(INSTALL_DIR) $(1)/etc/dibbler
|
||||||
|
$(INSTALL_CONF) \
|
||||||
|
$(PKG_BUILD_DIR)/doc/examples/server.conf \
|
||||||
|
$(1)/etc/dibbler/
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
$(INSTALL_BIN) ./files/dibbler.init $(1)/etc/init.d/
|
$(INSTALL_BIN) \
|
||||||
|
./files/dibbler-server.init \
|
||||||
|
$(1)/etc/init.d/dibbler-server
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,dibbler-poslib))
|
|
||||||
$(eval $(call BuildPackage,dibbler-client))
|
$(eval $(call BuildPackage,dibbler-client))
|
||||||
$(eval $(call BuildPackage,dibbler-relay))
|
$(eval $(call BuildPackage,dibbler-relay))
|
||||||
|
$(eval $(call BuildPackage,dibbler-requestor))
|
||||||
$(eval $(call BuildPackage,dibbler-server))
|
$(eval $(call BuildPackage,dibbler-server))
|
||||||
|
13
ipv6/dibbler/files/dibbler-client.init
Normal file
13
ipv6/dibbler/files/dibbler-client.init
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
#!/bin/sh /etc/rc.common
|
||||||
|
|
||||||
|
START=90
|
||||||
|
STOP=90
|
||||||
|
|
||||||
|
start() {
|
||||||
|
mkdir -p /var/lib/dibbler
|
||||||
|
dibbler-client start
|
||||||
|
}
|
||||||
|
|
||||||
|
stop() {
|
||||||
|
dibbler-client stop
|
||||||
|
}
|
13
ipv6/dibbler/files/dibbler-relay.init
Normal file
13
ipv6/dibbler/files/dibbler-relay.init
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
#!/bin/sh /etc/rc.common
|
||||||
|
|
||||||
|
START=90
|
||||||
|
STOP=90
|
||||||
|
|
||||||
|
start() {
|
||||||
|
mkdir -p /var/lib/dibbler
|
||||||
|
dibbler-relay start
|
||||||
|
}
|
||||||
|
|
||||||
|
stop() {
|
||||||
|
dibbler-relay stop
|
||||||
|
}
|
@ -1,20 +0,0 @@
|
|||||||
--- a/poslib/config.sub
|
|
||||||
+++ b/poslib/config.sub
|
|
||||||
@@ -230,7 +230,7 @@
|
|
||||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
|
||||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
|
||||||
| am33_2.0 \
|
|
||||||
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
|
||||||
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
|
||||||
| c4x | clipper \
|
|
||||||
| d10v | d30v | dlx | dsp16xx \
|
|
||||||
| fr30 | frv \
|
|
||||||
@@ -297,7 +297,7 @@
|
|
||||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
|
||||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
|
||||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
|
||||||
- | avr-* \
|
|
||||||
+ | avr-* | avr32-* \
|
|
||||||
| bs2000-* \
|
|
||||||
| c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
|
|
||||||
| clipper-* | cydra-* \
|
|
@ -1,32 +0,0 @@
|
|||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -61,7 +61,8 @@
|
|
||||||
-L$(MESSAGES) -lMsg \
|
|
||||||
-lClntOptions -lOptions -lLowLevel \
|
|
||||||
-L$(MISC) -lMisc \
|
|
||||||
- -L$(POSLIB) $(CLNTPOSLIB)
|
|
||||||
+ -L$(POSLIB) $(CLNTPOSLIB) \
|
|
||||||
+ $(CLNT_LIBS)
|
|
||||||
|
|
||||||
server: $(SERVERBIN)
|
|
||||||
|
|
||||||
@@ -93,7 +94,8 @@
|
|
||||||
-L$(MISC) -lMisc \
|
|
||||||
-L$(LOWLEVEL) -lLowLevel \
|
|
||||||
-L$(IFACEMGR) -lIfaceMgr \
|
|
||||||
- -L$(POSLIB) $(SRVPOSLIB)
|
|
||||||
+ -L$(POSLIB) $(SRVPOSLIB) \
|
|
||||||
+ $(SRV_LIBS)
|
|
||||||
|
|
||||||
|
|
||||||
relay: $(RELAYBIN)
|
|
||||||
@@ -113,7 +115,8 @@
|
|
||||||
-L$(MESSAGES) -lMsg \
|
|
||||||
-L$(MISC) -lMisc \
|
|
||||||
-L$(OPTIONS) -lOptions \
|
|
||||||
- -lMisc -lIfaceMgr -lLowLevel -lRelTransMgr -lRelCfgMgr -lRelMsg -lRelOptions -lOptions
|
|
||||||
+ -lMisc -lIfaceMgr -lLowLevel -lRelTransMgr -lRelCfgMgr -lRelMsg -lRelOptions -lOptions \
|
|
||||||
+ $(SRV_LIBS)
|
|
||||||
|
|
||||||
requestor: $(REQUESTORBIN)
|
|
||||||
$(REQUESTORBIN): includes commonlibs Requestor $(REQUESTORDIRS)
|
|
Loading…
x
Reference in New Issue
Block a user