[package] update dovecot to 1.2.8 (#6264)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18648 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9e70391178
commit
b3cb7188d7
@ -8,19 +8,19 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dovecot
|
PKG_NAME:=dovecot
|
||||||
PKG_VERSION:=1.1.2
|
PKG_VERSION:=1.2.8
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.1
|
PKG_SOURCE_URL:=http://www.dovecot.org/releases/1.2
|
||||||
PKG_MD5SUM:=fcebb6c099421049632b2f1f019f55cd
|
PKG_MD5SUM:=c6d6c061413d299ccea7b55c3e4faa0a
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/dovecot
|
define Package/dovecot
|
||||||
SECTION:=mail
|
SECTION:=mail
|
||||||
CATEGORY:=Mail
|
CATEGORY:=Mail
|
||||||
DEPENDS:=+libopenssl +zlib
|
DEPENDS:=+libopenssl +librt
|
||||||
TITLE:=An IMAP and POP3 daemon
|
TITLE:=An IMAP and POP3 daemon
|
||||||
URL:=http://www.dovecot.org/
|
URL:=http://www.dovecot.org/
|
||||||
endef
|
endef
|
||||||
@ -53,7 +53,7 @@ define Build/Configure
|
|||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
all install
|
all install
|
||||||
@ -62,7 +62,7 @@ endef
|
|||||||
define Package/dovecot/install
|
define Package/dovecot/install
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
$(INSTALL_BIN) ./files/dovecot.init $(1)/etc/init.d/dovecot
|
$(INSTALL_BIN) ./files/dovecot.init $(1)/etc/init.d/dovecot
|
||||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/dovecot-example.conf $(1)/etc/dovecot.conf
|
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/dovecot-example.conf $(1)/etc/dovecot.conf
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/dovecot
|
$(INSTALL_DIR) $(1)/usr/lib/dovecot
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/dovecot/* $(1)/usr/lib/dovecot/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/dovecot/* $(1)/usr/lib/dovecot/
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- dovecot-1.1.2-orig/configure.in 2008-07-24 01:46:52.000000000 +0200
|
--- a/configure.in
|
||||||
+++ dovecot-1.1.2/configure.in 2008-07-29 15:46:47.000000000 +0200
|
+++ b/configure.in
|
||||||
@@ -473,9 +473,9 @@
|
@@ -398,9 +398,9 @@ have_ioloop=no
|
||||||
|
|
||||||
if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then
|
if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then
|
||||||
AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[
|
AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[
|
||||||
@ -12,3 +12,20 @@
|
|||||||
int main()
|
int main()
|
||||||
{
|
{
|
||||||
return epoll_create(5) < 1;
|
return epoll_create(5) < 1;
|
||||||
|
@@ -559,7 +559,7 @@ AC_TRY_COMPILE([
|
||||||
|
dnl * Old glibcs have broken posix_fallocate(). Make sure not to use it.
|
||||||
|
dnl * It may also be broken in AIX.
|
||||||
|
AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
|
||||||
|
- AC_TRY_RUN([
|
||||||
|
+ AC_TRY_LINK([
|
||||||
|
#define _XOPEN_SOURCE 600
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
@@ -568,6 +568,7 @@ AC_CACHE_CHECK([whether posix_fallocate(
|
||||||
|
#if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7)
|
||||||
|
possibly broken posix_fallocate
|
||||||
|
#endif
|
||||||
|
+ ], [
|
||||||
|
int main() {
|
||||||
|
int fd = creat("conftest.temp", 0600);
|
||||||
|
int ret;
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- dovecot-1.1.2-orig/dovecot-example.conf 2008-07-12 01:14:14.000000000 +0200
|
--- a/dovecot-example.conf
|
||||||
+++ dovecot-1.1.2/dovecot-example.conf 2008-07-29 21:16:02.000000000 +0200
|
+++ b/dovecot-example.conf
|
||||||
@@ -502,19 +502,19 @@
|
@@ -537,20 +537,20 @@
|
||||||
|
|
||||||
protocol imap {
|
protocol imap {
|
||||||
# Login executable location.
|
# Login executable location.
|
||||||
@ -10,9 +10,10 @@
|
|||||||
# IMAP executable location. Changing this allows you to execute other
|
# IMAP executable location. Changing this allows you to execute other
|
||||||
# binaries before the imap process is executed.
|
# binaries before the imap process is executed.
|
||||||
#
|
#
|
||||||
# This would write rawlogs into ~/dovecot.rawlog/ directory:
|
# This would write rawlogs into user's ~/dovecot.rawlog/, if it exists:
|
||||||
- # mail_executable = /usr/libexec/dovecot/rawlog /usr/libexec/dovecot/imap
|
- # mail_executable = /usr/libexec/dovecot/rawlog /usr/libexec/dovecot/imap
|
||||||
+ # mail_executable = /usr/lib/dovecot/rawlog /usr/lib/dovecot/imap
|
+ # mail_executable = /usr/lib/dovecot/rawlog /usr/lib/dovecot/imap
|
||||||
|
# <doc/wiki/Debugging/Rawlog.txt>
|
||||||
#
|
#
|
||||||
# This would attach gdb into the imap process and write backtraces into
|
# This would attach gdb into the imap process and write backtraces into
|
||||||
# /tmp/gdbhelper.* files:
|
# /tmp/gdbhelper.* files:
|
||||||
@ -24,7 +25,7 @@
|
|||||||
|
|
||||||
# Maximum IMAP command line length in bytes. Some clients generate very long
|
# Maximum IMAP command line length in bytes. Some clients generate very long
|
||||||
# command lines with huge mailboxes, so you may need to raise this if you get
|
# command lines with huge mailboxes, so you may need to raise this if you get
|
||||||
@@ -571,11 +571,11 @@
|
@@ -614,11 +614,11 @@ protocol imap {
|
||||||
|
|
||||||
protocol pop3 {
|
protocol pop3 {
|
||||||
# Login executable location.
|
# Login executable location.
|
||||||
@ -38,7 +39,7 @@
|
|||||||
|
|
||||||
# Don't try to set mails non-recent or seen with POP3 sessions. This is
|
# Don't try to set mails non-recent or seen with POP3 sessions. This is
|
||||||
# mostly intended to reduce disk I/O. With maildir it doesn't move files
|
# mostly intended to reduce disk I/O. With maildir it doesn't move files
|
||||||
@@ -692,7 +692,7 @@
|
@@ -743,7 +743,7 @@ protocol lda {
|
||||||
##
|
##
|
||||||
|
|
||||||
# Executable location
|
# Executable location
|
||||||
@ -47,16 +48,16 @@
|
|||||||
|
|
||||||
# Set max. process size in megabytes.
|
# Set max. process size in megabytes.
|
||||||
#auth_process_size = 256
|
#auth_process_size = 256
|
||||||
@@ -825,7 +825,7 @@
|
@@ -872,7 +872,7 @@ auth default {
|
||||||
# database (passwd usually), you can use static userdb.
|
# database (passwd usually), you can use static userdb.
|
||||||
# REMEMBER: You'll need /etc/pam.d/dovecot file created for PAM
|
# REMEMBER: You'll need /etc/pam.d/dovecot file created for PAM
|
||||||
# authentication to actually work. <doc/wiki/PasswordDatabase.PAM.txt>
|
# authentication to actually work. <doc/wiki/PasswordDatabase.PAM.txt>
|
||||||
- passdb pam {
|
- passdb pam {
|
||||||
+ #passdb pam {
|
+ #passdb pam {
|
||||||
# [session=yes] [setcred=yes] [failure_show_msg=yes]
|
# [session=yes] [setcred=yes] [failure_show_msg=yes] [max_requests=<n>]
|
||||||
# [cache_key=<key>] [<service name>]
|
# [cache_key=<key>] [<service name>]
|
||||||
#
|
#
|
||||||
@@ -854,15 +854,15 @@
|
@@ -905,15 +905,15 @@ auth default {
|
||||||
# args = session=yes %Ls
|
# args = session=yes %Ls
|
||||||
# args = cache_key=%u dovecot
|
# args = cache_key=%u dovecot
|
||||||
#args = dovecot
|
#args = dovecot
|
||||||
@ -75,12 +76,12 @@
|
|||||||
|
|
||||||
# Shadow passwords for system users (NSS, /etc/shadow or similiar).
|
# Shadow passwords for system users (NSS, /etc/shadow or similiar).
|
||||||
# Deprecated by PAM nowadays.
|
# Deprecated by PAM nowadays.
|
||||||
@@ -1129,7 +1129,7 @@
|
@@ -1192,7 +1192,7 @@ plugin {
|
||||||
# a dictionary so it can be quickly determined which mailboxes contain
|
# a dictionary so it can be quickly determined which mailboxes contain
|
||||||
# expired mails. The actual expunging is done in a nightly cronjob, which
|
# expired mails. The actual expunging is done in a nightly cronjob, which
|
||||||
# you must set up:
|
# you must set up:
|
||||||
- # dovecot --exec-mail ext /usr/libexec/dovecot/expire-tool
|
- # dovecot --exec-mail ext /usr/libexec/dovecot/expire-tool
|
||||||
+ # dovecot --exec-mail ext /usr/lib/dovecot/expire-tool
|
+ # dovecot --exec-mail ext /usr/lib/dovecot/expire-tool
|
||||||
#expire = Trash 7 Spam 30
|
#expire = Trash 7 Spam 30
|
||||||
#expire_dict = db:/var/lib/dovecot/expire.db
|
#expire_dict = proxy::expire
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user