Update opal to use ptlib instead of pwlib (closes ticket #2655)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9506 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
471c72833c
commit
b43802e4a7
@ -8,27 +8,28 @@
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=opal
|
||||
PKG_VERSION:=2.3.1
|
||||
PKG_NAME:=opal-snapshot
|
||||
PKG_VERSION:=18818
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://peternixon.net/pub/voxgratia
|
||||
PKG_MD5SUM:=5a9d7f060527885bed3a26324de6dcfc
|
||||
PKG_MD5SUM:=121b77a82f9a4eb289e2351d588185e9
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
# Set location of pwlib (Which needs to have been built already)
|
||||
PWLIBDIR=$(BUILD_DIR)/pwlib-1.11.1
|
||||
# Set location of ptlib (Which needs to have been built already)
|
||||
export PWLIBDIR=$(BUILD_DIR)/ptlib-snapshot
|
||||
export PTLIBDIR=$(BUILD_DIR)/ptlib-snapshot
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libopal
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+pwlib +uclibcxx
|
||||
DEPENDS:=+ptlib +uclibcxx
|
||||
TITLE:=Open Phone Abstraction Library
|
||||
URL:=http://www.voxgratia.org/
|
||||
URL:=http://www.opalvoip.org/
|
||||
endef
|
||||
|
||||
define Package/libopal/description
|
||||
@ -39,9 +40,17 @@ define Package/libopal/description
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-minsize \
|
||||
--enable-audio \
|
||||
--disable-video
|
||||
--disable-video \
|
||||
--enable-sip \
|
||||
--enable-h323 \
|
||||
--disable-iax \
|
||||
--disable-h224 \
|
||||
--disable-h450 \
|
||||
--disable-h460 \
|
||||
--disable-ivr \
|
||||
--disable-rfc4175 \
|
||||
--disable-versioncheck
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
|
||||
|
@ -1,78 +0,0 @@
|
||||
diff -u -r1.42 configure
|
||||
--- opal/configure 5 Aug 2007 22:34:08 -0000 1.42
|
||||
+++ opal/configure 6 Oct 2007 17:33:21 -0000
|
||||
@@ -2668,10 +2668,10 @@
|
||||
if eval "test \"\${$as_ac_File+set}\" = set"; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "${PWLIBDIR}/version.h"; then
|
||||
eval "$as_ac_File=yes"
|
||||
else
|
||||
@@ -2692,10 +2692,10 @@
|
||||
if eval "test \"\${$as_ac_File+set}\" = set"; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "${OPALDIR}/../pwlib/version.h"; then
|
||||
eval "$as_ac_File=yes"
|
||||
else
|
||||
@@ -2717,10 +2717,10 @@
|
||||
if eval "test \"\${$as_ac_File+set}\" = set"; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "${HOME}/pwlib/include/ptlib.h"; then
|
||||
eval "$as_ac_File=yes"
|
||||
else
|
||||
@@ -2741,10 +2741,10 @@
|
||||
if test "${ac_cv_file__usr_local_include_ptlib_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "/usr/local/include/ptlib.h"; then
|
||||
ac_cv_file__usr_local_include_ptlib_h=yes
|
||||
else
|
||||
@@ -2803,10 +2803,10 @@
|
||||
if test "${ac_cv_file__usr_include_ptlib_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "/usr/include/ptlib.h"; then
|
||||
ac_cv_file__usr_include_ptlib_h=yes
|
||||
else
|
Loading…
x
Reference in New Issue
Block a user