[packages] htop: update to 0.9, add upstream's r213 uClibc commit and use PKG_INSTALL

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24660 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
swalker 2010-12-18 03:19:51 +00:00
parent 725f30e728
commit b45978cef3
2 changed files with 57 additions and 4 deletions

View File

@ -8,14 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=htop
PKG_VERSION:=0.8.3
PKG_RELEASE:=2
PKG_VERSION:=0.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=5c9f093f9eaddf6e77aa6d54c2116d0c
PKG_MD5SUM:=7c5507f35f363f3f40183a2ba3c561f8
PKG_FIXUP:=libtool
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@ -39,7 +40,7 @@ CONFIGURE_VARS += \
define Package/htop/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
endef
$(eval $(call BuildPackage,htop))

View File

@ -0,0 +1,52 @@
--- a/CRT.c
+++ b/CRT.c
@@ -11,7 +11,9 @@ in the source distribution for its full
#include <signal.h>
#include <stdlib.h>
#include <stdbool.h>
+#ifdef HAVE_EXECINFO_H
#include <execinfo.h>
+#endif
#include "String.h"
@@ -125,12 +127,14 @@ static void CRT_handleSIGSEGV(int sgn) {
CRT_done();
#if __linux
fprintf(stderr, "\n\nhtop " VERSION " aborting. Please report bug at http://htop.sf.net\n");
- #else
- fprintf(stderr, "\n\nhtop " VERSION " aborting. Unsupported platform.\n");
- #endif
+ #ifdef HAVE_EXECINFO_H
size_t size = backtrace(backtraceArray, sizeof(backtraceArray));
fprintf(stderr, "Backtrace: \n");
backtrace_symbols_fd(backtraceArray, size, 2);
+ #endif
+ #else
+ fprintf(stderr, "\n\nhtop " VERSION " aborting. Unsupported platform.\n");
+ #endif
abort();
}
--- a/CRT.h
+++ b/CRT.h
@@ -14,7 +14,9 @@ in the source distribution for its full
#include <signal.h>
#include <stdlib.h>
#include <stdbool.h>
+#ifdef HAVE_EXECINFO_H
#include <execinfo.h>
+#endif
#include "String.h"
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,7 @@ AC_HEADER_STDC
AC_CHECK_HEADERS([stdlib.h string.h strings.h sys/param.h sys/time.h unistd.h curses.h],[:],[
missing_headers="$missing_headers $ac_header"
])
+AC_CHECK_HEADERS([execinfo.h],[:],[:])
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL