[packages] xtables-addons: the configure first calls "make kernelrelease" which then triggers a silentoldconfig of the tree

for the sole purpose of adding the localversion which is then stripped anyway. Let it call "make kernelversion" instead
which does not have such issues. This patch should fix #8535.


git-svn-id: svn://svn.openwrt.org/openwrt/packages@24920 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2011-01-06 09:57:53 +00:00
parent d4f8b0644a
commit b46883d13d

View File

@ -0,0 +1,22 @@
--- a/configure
+++ b/configure
@@ -10811,7 +10811,7 @@ if grep -q "CentOS release 5\." /etc/red
fi;
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking kernel version that we will build against" >&5
$as_echo_n "checking kernel version that we will build against... " >&6; }
-krel="$(make -sC ${kbuilddir} kernelrelease)";
+krel="$(make -sC ${kbuilddir} kernelversion)";
krel="${krel%%-*}";
kmajor="${krel%%.*}";
krel="${krel#*.}";
--- a/configure.ac
+++ b/configure.ac
@@ -49,7 +49,7 @@ if grep -q "CentOS release 5\." /etc/red
echo "WARNING: This distribution's shipped kernel is not supported.";
fi;
AC_MSG_CHECKING([kernel version that we will build against])
-krel="$(make -sC ${kbuilddir} kernelrelease)";
+krel="$(make -sC ${kbuilddir} kernelversion)";
krel="${krel%%-*}";
kmajor="${krel%%.*}";
krel="${krel#*.}";