[packages] libusb-1.0: update to 1.0.9, fix title & description, use PKG_INSTALL
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32495 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a67bc086dd
commit
b4829ab17c
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2010 OpenWrt.org
|
# Copyright (C) 2010-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,45 +8,49 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libusb-1.0
|
PKG_NAME:=libusb-1.0
|
||||||
PKG_VERSION:=1.0.8
|
PKG_VERSION:=1.0.9
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=libusb-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=libusb-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://downloads.sourceforge.net/project/libusb/libusb-1.0/libusb-$(PKG_VERSION)
|
PKG_SOURCE_URL:=@SF/libusb
|
||||||
PKG_MD5SUM:=37d34e6eaa69a4b645a19ff4ca63ceef
|
PKG_MD5SUM:=7f5a02375ad960d4e33a6dae7d63cfcb
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/libusb-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/libusb-$(PKG_VERSION)
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/libusb-1.0
|
define Package/libusb-1.0
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=libusb-1.0
|
TITLE:=A library for accessing Linux USB devices (non-legacy)
|
||||||
DEPENDS:=+libpthread +librt
|
DEPENDS:=+libpthread +librt
|
||||||
URL:=http://libusb.wiki.sourceforge.net/
|
URL:=http://libusb.wiki.sourceforge.net/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libusb-1.0/description
|
define Package/libusb-1.0/description
|
||||||
libusb-1.0
|
libusb is a C library that gives applications easy access to USB devices on
|
||||||
|
many different operating systems.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
TARGET_CFLAGS += $(FPIC)
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(MAKE) install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include/libusb-1.0
|
$(INSTALL_DIR) $(1)/usr/include/libusb-1.0
|
||||||
$(CP) $(PKG_BUILD_DIR)/libusb/libusb.h $(1)/usr/include/libusb-1.0/
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/include/libusb-1.0/libusb.h \
|
||||||
|
$(1)/usr/include/libusb-1.0/
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_BUILD_DIR)/libusb/.libs/libusb*.{a,so*} $(1)/usr/lib/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb*.{a,la,so*} $(1)/usr/lib/
|
||||||
$(CP) $(PKG_BUILD_DIR)/libusb/libusb*.la $(1)/usr/lib/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||||
$(CP) $(PKG_BUILD_DIR)/libusb*.pc $(1)/usr/lib/pkgconfig/
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libusb*.pc \
|
||||||
|
$(1)/usr/lib/pkgconfig/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libusb-1.0/install
|
define Package/libusb-1.0/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_BUILD_DIR)/libusb/.libs/libusb*.so* $(1)/usr/lib/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb*.so* $(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libusb-1.0))
|
$(eval $(call BuildPackage,libusb-1.0))
|
||||||
|
@ -12,8 +12,6 @@ Date: Thu Jan 27 06:39:16 2011 +0300
|
|||||||
|
|
||||||
Signed-off-by: Alexander Gordeev <lasaine@lvk.cs.msu.su>
|
Signed-off-by: Alexander Gordeev <lasaine@lvk.cs.msu.su>
|
||||||
|
|
||||||
diff --git a/libusb/io.c b/libusb/io.c
|
|
||||||
index 1379eb3..250b8dc 100644
|
|
||||||
--- a/libusb/io.c
|
--- a/libusb/io.c
|
||||||
+++ b/libusb/io.c
|
+++ b/libusb/io.c
|
||||||
@@ -20,6 +20,7 @@
|
@@ -20,6 +20,7 @@
|
||||||
@ -21,10 +19,10 @@ index 1379eb3..250b8dc 100644
|
|||||||
#include <config.h>
|
#include <config.h>
|
||||||
#include <errno.h>
|
#include <errno.h>
|
||||||
+#include <fcntl.h>
|
+#include <fcntl.h>
|
||||||
#include <poll.h>
|
|
||||||
#include <pthread.h>
|
|
||||||
#include <signal.h>
|
#include <signal.h>
|
||||||
@@ -1025,7 +1026,7 @@ int usbi_io_init(struct libusb_context *ctx)
|
#include <stdint.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
@@ -1072,7 +1073,7 @@ int usbi_io_init(struct libusb_context *
|
||||||
|
|
||||||
#ifdef USBI_TIMERFD_AVAILABLE
|
#ifdef USBI_TIMERFD_AVAILABLE
|
||||||
ctx->timerfd = timerfd_create(usbi_backend->get_timerfd_clockid(),
|
ctx->timerfd = timerfd_create(usbi_backend->get_timerfd_clockid(),
|
||||||
|
Loading…
x
Reference in New Issue
Block a user