[packages] tcpdump: Update to v4.0.0 (closes #5656)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@17210 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
acinonyx 2009-08-10 23:32:58 +00:00
parent ca456ede41
commit b4922c6f09
4 changed files with 28 additions and 24 deletions

View File

@ -8,15 +8,15 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=tcpdump PKG_NAME:=tcpdump
PKG_VERSION:=3.9.8 PKG_VERSION:=4.0.0
PKG_RELEASE:=3 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \ PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
http://ftp.gwdg.de/pub/misc/tcpdump/ \ http://ftp.gwdg.de/pub/misc/tcpdump/ \
http://www.at.tcpdump.org/ \ http://www.at.tcpdump.org/ \
http://www.br.tcpdump.org/ http://www.br.tcpdump.org/
PKG_MD5SUM:=c491a78c52fe73f1f7271aa5d8c6ab2e PKG_MD5SUM:=b22ca72890df2301d922c9f2d17867f9
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk

View File

@ -1,7 +1,6 @@
diff -urN tcpdump-3.9.8.orig/tcpdump.c tcpdump-3.9.8/tcpdump.c --- a/tcpdump.c
--- tcpdump-3.9.8.orig/tcpdump.c +++ b/tcpdump.c
+++ tcpdump-3.9.8/tcpdump.c @@ -826,20 +826,6 @@ main(int argc, char **argv)
@@ -765,20 +765,6 @@
error("invalid data link type %s", gndo->ndo_dltname); error("invalid data link type %s", gndo->ndo_dltname);
break; break;
@ -19,6 +18,6 @@ diff -urN tcpdump-3.9.8.orig/tcpdump.c tcpdump-3.9.8/tcpdump.c
- } - }
- break; - break;
-#endif -#endif
case 'Z': case 'z':
if (optarg) { if (optarg) {
username = strdup(optarg); zflag = strdup(optarg);

View File

@ -1,15 +1,6 @@
tcpdump explicitly checks for a static version of libpcap in --- a/configure
../libpcap-[0-9]*.[0-9]*(.[0-9]*)?([ab][0-9]*)? relative to its build dir +++ b/configure
if found, tcpdump is linked statically against this lib @@ -9280,26 +9280,6 @@ echo "${ECHO_T}Using $pfopen" >&6; }
The patch removes the check for the static lib and headers in this relative
location for tcpdump's configure script.
Index: tcpdump-3.9.8/configure
===================================================================
--- tcpdump-3.9.8.orig/configure 2007-09-25 19:16:50.000000000 -0700
+++ tcpdump-3.9.8/configure 2009-05-21 17:17:07.000000000 -0700
@@ -9278,26 +9278,6 @@
LIBS="$LIBS $pfopen" LIBS="$LIBS $pfopen"
fi fi
fi fi
@ -36,7 +27,7 @@ Index: tcpdump-3.9.8/configure
{ echo "$as_me:$LINENO: checking for main in -lpcap" >&5 { echo "$as_me:$LINENO: checking for main in -lpcap" >&5
echo $ECHO_N "checking for main in -lpcap... $ECHO_C" >&6; } echo $ECHO_N "checking for main in -lpcap... $ECHO_C" >&6; }
if test "${ac_cv_lib_pcap_main+set}" = set; then if test "${ac_cv_lib_pcap_main+set}" = set; then
@@ -9362,40 +9342,6 @@ @@ -9364,40 +9344,6 @@ fi
echo "$as_me: error: see the INSTALL doc for more info" >&2;} echo "$as_me: error: see the INSTALL doc for more info" >&2;}
{ (exit 1); exit 1; }; } { (exit 1); exit 1; }; }
fi fi

View File

@ -0,0 +1,14 @@
--- a/print-enc.c
+++ b/print-enc.c
@@ -77,9 +77,11 @@ enc_if_print(const struct pcap_pkthdr *h
case AF_INET:
ip_print(gndo, p, length);
break;
+#ifdef INET6
case AF_INET6:
ip6_print(p, length);
break;
+#endif /*INET6*/
}
out: