[packages] mrtg:
- don't patch configure, but use autoreconf instead - remove extra CFLAGS and LDFLAGS, they're unneeded after recent toolchain rework - set PKG_REVISION - wrap long DEPENDS line git-svn-id: svn://svn.openwrt.org/openwrt/packages@29812 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d9aacad19a
commit
b50e0b1a74
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2011 OpenWrt.org
|
# Copyright (C) 2011-2012 OpenWrt.org
|
||||||
# Copyright (C) 2011 Paolo Pisati <p.pisati@gmail.com>
|
# Copyright (C) 2011 Paolo Pisati <p.pisati@gmail.com>
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
@ -10,20 +10,26 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=mrtg
|
PKG_NAME:=mrtg
|
||||||
PKG_VERSION:=2.17.3
|
PKG_VERSION:=2.17.3
|
||||||
PKG_RELEASE:=
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://oss.oetiker.ch/mrtg/pub/
|
PKG_SOURCE_URL:=http://oss.oetiker.ch/mrtg/pub/
|
||||||
PKG_MD5SUM:=c803f671d04367ee719039ea71fb5b37
|
PKG_MD5SUM:=c803f671d04367ee719039ea71fb5b37
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
PKG_FIXUP:=autoreconf
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/mrtg
|
define Package/mrtg
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
DEPENDS:=+libgd +libpng +zlib +perl +perlbase-essential +perlbase-findbin +perlbase-cwd +perlbase-config +perlbase-file +perlbase-getopt +perlbase-math +perlbase-integer +perlbase-xsloader +perlbase-pod +perlbase-universal +perlbase-socket +perlbase-posix +perlbase-autoloader +perlbase-fcntl +perlbase-tie +perlbase-io +perlbase-symbol +perlbase-selectsaver +perlbase-errno
|
DEPENDS:=+libgd +libpng +zlib +perl +perlbase-essential +perlbase-findbin \
|
||||||
|
+perlbase-cwd +perlbase-config +perlbase-file +perlbase-getopt \
|
||||||
|
+perlbase-math +perlbase-integer +perlbase-xsloader +perlbase-pod \
|
||||||
|
+perlbase-universal +perlbase-socket +perlbase-posix +perlbase-autoloader \
|
||||||
|
+perlbase-fcntl +perlbase-tie +perlbase-io +perlbase-symbol \
|
||||||
|
+perlbase-selectsaver +perlbase-errno
|
||||||
TITLE:=The Multi Router Traffic Grapher
|
TITLE:=The Multi Router Traffic Grapher
|
||||||
URL:=http://oss.oetiker.ch/mrtg/index.en.html
|
URL:=http://oss.oetiker.ch/mrtg/index.en.html
|
||||||
endef
|
endef
|
||||||
@ -37,9 +43,6 @@ define Package/mrtg/description
|
|||||||
for almost anything.
|
for almost anything.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
EXTRA_CFLAGS+= $(TARGET_CPPFLAGS)
|
|
||||||
EXTRA_LDFLAGS+= $(TARGET_LDFLAGS) -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
|
|
||||||
|
|
||||||
define Package/mrtg/install
|
define Package/mrtg/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
||||||
|
@ -48,66 +48,3 @@
|
|||||||
dnl Checks for libraries.
|
dnl Checks for libraries.
|
||||||
AC_CHECK_LIB(m, pow, [ MATHLIBS="-lm" ])
|
AC_CHECK_LIB(m, pow, [ MATHLIBS="-lm" ])
|
||||||
|
|
||||||
--- mrtg-2.17.3.orig/configure 2011-12-26 00:02:43.178539074 +0100
|
|
||||||
+++ mrtg-2.17.3/configure 2011-12-26 00:04:09.056241468 +0100
|
|
||||||
@@ -3609,60 +3609,6 @@
|
|
||||||
done
|
|
||||||
|
|
||||||
|
|
||||||
-# Taken from libIDL-0.8.2
|
|
||||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for printf long long format specifier" >&5
|
|
||||||
-$as_echo_n "checking for printf long long format specifier... " >&6; }
|
|
||||||
-if test "${long_long_format_specifier+set}" = set; then :
|
|
||||||
- $as_echo_n "(cached) " >&6
|
|
||||||
-else
|
|
||||||
-
|
|
||||||
- for format in ll l q I64; do
|
|
||||||
- if test "$cross_compiling" = yes; then :
|
|
||||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
|
||||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
|
||||||
-as_fn_error $? "cannot run test program while cross compiling
|
|
||||||
-See \`config.log' for more details" "$LINENO" 5 ; }
|
|
||||||
-else
|
|
||||||
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
||||||
-/* end confdefs.h. */
|
|
||||||
-#include <stdio.h>
|
|
||||||
- int main()
|
|
||||||
- {
|
|
||||||
- long long b, a = -0x3AFAFAFAFAFAFAFALL;
|
|
||||||
- char buffer[1000];
|
|
||||||
- sprintf (buffer, "%${format}u", a);
|
|
||||||
- sscanf (buffer, "%${format}u", &b);
|
|
||||||
- exit (b!=a);
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
-_ACEOF
|
|
||||||
-if ac_fn_c_try_run "$LINENO"; then :
|
|
||||||
- long_long_format_specifier="%${format}d"
|
|
||||||
- long_long_format="${format}d"
|
|
||||||
- break
|
|
||||||
-fi
|
|
||||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext \
|
|
||||||
- conftest.$ac_objext conftest.beam conftest.$ac_ext
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
- done
|
|
||||||
-fi
|
|
||||||
-
|
|
||||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $long_long_format_specifier" >&5
|
|
||||||
-$as_echo "$long_long_format_specifier" >&6; }
|
|
||||||
-
|
|
||||||
-cat >>confdefs.h <<_ACEOF
|
|
||||||
-#define LLD "$long_long_format_specifier"
|
|
||||||
-_ACEOF
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-cat >>confdefs.h <<_ACEOF
|
|
||||||
-#define LLD_FORMAT "$long_long_format"
|
|
||||||
-_ACEOF
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-
|
|
||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for pow in -lm" >&5
|
|
||||||
$as_echo_n "checking for pow in -lm... " >&6; }
|
|
||||||
if test "${ac_cv_lib_m_pow+set}" = set; then :
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user