updated with zeromq-2.1.9
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28145 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5175042541
commit
b5a776791b
@ -16,7 +16,7 @@ PKG_RELEASE:=1
|
||||
#
|
||||
# The latest FS git hash in PKG_REV can be obtained from http://fisheye.freeswitch.org
|
||||
#
|
||||
PKG_REV:=f697e5aa37e0aae56ce7d07ce74080fe809ddf25
|
||||
PKG_REV:=cf9859ea6959699260ef928d2b9fb79f9f0c3389
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
|
||||
@ -384,7 +384,7 @@ endif
|
||||
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_$(PKG_NAME)-mod-event-zmq),)
|
||||
$(eval $(call Download/files,event-zmq,zeromq-2.1.7.tar.gz,7d3120f8a8fb913a7e55c57c6eb024f3,http://download.zeromq.org,,libs/))
|
||||
$(eval $(call Download/files,event-zmq,zeromq-2.1.9.tar.gz,94c5e0262a79c5f82bc0b178c1f8a33d,http://download.zeromq.org,,libs/))
|
||||
endif
|
||||
|
||||
|
||||
|
@ -15,19 +15,19 @@
|
||||
fs_encode_CFLAGS = $(AM_CFLAGS)
|
||||
-fs_encode_LDFLAGS = $(AM_LDFLAGS) $(CORE_LIBS)
|
||||
+fs_encode_LDFLAGS = $(AM_LDFLAGS) -lpthread $(CORE_LIBS)
|
||||
fs_encode_LDADD = libfreeswitch.la
|
||||
fs_encode_LDADD = libfreeswitch.la -lcrypt -lrt
|
||||
|
||||
##
|
||||
@@ -307,7 +312,7 @@ fs_encode_LDADD = libfreeswitch.la
|
||||
@@ -307,7 +312,7 @@ fs_encode_LDADD = libfreeswitch.la -lcry
|
||||
##
|
||||
tone2wav_SOURCES = src/tone2wav.c
|
||||
tone2wav_CFLAGS = $(AM_CFLAGS)
|
||||
-tone2wav_LDFLAGS = $(AM_LDFLAGS) $(CORE_LIBS)
|
||||
+tone2wav_LDFLAGS = $(AM_LDFLAGS) -lpthread $(CORE_LIBS)
|
||||
tone2wav_LDADD = libfreeswitch.la
|
||||
tone2wav_LDADD = libfreeswitch.la -lcrypt -lrt
|
||||
|
||||
##
|
||||
@@ -585,10 +590,13 @@ speex-reconf:
|
||||
@@ -586,10 +591,13 @@ speex-reconf:
|
||||
|
||||
tiff-reconf:
|
||||
cd libs/tiff-3.8.2 && autoreconf -fi
|
||||
@ -44,7 +44,7 @@
|
||||
|
||||
python-reconf:
|
||||
rm -f src/mod/languages/mod_python/Makefile
|
||||
@@ -611,12 +619,6 @@ iks-reconf:
|
||||
@@ -612,12 +620,6 @@ iks-reconf:
|
||||
cd libs/iksemel && sh ./configure.gnu --prefix=$(prefix)
|
||||
$(MAKE) mod_dingaling-clean
|
||||
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- a/libs/esl/Makefile
|
||||
+++ b/libs/esl/Makefile
|
||||
@@ -7,7 +7,7 @@ PICKY=-O2 -ffast-math -Wall -Werror -Wun
|
||||
@@ -7,7 +7,7 @@ PICKY=-O2
|
||||
CFLAGS=$(BASE_FLAGS) $(PICKY)
|
||||
CXXFLAGS=$(BASE_FLAGS) -Wall -Werror -Wno-unused-variable
|
||||
CXXFLAGS=$(BASE_FLAGS)
|
||||
MYLIB=libesl.a
|
||||
-LIBS=-lncurses -lpthread -lesl -lm
|
||||
+LIBS=-L$(STAGING_DIR)/usr/lib -lncurses -lpthread -lesl -lm
|
||||
-LIBS=-lncurses -lesl -lpthread -lm
|
||||
+LIBS=-L$(STAGING_DIR)/usr/lib -lncurses -lesl -lpthread -lm
|
||||
LDFLAGS=-L.
|
||||
OBJS=src/esl.o src/esl_event.o src/esl_threadmutex.o src/esl_config.o src/esl_json.o src/esl_buffer.o
|
||||
SRC=src/esl.c src/esl_json.c src/esl_event.c src/esl_threadmutex.c src/esl_config.c src/esl_oop.cpp src/esl_json.c src/esl_buffer.c
|
||||
|
Loading…
x
Reference in New Issue
Block a user